LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Unable to connect to Internet Dongle (http://www.linuxquestions.org/questions/linux-hardware-18/unable-to-connect-to-internet-dongle-906744/)

radiosgalore 10-06-2011 08:53 AM

Unable to connect to Internet Dongle
 
OK i'll try to explain this clearly. I have a T-Mobile Dongle I recently got and it simply won't work. I tried ejecting it. I've entered the connection info in manually such as APN etc however its when i go to the terminal that it gets interesting. I know very little about the command line but i get the following

sudo wvdialconf
Found an USB modem on /dev/ttyACM0.
Modem configuration written to /etc/wvdial.conf.
ttyACM0<Info>: Speed 460800; init "ATQ0 V1 E1 S0=0 &C1 &D2"
ttyACM1<Info>: Speed 460800; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"
ttyACM1A<Info>: Speed 460800; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"

we see it finds the modem then the key part of the next command...

GNOME PPP: STDERR: ttyACM0<Info>: Device or resource busy
GNOME PPP: STDERR: Modem Port Scan<*1>: ACM0
GNOME PPP: STDERR: ttyACM1<Info>: Device or resource busy
GNOME PPP: STDERR: Modem Port Scan<*1>: ACM1
GNOME PPP: STDERR: ttyACM1A<Info>: Device or resource busy

i hit right click and ejected the thing so whats it busy with? Lastly I enter

sudo lsof /dev/ttyAMC1
lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/guest/.gvfs
Output information may be incomplete.
lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/andrew/.gvfs
Output information may be incomplete.

This last i believe should have told me what why the device was busy but what I got is total gibberish to me. I've asked on several forums and have gotten no usable information. I would be grateful if a resolution to this could be found

*using latest Mint Distro*

business_kid 10-06-2011 01:50 PM

Sounds like a resource conflict. I think it's seeing the modem on ttyACM0, ttyACM1 & ttyACM1A. It's a serial device, and you only want it once. Take a few entries out of the wvdial config.

radiosgalore 10-06-2011 02:58 PM

Quote:

Originally Posted by business_kid (Post 4491778)
Sounds like a resource conflict. I think it's seeing the modem on ttyACM0, ttyACM1 & ttyACM1A. It's a serial device, and you only want it once. Take a few entries out of the wvdial config.

trouble is thats whats in /dev. if its anything like a windows BIOS i don't dare start messing in that. And what do i leave? ttyACM0 maybe? i'm too new at this to have much of an idea if i'm honest

well i opened wvdial.conf and get

[Dialer Defaults]
Modem = /dev/ttyACM0
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Stupid Mode = 1
Modem Type = USB Modem
Phone = *99#
New PPPD = yes
ISDN = 0
Username = user
Password = user
Baud = 460800

[Dialer TMobile]
Init2 = ATZ
Init3 = ATQ0 V1 &D2 &C1 S0=0 +IFC=2,2
Init5 = AT+CGDCONT=1,”IP”,”general.t-mobile.uk”
ISDN = 0
Modem = /dev/ttyATC1
Modem Type = Analog Modem
Baud = 460800

the latter looks more accurate but the first was the default setting.

Knightron 10-06-2011 03:39 PM

how are you trying to connect? have you tried gnome network manager applet

radiosgalore 10-06-2011 04:35 PM

Quote:

Originally Posted by Knightron (Post 4491850)
how are you trying to connect? have you tried gnome network manager applet

you mean via gnone-ppp? yep. done that and via the little icon on my taskbar. Best bet is to resolve this conflict issue but i'm not sure where to sort that out. the command line throws up that strange error message I posted

Knightron 10-06-2011 06:43 PM

via ppp? with your dongle plugged in, if you right click that applet (if this is in linux mint, left click), select edit conections and in the window that comes up there should b a mobilebroadband tab, select it and then press the add connection button and follow the steps.

business_kid 10-07-2011 01:51 AM

Quote:

Originally Posted by radiosgalore (Post 4491831)
trouble is thats whats in /dev. if its anything like a windows BIOS i don't dare start messing in that. And what do i leave? ttyACM0 maybe? i'm too new at this to have much of an idea if i'm honest

well i opened wvdial.conf and get

[Dialer Defaults]
Modem = /dev/ttyACM0
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Stupid Mode = 1
Modem Type = USB Modem
Phone = *99#
New PPPD = yes
ISDN = 0
Username = user
Password = user
Baud = 460800

[Dialer TMobile]
Init2 = ATZ
Init3 = ATQ0 V1 &D2 &C1 S0=0 +IFC=2,2
Init5 = AT+CGDCONT=1,”IP”,”general.t-mobile.uk”
ISDN = 0
Modem = /dev/ttyATC1
Modem Type = Analog Modem
Baud = 460800

the latter looks more accurate but the first was the default setting.

That looks fairly good. Change the wvdial.conf to /dev/ttyATC0, and in udev just leave ttyATC0. Save out the rules, in case you need them. I also don't like the 'new pppd' line, because that is probably telling it to start a new instance regardless, which you only need if you have several modems.

wabbalee 10-07-2011 11:14 PM

I am no expert on cli, but I have a nokia C5 mobile phone that has a built in modem that I am using all the time, I recently discovered that setting it (under connectivity options for usb) to 'pc suite' mode, which will in windows start whatever software is wrtten for it, In Ubuntu it now just connects as soon as i plug it in; username and password are stored in the phone. before this discovery, i had it set to 'connect pc to web' mode and needed to start xp in virtual box and get it to connect there first, then disconnect and Ubuntu would then use it. a work around you could say. But like I said before setting it to 'pc suite' mode eliminated all this agony and windows pain, there is even a little proggie called 'S60 remote' or something that enables me (while in 'bluetooth' mode) to do the same things as in its windos equivalent software from nokia where it allows you to synchronise, send and receive sms messages and what not. A little irrelevant may be, but the bottom line is that it works seem less now under kde and XFCE (i don't use Gnome so much)

hope this was some what helpful.

kind regards
Ron


All times are GMT -5. The time now is 05:08 AM.