LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-15-2004, 05:43 PM   #1
tamills
LQ Newbie
 
Registered: May 2004
Location: Southern Indiana, USA
Distribution: Ubuntu, SUSE, Mandrake
Posts: 8

Rep: Reputation: 0
udev and 51 sound devices!


First, my config quickly. 900Mhz Athlon, 700+mb, SB Live!, Nvidia Ti-4200.
Running Debian-Sarge and 2.6.5 kernel.

Second this is a sound question but I have sound working. Woo-Hoo!

BUT: I'm trying to be proactive and use udev. But I think maybe udev gave me a few too many devices. If I start up alsamixergui, I see 4 headphones, 4 wav controls, 10 EMU PCM, 2 PCM, 8 IEC598s (what the heck is that???) and just a bunch of stuff on my mixer control. WHY?!! Most of them don't do anything.

Understand, in many ways I'm flying blind. Or maybe blind bull in a chinashop is better. I'm charging in with all kinds of apt-get goodness, not really knowing what I'm getting. I'm pretty handy with Linux, but there's an awful lot to keep track of. So could somone explain a little about whats happening?

Also, I just assumed that somehow udev was creating all these devices that the mixer is trying to control. Maybe that isn't true?

Any help would be appreciated.

Drew
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Udev & devices trouble Macky Slackware 1 12-01-2005 02:11 PM
udev killed my sound! noxious Slackware 1 07-20-2005 12:31 AM
UDEV and Raw devices swissworks Slackware 6 09-14-2004 01:08 PM
sysfs and udev lost my cdrom devices cexshun Linux - Hardware 0 09-11-2004 06:23 PM
Help! udev created 51 sound devices! tamills Debian 2 05-17-2004 09:07 AM


All times are GMT -5. The time now is 07:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration