LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 04-18-2013, 07:48 PM   #16
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199

A few things I see in the logs and configs.
1.
nvidia-xconfig: version 295.40 is very old, may cause an ABI mismatch during compilation, update to 313.30 asap.

2.
remove "quiet splash" from kernel cli, so you can see errors....

3.
append to the end of the line "nokmsboot vga=791 3" without the quotes. legend, nokmsboot(kernel module loading service, not for proprietary ati and nvidia driver modules. vga=791, (must remove splash and quiet, text mode 1024x768x16bit) 3 is boot to runlevel 3 (don't try to load the gui-xserver)

4.
the question is for noobs, this will reverse your custom work in no time flat! Ignore it.

Now, you got all that? try again from the beginning,

Oh yeah, make sure you have kernel-devel installed for your running kernel version.

Last edited by GlennsPref; 04-18-2013 at 08:28 PM. Reason: spelling
 
Old 04-18-2013, 08:20 PM   #17
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,509
Blog Entries: 2

Rep: Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018Reputation: 4018
Quote:
Originally Posted by GlennsPref View Post
3 is boot to runlevel 3 (don't try to load the gui-xserver)
This does not work on Debian based distributions, like Ubuntu, on those distribution runlevels 2-5 are the same.
 
Old 04-18-2013, 08:26 PM   #18
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
OK, Thanks tobi(I'm using Mageia) then it should be 1, for runlevel 1. (0,1,5,6)

also, diff... xorg does not contain this section (and is missing fonts) Load "glx"
Code:
Section "Module"
    Disable "dri"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "glx" # 3D layer
EndSection
X Config Options
regards glenn
 
Old 04-19-2013, 01:37 AM   #19
shakira19
Member
 
Registered: Sep 2012
Posts: 34

Original Poster
Rep: Reputation: Disabled
So in the end, after this expert conversation, could you please give step by step newbie details as to what I am to attempt ?
 
Old 04-19-2013, 01:56 AM   #20
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
Yes, but it will take a little while to write. all the info is above, brb...
 
Old 04-19-2013, 08:01 PM   #21
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
check for and if not, download and install kenel-latest

check for and if not, download and install kernel-devel-latest

download nvidia-313.30 > gfx 680 gt (for later)

set blacklist nouveau

reboot

pause at the grub menue screen, F3, then ESC to drop out of that dialogue.

use the arrow keys to navigate along that (current) command-line

remove any terms, "silent", "quiet", "splash", "vga=..." (without quotes (""), grub uses a space separated list)

add these terms to the line, "nokmsboot" "vga=794" "1"

now boot.

this should get you to runlevel 1 on your .deb system. command interface shell.

now login as root or if you have sudo setup, login as usuall. don't try to start X! yet.

type, lsmod | grep nouveau (should have no answer),

but if it is there, reboot with ctrl-alt-del.

repeat the boot process as above. and check again for the module.

type, lsmod | grep nouveau (should have no answer),

if the module is still loaded, we'll try one more term in the grub cli,

video=vesa (maybe vesafb on some systems)

once again, check if the module is loaded

Hopefully it's gone by now. ;-)

cd to the directory you saved the nvidia .run file to...type,

sh NVIDIA-Linux-x86_64-313.30.run --ui=none -a

legend, --ui=none (plain text installer) -a (answer yes to licence)

reboot using the same grub line as was used last.

back at the cli, login and check if the module is loaded.

type lsmod | grep nvidia

if so, check your xorg.conf file for the nvidia listing in the driver section.

if all goood, or you edit it, save and (logged in as normal user) and type

startx

vga=794 (for cli text)
Code:
	640x480 800x600 1024x768 1280x1024 1600x1200 Ask user at boot
8 bits 	vga=769 vga=771 vga=773  vga=775   vga=796   vga=ask
16 bits vga=785 vga=788 vga=791  vga=794   vga=798   vga=ask
32 bits vga=786 vga=789 vga=792  vga=795   vga=799   vga=ask
eventually, your grub line will need nokmsboot while using this nvidia driver.

see how you go.

regards Glenn

ps, you may or may not require this section in your xorg.conf. (but I may be wrong)
https://www.linuxquestions.org/quest...ml#post4934462

check with a gui, type
Code:
glxinfo | grep render
should give some graphics card info as well as nvidia.

Last edited by GlennsPref; 04-19-2013 at 08:21 PM. Reason: glx and glxinfo
 
Old 05-02-2013, 04:59 PM   #22
shakira19
Member
 
Registered: Sep 2012
Posts: 34

Original Poster
Rep: Reputation: Disabled
I've been reading this last post on and off for almost two weeks now, but there's no way I'm going to be able to do all that on my own. I'm just a regular user, and even though I quite like linux, I'm not even close to understanding half of what is written there.

I'd just like to go baby steps at a time to make sure I'm not missing anything.
So first step:
What is kernel-latest and kernel-dev-latest ? If I do apt-get install these, I don't get anything.
 
Old 05-02-2013, 08:15 PM   #23
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
I'm sorry I am not more help with your distro commands, as I use Mageia.

you may find some usefull info here.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu 10.10 on Vostro 3300 - graphic card not recognised. dardamavet Linux - Laptop and Netbook 2 04-25-2011 08:59 AM
Ubuntu 9.04 - Nvidia Graphic card Dreamer801 Linux - Newbie 3 06-28-2009 10:22 AM
Bash Command for graphic card (Ubuntu) Mate de Vita Linux - Newbie 2 09-21-2008 07:24 AM
ati graphic card with ubuntu ultimate gamers in2media Ubuntu 1 04-20-2008 11:51 PM
s3 64mp2 pci graphic card detection error D3javu Linux - Hardware 0 02-15-2006 01:37 AM


All times are GMT -5. The time now is 03:34 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration