LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Ubuntu doesn't close properly (http://www.linuxquestions.org/questions/linux-hardware-18/ubuntu-doesnt-close-properly-684751/)

Pazau 11-19-2008 08:32 PM

Ubuntu doesn't close properly
 
Hello everyone.

I installed Ubuntu 8.10, and it works as it should be - except for one thing. The shutter is not properly.

When I put Ubuntu to switch off, then go down the line as it should, but when the hard drive is off and the computer is going to turn off completely, so it stays lit. It shuts off only when I press any key on the keyboard, and it annoys me.

However, it is not always to do it, but it is only rarely that it turns off completely. I can solve the problem temporarily by taking out the battery and plugging it back until the problem occurs again a little while after.

My laptop is an HP dv6645eo.

What can the problem is and how do I remedy this?

malan_in 11-19-2008 10:45 PM

Linux - Hardware - ubuntu
 
Hi,
check with the hardware compatibility. Or check the updates are installed correctly.

tommcd 11-20-2008 10:00 AM

Boot Ubuntu to recovery mode. From recovery mode, choose "drop to root shell" from the menu that comes up. Then run:
Code:

shutdown -h now
If the laptop shuts down properly, then it may be an ACPI problem. If it shuts down ok from recovery mode, do this from a normal boot:
1. Back up your grub menu.lst:
Code:

sudo cp /boot/grub/menu.lst /boot/grub/menu.lst.bak
gksudo gedit /boot/grub/menu.lst

Scroll down to the ###End Default Options### section. Then add acpi=force to the kernel line for booting Ubuntu. Save the file and exit. Then reboot and see if that fixes the shutdown problem.

Pazau 11-20-2008 11:23 AM

Now I believe that it is an ACPI problem. I have stopped Powernowd, because otherwise the CPU running at paltry 800mhz.

Could it have anything to do with it?
I'm not sure it with GRUB list, think of if the computer can not start up, what do I do?

Pazau 11-22-2008 07:14 PM

Can you make a screenshot of the outcome, so I can see exactly how I should do?

tommcd 11-23-2008 04:32 AM

Quote:

Originally Posted by Pazau (Post 3348793)
Now I believe that it is an ACPI problem. I have stopped Powernowd, because otherwise the CPU running at paltry 800mhz.

Could it have anything to do with it?
I'm not sure it with GRUB list, think of if the computer can not start up, what do I do?

Did disabling powernowd fix the shutdown problem?

Adding acpi=force to the kernel line in grub's menu.lst would not prevent the system from starting up. If you first back up menu.lst before editing it like I showed in my last post, you can always restore the original menu.lst if something goes wrong.

Suppose you messed up menu.lst while editing it so that Ubuntu would not boot. To restore the original menu.lst, you can boot from the Ubuntu live CD, mount your Ubuntu partition, and replace the backed up menu.lst. For example, suppose Ubuntu is on /dev/sda2. You would do this from the Ubuntu live CD:
Code:

sudo mount /dev/sda2 /mnt
sudo cp /mnt/boot/grub/menu.lst.bak /mnt/boot/grub/menu.lst

Then save the file and close gedit. Then reboot and grub will be back the way it was before you messed it up.
If you don't know what partition Ubuntu is on look at /etc/fstab. The partition that has the mount point as / (for root) is your Ubuntu root partition.
I always back up any configuration file first before editing it for this reason.

tommcd 11-23-2008 04:51 AM

Quote:

Originally Posted by Pazau (Post 3351326)
Can you make a screenshot of the outcome, so I can see exactly how I should do?

Here is how you would add acpi=force to the kernel line for booting Ubuntu. Run gksudo gedit /boot/grub/menu.lst from terminal. Scroll down to the section ## ## End Default Options ##. The entries for booting Ubuntu are below that. There is an entry for booting Ubuntu, plus an entry for booting to recovery mode, for each kernel that you have. Here is the entry for booting Ubuntu from my menu.lst:
Code:

title                Ubuntu 8.10, kernel 2.6.27-7-generic
uuid                eedd9a75-b5ef-4490-9e47-e7fe9fda82f1
kernel                /boot/vmlinuz-2.6.27-7-generic root=UUID=eedd9a75-b5ef-4490-9e47-e7fe9fda82f1 ro 
initrd                /boot/initrd.img-2.6.27-7-generic
quiet

To add acpi=force I would change the kernel line like this (changes in bold type):
Code:

title                Ubuntu 8.10, kernel 2.6.27-7-generic
uuid                eedd9a75-b5ef-4490-9e47-e7fe9fda82f1
kernel                /boot/vmlinuz-2.6.27-7-generic root=UUID=eedd9a75-b5ef-4490-9e47-e7fe9fda82f1 ro acpi=force
initrd                /boot/initrd.img-2.6.27-7-generic
quiet

Then save the file and exit. Then reboot. If it don't work you can just edit menu.lst again and remove acpi=force.
You only need to add acpi=force to the first entry in grub for booting Ubuntu. Don't worry about the entries below that for older kernels you may have.

Pazau 11-23-2008 06:29 AM

Now, I have again made the command "shutdown-h now" in recovery mode, and then it was off the disk, which said:

Will now halt: Could't not iterate IDE / ATA devices. (there was also something else but can not remember exactly what was written, but it had something to do with the HDD)

But acpi=force works, the only one who would have been nice to boot graphics still appear, and it does not. Is there a way to turn it on?

Pazau 11-23-2008 07:38 AM

When I disabled Powernowd that was just the system faster. It did not resolve my problem.
Now I would like to have restored GRUB from the .bak file, but I can not doubleclick on the .bak file.
How I restore the GRUB list without making use of Live-CD?

tommcd 11-23-2008 11:36 PM

Quote:

Originally Posted by Pazau (Post 3351728)
But acpi=force works,

Do you mean it fixes the shutdown problem? Or do you just mean that the system boots with acpi=force added to the kernel line in menu.lst? If it fixes the shutddown problem just leave it the way it is.

Quote:

Originally Posted by Pazau (Post 3351728)
the only one who would have been nice to boot graphics still appear, and it does not. Is there a way to turn it on?

I'm not sure what you mean by that. What graphics are you talking about?

tommcd 11-23-2008 11:47 PM

Quote:

Originally Posted by Pazau (Post 3351776)
Now I would like to have restored GRUB from the .bak file, but I can not doubleclick on the .bak file.
How I restore the GRUB list without making use of Live-CD?

You could just edit menu.lst again and remove the acpi=force that you added to the kernel line.

If you backed up your menu.lst like this:
Code:

sudo cp /boot/grub/menu.lst /boot/grub/menu.lst.bak
then to restore the original menu.lst from the .bak file just do this:
Code:

sudo cp -i /boot/grub/menu.lst.bak /boot/grub/menu.lst
The -i switch added to the cp command is for interactive. It will ask you to confirm overwriting menu.lst. Just answer y for yes to confirm and this will restore menu.lst from the .bak file.

The "-i" switch is optional. It is a good safety feature because it asks you to confirm the overwrite, so you don't accidentally overwrite the wrong file. This is unlikely in this case, but in other cases many files have similar names, so a typo could accidentally overwrite the wrong file.

Pazau 11-24-2008 09:43 AM

Thanks a lot! My computer works properly now. :)

Pazau 11-24-2008 02:02 PM

I thought to completely disable ACPI from, because this is what was the problem.
http://ubuntuforums.org/showthread.php?t=89491

The top two services had I intend to turn off. Will it work better?

Pazau 11-24-2008 04:58 PM

The problem now is back.

When I shut down Ubuntu, it's not always that there are ACPI Exiting. But when it does it come Power Down message not before I press any key.

What can the problem is due?
Dansk

»
Engelsk

Oversæt

SqdnGuns 11-24-2008 06:05 PM

Quote:

Originally Posted by Pazau (Post 3353178)
The problem now is back.

When I shut down Ubuntu, it's not always that there are ACPI Exiting. But when it does it come Power Down message not before I press any key.

What can the problem is due?
Dansk

»
Engelsk

Oversæt

Bet you got an update from Ubombtu that made the changes.........they know how your box should run. <sarcasm>


All times are GMT -5. The time now is 12:39 PM.