LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-19-2008, 07:32 PM   #1
Pazau
Member
 
Registered: Nov 2008
Location: Copenhagen, Denmark
Distribution: Ubuntu and Xubuntu 8.10
Posts: 98

Rep: Reputation: 15
Exclamation Ubuntu doesn't close properly


Hello everyone.

I installed Ubuntu 8.10, and it works as it should be - except for one thing. The shutter is not properly.

When I put Ubuntu to switch off, then go down the line as it should, but when the hard drive is off and the computer is going to turn off completely, so it stays lit. It shuts off only when I press any key on the keyboard, and it annoys me.

However, it is not always to do it, but it is only rarely that it turns off completely. I can solve the problem temporarily by taking out the battery and plugging it back until the problem occurs again a little while after.

My laptop is an HP dv6645eo.

What can the problem is and how do I remedy this?
 
Old 11-19-2008, 09:45 PM   #2
malan_in
LQ Newbie
 
Registered: Sep 2007
Distribution: redhat, debian, suse, fedora, ubuntu
Posts: 18

Rep: Reputation: 0
Linux - Hardware - ubuntu

Hi,
check with the hardware compatibility. Or check the updates are installed correctly.
 
Old 11-20-2008, 09:00 AM   #3
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,229

Rep: Reputation: 286Reputation: 286Reputation: 286
Boot Ubuntu to recovery mode. From recovery mode, choose "drop to root shell" from the menu that comes up. Then run:
Code:
shutdown -h now
If the laptop shuts down properly, then it may be an ACPI problem. If it shuts down ok from recovery mode, do this from a normal boot:
1. Back up your grub menu.lst:
Code:
sudo cp /boot/grub/menu.lst /boot/grub/menu.lst.bak
gksudo gedit /boot/grub/menu.lst
Scroll down to the ###End Default Options### section. Then add acpi=force to the kernel line for booting Ubuntu. Save the file and exit. Then reboot and see if that fixes the shutdown problem.
 
Old 11-20-2008, 10:23 AM   #4
Pazau
Member
 
Registered: Nov 2008
Location: Copenhagen, Denmark
Distribution: Ubuntu and Xubuntu 8.10
Posts: 98

Original Poster
Rep: Reputation: 15
Now I believe that it is an ACPI problem. I have stopped Powernowd, because otherwise the CPU running at paltry 800mhz.

Could it have anything to do with it?
I'm not sure it with GRUB list, think of if the computer can not start up, what do I do?
 
Old 11-22-2008, 06:14 PM   #5
Pazau
Member
 
Registered: Nov 2008
Location: Copenhagen, Denmark
Distribution: Ubuntu and Xubuntu 8.10
Posts: 98

Original Poster
Rep: Reputation: 15
Can you make a screenshot of the outcome, so I can see exactly how I should do?
 
Old 11-23-2008, 03:32 AM   #6
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,229

Rep: Reputation: 286Reputation: 286Reputation: 286
Quote:
Originally Posted by Pazau View Post
Now I believe that it is an ACPI problem. I have stopped Powernowd, because otherwise the CPU running at paltry 800mhz.

Could it have anything to do with it?
I'm not sure it with GRUB list, think of if the computer can not start up, what do I do?
Did disabling powernowd fix the shutdown problem?

Adding acpi=force to the kernel line in grub's menu.lst would not prevent the system from starting up. If you first back up menu.lst before editing it like I showed in my last post, you can always restore the original menu.lst if something goes wrong.

Suppose you messed up menu.lst while editing it so that Ubuntu would not boot. To restore the original menu.lst, you can boot from the Ubuntu live CD, mount your Ubuntu partition, and replace the backed up menu.lst. For example, suppose Ubuntu is on /dev/sda2. You would do this from the Ubuntu live CD:
Code:
sudo mount /dev/sda2 /mnt
sudo cp /mnt/boot/grub/menu.lst.bak /mnt/boot/grub/menu.lst
Then save the file and close gedit. Then reboot and grub will be back the way it was before you messed it up.
If you don't know what partition Ubuntu is on look at /etc/fstab. The partition that has the mount point as / (for root) is your Ubuntu root partition.
I always back up any configuration file first before editing it for this reason.

Last edited by tommcd; 11-23-2008 at 03:35 AM.
 
Old 11-23-2008, 03:51 AM   #7
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,229

Rep: Reputation: 286Reputation: 286Reputation: 286
Quote:
Originally Posted by Pazau View Post
Can you make a screenshot of the outcome, so I can see exactly how I should do?
Here is how you would add acpi=force to the kernel line for booting Ubuntu. Run gksudo gedit /boot/grub/menu.lst from terminal. Scroll down to the section ## ## End Default Options ##. The entries for booting Ubuntu are below that. There is an entry for booting Ubuntu, plus an entry for booting to recovery mode, for each kernel that you have. Here is the entry for booting Ubuntu from my menu.lst:
Code:
title		Ubuntu 8.10, kernel 2.6.27-7-generic
uuid		eedd9a75-b5ef-4490-9e47-e7fe9fda82f1
kernel		/boot/vmlinuz-2.6.27-7-generic root=UUID=eedd9a75-b5ef-4490-9e47-e7fe9fda82f1 ro  
initrd		/boot/initrd.img-2.6.27-7-generic
quiet
To add acpi=force I would change the kernel line like this (changes in bold type):
Code:
title		Ubuntu 8.10, kernel 2.6.27-7-generic
uuid		eedd9a75-b5ef-4490-9e47-e7fe9fda82f1
kernel		/boot/vmlinuz-2.6.27-7-generic root=UUID=eedd9a75-b5ef-4490-9e47-e7fe9fda82f1 ro acpi=force 
initrd		/boot/initrd.img-2.6.27-7-generic
quiet
Then save the file and exit. Then reboot. If it don't work you can just edit menu.lst again and remove acpi=force.
You only need to add acpi=force to the first entry in grub for booting Ubuntu. Don't worry about the entries below that for older kernels you may have.

Last edited by tommcd; 11-23-2008 at 03:54 AM.
 
Old 11-23-2008, 05:29 AM   #8
Pazau
Member
 
Registered: Nov 2008
Location: Copenhagen, Denmark
Distribution: Ubuntu and Xubuntu 8.10
Posts: 98

Original Poster
Rep: Reputation: 15
Now, I have again made the command "shutdown-h now" in recovery mode, and then it was off the disk, which said:

Will now halt: Could't not iterate IDE / ATA devices. (there was also something else but can not remember exactly what was written, but it had something to do with the HDD)

But acpi=force works, the only one who would have been nice to boot graphics still appear, and it does not. Is there a way to turn it on?
 
Old 11-23-2008, 06:38 AM   #9
Pazau
Member
 
Registered: Nov 2008
Location: Copenhagen, Denmark
Distribution: Ubuntu and Xubuntu 8.10
Posts: 98

Original Poster
Rep: Reputation: 15
When I disabled Powernowd that was just the system faster. It did not resolve my problem.
Now I would like to have restored GRUB from the .bak file, but I can not doubleclick on the .bak file.
How I restore the GRUB list without making use of Live-CD?
 
Old 11-23-2008, 10:36 PM   #10
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,229

Rep: Reputation: 286Reputation: 286Reputation: 286
Quote:
Originally Posted by Pazau View Post
But acpi=force works,
Do you mean it fixes the shutdown problem? Or do you just mean that the system boots with acpi=force added to the kernel line in menu.lst? If it fixes the shutddown problem just leave it the way it is.

Quote:
Originally Posted by Pazau View Post
the only one who would have been nice to boot graphics still appear, and it does not. Is there a way to turn it on?
I'm not sure what you mean by that. What graphics are you talking about?
 
Old 11-23-2008, 10:47 PM   #11
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,229

Rep: Reputation: 286Reputation: 286Reputation: 286
Quote:
Originally Posted by Pazau View Post
Now I would like to have restored GRUB from the .bak file, but I can not doubleclick on the .bak file.
How I restore the GRUB list without making use of Live-CD?
You could just edit menu.lst again and remove the acpi=force that you added to the kernel line.

If you backed up your menu.lst like this:
Code:
sudo cp /boot/grub/menu.lst /boot/grub/menu.lst.bak
then to restore the original menu.lst from the .bak file just do this:
Code:
sudo cp -i /boot/grub/menu.lst.bak /boot/grub/menu.lst
The -i switch added to the cp command is for interactive. It will ask you to confirm overwriting menu.lst. Just answer y for yes to confirm and this will restore menu.lst from the .bak file.

The "-i" switch is optional. It is a good safety feature because it asks you to confirm the overwrite, so you don't accidentally overwrite the wrong file. This is unlikely in this case, but in other cases many files have similar names, so a typo could accidentally overwrite the wrong file.
 
Old 11-24-2008, 08:43 AM   #12
Pazau
Member
 
Registered: Nov 2008
Location: Copenhagen, Denmark
Distribution: Ubuntu and Xubuntu 8.10
Posts: 98

Original Poster
Rep: Reputation: 15
Thanks a lot! My computer works properly now.
 
Old 11-24-2008, 01:02 PM   #13
Pazau
Member
 
Registered: Nov 2008
Location: Copenhagen, Denmark
Distribution: Ubuntu and Xubuntu 8.10
Posts: 98

Original Poster
Rep: Reputation: 15
I thought to completely disable ACPI from, because this is what was the problem.
http://ubuntuforums.org/showthread.php?t=89491

The top two services had I intend to turn off. Will it work better?
 
Old 11-24-2008, 03:58 PM   #14
Pazau
Member
 
Registered: Nov 2008
Location: Copenhagen, Denmark
Distribution: Ubuntu and Xubuntu 8.10
Posts: 98

Original Poster
Rep: Reputation: 15
The problem now is back.

When I shut down Ubuntu, it's not always that there are ACPI Exiting. But when it does it come Power Down message not before I press any key.

What can the problem is due?
Dansk

»
Engelsk

Oversæt
 
Old 11-24-2008, 05:05 PM   #15
SqdnGuns
Member
 
Registered: Aug 2005
Location: Fountain Valley, CA / Thailand
Distribution: Slackware64® 14.0
Posts: 981

Rep: Reputation: 88
Quote:
Originally Posted by Pazau View Post
The problem now is back.

When I shut down Ubuntu, it's not always that there are ACPI Exiting. But when it does it come Power Down message not before I press any key.

What can the problem is due?
Dansk

»
Engelsk

Oversæt
Bet you got an update from Ubombtu that made the changes.........they know how your box should run. <sarcasm>
 
  


Reply

Tags
dont, shutdown, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting Java program to close properly on logging off kde arubin Programming 3 09-22-2008 03:19 AM
LXer: Can Ubuntu Linux Close the Digital Divide? LXer Syndicated Linux News 0 08-04-2008 02:40 AM
I cannot close applictions properly zzcranjo Linux - Software 2 07-01-2008 07:04 PM
LXer: From Fedora, through Ubuntu and Slackware, getting close to ZenWalk LXer Syndicated Linux News 0 08-02-2007 02:31 PM
Ubuntu wont start properly Lazy_Moron Ubuntu 1 02-20-2006 11:49 AM


All times are GMT -5. The time now is 07:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration