LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 04-30-2007, 09:08 AM   #1
colin.mcewan
LQ Newbie
 
Registered: Feb 2004
Location: Edinburgh, UK
Distribution: Mandrake 9.2
Posts: 7

Rep: Reputation: 0
Two problems 7130 based TV card - no sound and Agfa 1212U scanner


As an impatient newbie, these are driving me to distraction.

I am running Ubuntu Fiesty (2.6.20-15-generic)

My philips 7130 based TV card works well (UK) but there is no sound. I have unmuted the line in but to no effect. One line in dmesg (in full below) says

49.136503] saa7130[0]/alsa: saa7130[0] at 0xf7e00000 irq 16 registered as card -2

Why card 2 I wonder ? Is this the problem and, if so, how do I cure it ?


My second problem is the Agfa Scapscan 1212U scanner. This works well in Windows and worked fine with an old Suse distro I tried 3 years ago.

But now after the first scan (or preview) it does not reset itself properly and I get the message "Failure to start scanner.Error during device I/O"

Can anyone please help

Many thanks

Colin


dmesg:

48.802643] saa7130/34: v4l2 driver version 0.2.14 loaded
[ 48.802703] ACPI: PCI Interrupt 0000:00:0b.0[A] -> GSI 16 (level, low) -> IRQ 16
[ 48.802711] saa7130[0]: found at 0000:00:0b.0, rev: 1, irq: 16, latency: 64, mmio: 0xf7e00000
[ 48.802717] saa7130[0]: subsystem: 4e42:0138, board: LifeView/Typhoon FlyVIDEO2000 [card=3,autodetected]
[ 48.802726] saa7130[0]: board init: gpio is 39000
[ 48.802729] saa7130[0]: there are different flyvideo cards with different tuners
[ 48.802730] saa7130[0]: out there, you might have to use the tuner=<nr> insmod
[ 48.802731] saa7130[0]: option to override the default value.
[ 48.802792] input: saa7134 IR (LifeView/Typhoon Fl as /class/input/input2
[ 48.821481] parport0: Printer, EPSON Stylus COLOR 1160
[ 48.947411] saa7130[0]: i2c eeprom 00: 42 4e 38 01 10 28 ff ff ff ff ff ff ff ff ff ff
[ 48.947420] saa7130[0]: i2c eeprom 10: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 48.947426] saa7130[0]: i2c eeprom 20: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 48.947432] saa7130[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 48.947437] saa7130[0]: i2c eeprom 40: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 48.947443] saa7130[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 48.947448] saa7130[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 48.947454] saa7130[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 48.971450] tuner 0-0061: chip found @ 0xc2 (saa7130[0])
[ 48.971497] tuner 0-0061: type set to 37 (LG PAL (newer TAPC series))
[ 48.971501] tuner 0-0061: type set to 37 (LG PAL (newer TAPC series))
[ 48.974190] input: PC Speaker as /class/input/input3
[ 49.118202] saa7130[0]: registered device video0 [v4l2]
[ 49.118228] saa7130[0]: registered device vbi0
[ 49.118280] saa7130[0]: registered device radio0
[ 49.136470] saa7134 ALSA driver for DMA sound loaded
[ 49.136503] saa7130[0]/alsa: saa7130[0] at 0xf7e00000 irq 16 registered as card -2
[ 49.168657] nvidia: module license 'NVIDIA' taints kernel.
[ 49.432320] ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 16
 
Old 04-30-2007, 12:45 PM   #2
colin.mcewan
LQ Newbie
 
Registered: Feb 2004
Location: Edinburgh, UK
Distribution: Mandrake 9.2
Posts: 7

Original Poster
Rep: Reputation: 0
Regarding the scanner. I have been digging around and added the line

firmware /usr/share/sane/snapscan/SnapScan 1212U.bin to

/etc/sane.d/snapscan.conf

I then added the scapscan_1212U.bin file (from the installation disk) to /usr/share/sane/snapscan/

This was supposed to do the trick according to a couple of sources but nothing has changed. Have I missed a move here ?

Colin
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sabrent SBT-TVFM 7130 TV Card MTBer Linux - Hardware 24 08-05-2008 08:22 AM
no tuner loaded for Philips 7130 tv card on Suse 10.1 nightshade_1977 Linux - Hardware 3 12-11-2006 06:59 PM
philips 7130 tv-card greenthing Linux - Hardware 2 09-08-2005 10:15 PM
philips 7130 pci tuner card Jake_da_Snake Linux - Hardware 10 02-26-2005 12:01 AM
No sound using bt878 based radio card pkid Linux - Hardware 0 10-02-2004 01:49 AM


All times are GMT -5. The time now is 09:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration