LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 07-09-2006, 04:36 PM   #1
cncman
LQ Newbie
 
Registered: Jun 2006
Distribution: PCLinuxOS kernel 2.6.12
Posts: 16

Rep: Reputation: 0
TV card, no sound, eeprom invalid, no eeprom present (err=-121)


I have a Norwood Micro PCI TV tuner (conexant cx23880).
I'm running PCLinuxOS. I can view channels in xawtv and tvtime, but have no sound I also get different messeges when I dmesg

cx2388x v4l2 driver version 0.0.4 loaded
PCI: Found IRQ 3 for device 0000:00:0a.0
PCI: Sharing IRQ 3 with 0000:00:02.7
cx88[0]: subsystem: 0000:0000, board: Leadtek Winfast 2000XP Expert [card=5,insmod option]
tuner 0-0060: chip found @ 0xc0 (cx88[0])
tuner 0-0060: type set to 44 (Philips 4 in 1 (ATI TV Wonder Pro/Conexant))
tveeprom(cx88xx internal): Huh, no eeprom present (err=-121)?
cx88[0]: Leadtek eeprom invalid.

cx88[0]: registered IR remote control
cx88[0]/0: found at 0000:00:0a.0, rev: 5, irq: 3, latency: 32, mmio: 0xe8000000
cx88[0]/0: registered device video0 [v4l2]
cx88[0]/0: registered device vbi0
cx88[0]/0: registered device radio0

lspci output:
00:0a.0 Multimedia video controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)

lsmod output:
tda9887 12536 0
tuner 25160 0
ir_common 6084 1 cx88xx
v4l1_compat 12612 1 cx8800
evdev 7264 0
bttv 144432 0
video_buf 16420 3 cx8800,cx88xx,bttv
firmware_class 7136 1 bttv
i2c_algo_bit 8552 2 cx88xx,bttv
v4l2_common 4608 2 cx8800,bttv
btcx_risc 3816 3 cx8800,cx88xx,bttv
tveeprom 11544 2 cx88xx,bttv
i2c_core 16848 6 cx88xx,tda9887,tuner,bttv,i2c_algo_bit,tveeprom
videodev 6848 4 cx8800,cx88xx,bttv
dm_mod 48892 0
sata_vsc 4932 0


sometimes I get:
tuner 0-0060: Tv freq (268435455.93) out of range
after channel 60 i get nothing when i should have almost 20 channels to go.
I'm using card=5 tuner=44 If use any thing else I get nothing.

Also PCLinuxOS control center will not allow me to configure the card. after I make changes to the "Area" and the "User" feilds Control center starts scanning for channels, abruptly stops and closes the tv card configure window. When I open it back up no changes were made.
 
Old 08-05-2006, 07:24 AM   #2
PirateFSM
LQ Newbie
 
Registered: Oct 2005
Posts: 8

Rep: Reputation: Disabled
Same soundless boat

I'm in the same boat. I get it to work in WinXP, i checked that the line in volume is on and at a good volume, but still, nothing. Any help will be great. I thank you for reading my post.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
EEPROM Checksum Is Not Valid tikliang Linux - Networking 1 06-09-2006 10:57 PM
Write to Hardware (EEProm, RAM) GodSendDeath Programming 0 05-25-2004 11:59 PM
ERR MSG: orinoco_cs device eth1 does not seem to be present, delaying initialization. gt6350a Linux - Hardware 1 11-08-2003 03:33 PM
invalid compressed format (err=1) shameless Linux - General 1 08-16-2003 11:15 AM
LTSP - Need EEPROM? Can't use BIOS? lazlow69 Linux - Hardware 5 02-27-2003 03:52 PM


All times are GMT -5. The time now is 01:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration