LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 03-18-2006, 10:59 PM   #1
kg4ysy
Member
 
Registered: May 2005
Location: North Carolina
Distribution: Gentoo
Posts: 123

Rep: Reputation: 19
turn off touchpad tapping?


I have installed gentoo on my toshiba, and for some reason my touchpad is so sensitive, I can breathe on it and have it click. How can I disable tapping, or better yet, adjust sensitivity to this? I have tried using the synaptics driver but it disabled my optical mouse. Any ideas anyone?

My xorg as it stands now (my optical mouse works fine)

33 Section "InputDevice"
34 # generated from data in "/etc/conf.d/gpm"
35 Identifier "Mouse0"
36 Driver "mouse"
37 Option "Protocol"
38 Option "Device" "/dev/input/mice"
39 Option "Emulate3Buttons" "yes"
40 Option "ZAxisMapping" "4 5"
 
Old 03-18-2006, 11:18 PM   #2
bluelightning
Member
 
Registered: Mar 2006
Location: Redmond, WA
Distribution: FC4, WinXP Pro
Posts: 37

Rep: Reputation: 15
I too have a toshiba, but it's running FC4. It looks like I'm using the synaptics driver. Both the touchpad and an optical trackball work on it. Here are the relevant parts of my xorg.conf file. Maybe with these options the synaptics driver will work with your optical mouse:

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "AlwaysCore"
EndSection

#from a different spot

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
Option "LeftEdge" "120"
Option "RightEdge" "830"
Option "TopEdge" "120"
Option "BottomEdge" "650"
Option "FingerLow" "14"
Option "FingerHigh" "15"
Option "MaxTapMove" "110"
Option "VertScrollDelta" "20"
Option "HorizScrollDelta" "20"
Option "MinSpeed" "0.3"
Option "MaxSpeed" "0.75"
EndSection
 
Old 03-18-2006, 11:31 PM   #3
tamoneya
Member
 
Registered: Jan 2005
Location: MA
Distribution: Ubuntu 7.10
Posts: 558

Rep: Reputation: 30
i have dealt a little with trying to disable keypad taps on windows systems with dell laptops. After spending sometime with dell i discovered that they cant really fix the tapping at all. That would suggest to me that the tapping is part of the keypad but i am not sure.
from looking at the synaptics driver i would think that setting MaxTapMove to "0" might help. But dont quote me on that. It just seems the logical choice.
 
Old 03-19-2006, 11:32 AM   #4
kg4ysy
Member
 
Registered: May 2005
Location: North Carolina
Distribution: Gentoo
Posts: 123

Original Poster
Rep: Reputation: 19
I have switched my xorg to the info listed above. It works now. The tapping is delayed by a few tenths of a second, and the touchpad itself doesnt go fast enough for me , but I am thrilled this works now. It makes life so much easier.
 
Old 03-19-2006, 05:36 PM   #5
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
Excellent - thanks everyone for providing the info needed to successfully resolve this issue and thanks kg4ysy for posting back with the followup
 
Old 04-06-2006, 08:00 PM   #6
jtravnick
Member
 
Registered: Jul 2005
Location: Rhinelander Wi.
Distribution: FC6 F7 F8
Posts: 94

Rep: Reputation: 15
I have an acer aspire running FC5. can somebody tell me how to get the touchpad not to click on this machine? I have the same problem as the op. This one also has two buttons for clicking I would rather use them than tapping the touchpad since if im not careful just moving the mouse around I will acadently click on something I dont want.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turning off tapping on touchpad Tereno Linux - Software 1 12-11-2005 06:44 AM
ALPS touchpad, no tapping in 10.2 thunderweasel Mandriva 2 09-04-2005 05:38 AM
no touchpad tapping... nakaiy Suse/Novell 10 11-23-2004 05:29 PM
Tapping on TouchPad with 2.6 Kernel Dave Choy Mandriva 1 07-15-2004 04:37 PM
touchpad not tapping under mandrake 10 box_l Linux - Laptop and Netbook 0 06-21-2004 09:42 AM


All times are GMT -5. The time now is 01:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration