LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Trying to mount iPod touch 4 iOS 4.1 with ifuse (http://www.linuxquestions.org/questions/linux-hardware-18/trying-to-mount-ipod-touch-4-ios-4-1-with-ifuse-837754/)

gregorian 10-13-2010 04:47 AM

Trying to mount iPod touch 4 iOS 4.1 with ifuse
 
I've jailbroken my iPod touch 4 with limera1n and I'm trying to mount the file system using iFuse. I'm using Ubuntu 10.10

I can see 'Apple' when I run lsusb. When I try to use "sudo ifuse /mnt/ipod", I get:
Code:

usbmuxd_get_device_list: error opening socket!
No device found, is it connected?
If it is make sure that your user has permissions to access the raw usb device.
If you're still having issues try unplugging the device and reconnecting it.

I ran sudo usbmuxd and did it again, and this time the first error is removed. Any help?

prayag_pjs 10-13-2010 04:50 AM

Can you post the output of

Quote:

fdisk -l
here

gregorian 10-13-2010 09:52 AM

Thanks for your response.
Code:

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x94e494e4

  Device Boot      Start        End      Blocks  Id  System
/dev/sda1  *          1          13      102400    7  HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2              13        2550    20377600    7  HPFS/NTFS
/dev/sda3            2550        7180    37187584    7  HPFS/NTFS
/dev/sda4            7180        9730    20481025    5  Extended
/dev/sda5            7180        9618    19581952  83  Linux
/dev/sda6            9618        9730      898048  82  Linux swap / Solaris

The iPod camera memory mounts automatically. I'm trying to mount the iPod's file system by using iFuse. http://www.libimobiledevice.org/

someitalian123 10-15-2010 04:56 PM

I having a similar or the same problem. In kde it's automatically detected as a camera, none of the music is accessible. I'm not sure how to unmount because I don't know where the camera memory is mounted at, and their is no eject button on the device notifier. I try to use ifuse so I can use gtkpod but I get

No device found, is it connected?
If it is make sure that your user has permissions to access the raw usb device.
If you're still having issues try unplugging the device and reconnecting it.


All times are GMT -5. The time now is 11:28 PM.