LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-23-2013, 04:25 PM   #1
tswain
LQ Newbie
 
Registered: Oct 2004
Location: Oregon
Posts: 11

Rep: Reputation: 0
Trying to install CentOS 5.9 on ASUS Z87-Expert -- Hangs


All,

I've been trying to install CentOS 5.9 on few systems I built up using ASUS Z87-Expert MB with an Intel i7-4770k (haswell) CPU and just about every time it hangs. I have tried most everything, like, swapping out the HD, DVD, Memory, CPU.

It is hanging during the format section of the install and if I'm lucky enough it will hang during install.

Anyone out there have this problem to?

ASUS doesn't support Linux.


Let me know if there is another MB out there that can easily load 5.9 with the Haswell CPU.

Thank you,

T
 
Old 10-23-2013, 04:42 PM   #2
yooy
Senior Member
 
Registered: Dec 2009
Posts: 1,154

Rep: Reputation: 134Reputation: 134
probably it is not centos that won't run on your hardware but rather kernel. On new hardware always stick to new kernels if possible..

just for information:Centos 5.9 is not the latest stable version.
 
2 members found this post helpful.
Old 10-23-2013, 04:45 PM   #3
John VV
Guru
 
Registered: Aug 2005
Posts: 13,057

Rep: Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741
first off is it 100% MANDATORY to use the rather OLD 5 series ?
although RHEL 5.10 and Cent 5.9 are current updates the 5 series major versions of software are 6.5 years old
from April 2007

firefox is version 10 ( yes version 10 is the update )

or the long life firefox 17.09

and not the current firefox 24

ImageMagick-6.2
and the current is 6.8
The Gimp 2.2 and the current is 2.8

CentOS 5 also will not have any support for any new hardware
it was designed for hardware from 2007

but if you MUST , 100% MUST, use 5.9 and not the current 6.4 ( soon to be 6.5 )


on that hardware
install centos 6.4
then in a VM install 5.9 IN THE VM
 
1 members found this post helpful.
Old 10-23-2013, 05:00 PM   #4
tswain
LQ Newbie
 
Registered: Oct 2004
Location: Oregon
Posts: 11

Original Poster
Rep: Reputation: 0
Yooy & John,


Thank you for your quick response.

Unfortunately, our development tools do not support Version 6.X otherwise I'd move to the next stable release.

I was able to get 2 systems loaded up, but not without a lot of pain. Took me around 7-15 tries to finally get loaded.

I'll have to say that it is very fast and stable once loaded up.

T
 
Old 10-23-2013, 06:03 PM   #5
John VV
Guru
 
Registered: Aug 2005
Posts: 13,057

Rep: Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741
to bad you can not use the current rhel
rhel5 hit it's end of production 1 last January
and will hit "End of Production 2" support this coming January

now Production 3 goes to 2017
 
Old 10-29-2013, 05:56 AM   #6
kaoruzhu
LQ Newbie
 
Registered: Jan 2008
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by tswain View Post
Yooy & John,


Thank you for your quick response.

Unfortunately, our development tools do not support Version 6.X otherwise I'd move to the next stable release.

I was able to get 2 systems loaded up, but not without a lot of pain. Took me around 7-15 tries to finally get loaded.

I'll have to say that it is very fast and stable once loaded up.

T
can you tell me the tricks?
I need to run rhel5.x or rhel6.x on asus z87 + i74770 platform.
I tried many times, always failed.
thank you.
 
Old 10-30-2013, 06:27 PM   #7
tswain
LQ Newbie
 
Registered: Oct 2004
Location: Oregon
Posts: 11

Original Poster
Rep: Reputation: 0
Kaoruzhu,

For me it usually hangs during format of the HD. If I make past there it will hang shortly there after. CentOS has a newly released 5.10 but that is worse than 5.9

Sorry I could not be more help,

T
 
Old 10-30-2013, 06:50 PM   #8
John VV
Guru
 
Registered: Aug 2005
Posts: 13,057

Rep: Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741Reputation: 1741
Quote:
I need to run rhel5.x or rhel6.x on asus z87 + i74770 platform.
contact red hat sales and they can tell you if the hardware is supported
RHEL 6.5 is NOT free
-- single desktop install
the standard 1 year REQUIRED support contract is $299 / year
with a $49/ year SELF SUPPORT - you can not call redhat for help !

-- server install
anywhere from $349 to over $8600 / year



or use CentOS 6.4 ( a FREE rebuild of RHEL )

but then YOU are your own tech support
 
Old 11-14-2013, 07:18 PM   #9
tswain
LQ Newbie
 
Registered: Oct 2004
Location: Oregon
Posts: 11

Original Poster
Rep: Reputation: 0
[solved]

All -

I think I have this solved.

Not sure why the first two systems worked and the following 5 did not.

In BIOS v1008 <-- This should not work. I upgraded the BIOS to 1602

In BIOS 1405 or greater they added an additional feature called Memory Scrambler" found here in the BIOS.

Advanced | System agent Configuration | Memory Configuration

Memory scrambler is Enabled by default, disable it.

Rebooted and now my install finishes and I have a blazing fast development system.

T
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Install CentOS 5.1 (x86_64) with Virtualization on ASUS P5K Premium/WIFI-AP dbaxps Linux - Wireless Networking 1 01-17-2008 09:46 AM
CentOS 4.5 hangs after install jofred99 Linux - Hardware 1 09-15-2007 06:29 PM
CentOS installation hangs when trying to install on my computer with XP preinstalled Satyakam Linux - General 9 08-23-2007 10:48 AM
eth0 hangs GUI Centos 4.4 x86_64 on ASUS A8N-M Chebi Linux - Newbie 0 03-07-2007 12:20 PM
LXer: Install CentOS 4.4 on ASUS P5B Deluxe LXer Syndicated Linux News 0 02-15-2007 02:01 PM


All times are GMT -5. The time now is 03:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration