LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-28-2007, 02:16 PM   #1
jonlake
Member
 
Registered: Apr 2004
Distribution: Slackware 11.0, Gentoo
Posts: 252

Rep: Reputation: 31
Trying to get higher resolution


I have just received my new monitor (IBM T860). Previously had a 15" crt. Looked up information and it should support up to 1280x1024@60. I have made modifications to my xorg.conf. However, when I go to change the resolution, the highest setting available is 1024x768@60. Here is my xorg.conf

Code:
Section "Module"
    Load        "dbe"   # Double buffer extension
    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection
    Load        "type1"
    Load        "freetype"
    Load        "speedo"
    Load       "glx"
EndSection
Section "Files"
    RgbPath     "/usr/X11R6/lib/X11/rgb"
    FontPath   "/usr/X11R6/lib/X11/fonts/local/"
    FontPath   "/usr/X11R6/lib/X11/fonts/misc/"
    FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath   "/usr/X11R6/lib/X11/fonts/Type1/"
    FontPath   "/usr/X11R6/lib/X11/fonts/CID/"
    FontPath   "/usr/X11R6/lib/X11/fonts/Speedo/"
    FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/"
    FontPath   "/usr/X11R6/lib/X11/fonts/cyrillic/"
EndSection
Section "ServerFlags"
EndSection
Section "InputDevice"
    Identifier  "Keyboard1"
    Driver      "kbd"
EndSection
Section "InputDevice"
    Identifier  "Mouse1"
    Driver      "mouse"
    Option "Protocol"    "IMPS/2"
    Option "Device"      "/dev/mouse"
    Option "ZAxisMapping" "4 5"
EndSection
Section "Monitor"
    Identifier  "My Monitor"
    HorizSync   31.5-60.0
    VertRefresh 60
EndSection
Section "Device"
    Identifier "NVIDIA Corporation NV20 [GeForce3 Ti 200]"
    Driver     "nv"
    BusId      "PCI:1:0:0"
EndSection
Section "Screen"
    Identifier  "Screen 1"
    Device      "NVIDIA Corporation NV20 [GeForce3 Ti 200]"
    Monitor     "My Monitor"
    SubSection "Display"
        Depth           4
        Modes "1280x1024" "1152x900" "1152x870" "1152x768" "1024x768"
    EndSubSection
    SubSection "Display"
        Depth           8
        Modes "1280x1024" "1152x900" "1152x870" "1152x768" "1024x768"
    EndSubSection
    SubSection "Display"
        Depth           15
        Modes "1280x1024" "1152x900" "1152x870" "1152x768" "1024x768"
    EndSubSection
    SubSection "Display"
        Depth           16
        Modes "1280x1024" "1152x900" "1152x870" "1152x768" "1024x768"
    EndSubSection
    SubSection "Display"
        Depth           24
        Modes "1280x1024" "1152x900" "1152x870" "1152x768" "1024x768"
    EndSubSection
    SubSection "Display"
        Depth 32
        Modes "1280x1024" "1152x900" "1152x870" "1152x768" "1024x768"
    EndSubSection
EndSection
Section "ServerLayout"
    Identifier  "Simple Layout"
    Screen "Screen 1"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "Keyboard1" "CoreKeyboard"
EndSection
I have also tried the nvidia driver, but X fails to load completely. The error logs state it couldn't get certain symbols from EDID.
The logs from /var/log/Xorg.0.log are in the following post.

I have been looking into this and can't seem to get anywhere.
 
Old 01-28-2007, 02:19 PM   #2
jonlake
Member
 
Registered: Apr 2004
Distribution: Slackware 11.0, Gentoo
Posts: 252

Original Poster
Rep: Reputation: 31
logs

Code:
X Window System Version 6.9.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 6.9
Build Operating System: Linux 2.4.33.3 i686 [ELF]
Current Operating System: Linux evilpenguin 2.4.33.3 #1 Fri Sep 1 01:48:52 CDT 2006 i686
Build Date: 16 September 2006
        Before reporting problems, check http://wiki.X.Org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Jan 28 14:59:51 2007
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Simple Layout"
(**) |-->Screen "Screen 1" (0)
(**) |   |-->Monitor "My Monitor"
(**) |   |-->Device "NVIDIA Corporation NV20 [GeForce3 Ti 200]"
(**) |-->Input Device "Mouse1"
(**) |-->Input Device "Keyboard1"
(WW) `fonts.dir' not found (or not valid) in "/usr/X11R6/lib/X11/fonts/local/".
        Entry deleted from font path.
        (Run 'mkfontdir' on "/usr/X11R6/lib/X11/fonts/local/").
(WW) `fonts.dir' not found (or not valid) in "/usr/X11R6/lib/X11/fonts/Speedo/".
        Entry deleted from font path.
        (Run 'mkfontdir' on "/usr/X11R6/lib/X11/fonts/Speedo/").
(**) FontPath set to "/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/75dpi/:unscaled,/usr/X11R6/lib/X11/fonts/100dpi/:unscaled,/usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/CID/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/,/usr/X11R6/lib/X11/fonts/cyrillic/"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(WW) Open ACPI failed (/proc/acpi/event) (No such file or directory)
(II) No APM support in BIOS or kernel
(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.2
        X.Org Video Driver: 0.8
        X.Org XInput driver : 0.5
        X.Org Server Extension : 0.2
        X.Org Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.so
(II) Module bitmap: vendor="X.Org Foundation"
        compiled for 6.9.0, module version = 1.0.0
        Module class: X.Org Font Renderer
        ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.so
(II) Module pcidata: vendor="X.Org Foundation"
        compiled for 6.9.0, module version = 1.0.0
        ABI class: X.Org Video Driver, version 0.8
(++) using VT number 7

(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
        compiled for 6.9.0, module version = 1.0.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 0.2
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
        compiled for 6.9.0, module version = 1.0.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 0.2
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.so
(II) Module type1: vendor="X.Org Foundation"
        compiled for 6.9.0, module version = 1.0.2
        Module class: X.Org Font Renderer
        ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
        compiled for 6.9.0, module version = 2.1.0
        Module class: X.Org Font Renderer
        ABI class: X.Org Font Renderer, version 0.4
(II) Loading font FreeType
(II) LoadModule: "speedo"
(WW) Warning, couldn't open module speedo
(II) UnloadModule: "speedo"
(EE) Failed to load module "speedo" (module does not exist, 0)
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
        compiled for 4.0.2, module version = 1.0.6629
        Module class: XFree86 Server Extension
        ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "nv"
(II) Loading /usr/X11R6/lib/modules/drivers/nv_drv.so
(II) Module nv: vendor="X.Org Foundation"
        compiled for 6.9.0, module version = 1.0.1
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 0.8
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
        compiled for 6.9.0, module version = 1.0.3
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 0.5
(II) LoadModule: "kbd"
(II) Loading /usr/X11R6/lib/modules/input/kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
        compiled for 6.9.0, module version = 1.0.1
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 0.5
(II) NV: driver for NVIDIA chipsets: RIVA 128, RIVA TNT, RIVA TNT2,
        Unknown TNT2, Vanta, RIVA TNT2 Ultra, RIVA TNT2 Model 64,
        Aladdin TNT2, GeForce 256, GeForce DDR, Quadro, GeForce2 MX/MX 400,
        GeForce2 MX 100/200, GeForce2 Go, Quadro2 MXR/EX/Go,
        GeForce2 Integrated GPU, GeForce2 GTS, GeForce2 Ti, GeForce2 Ultra,
        Quadro2 Pro, GeForce4 MX 460, GeForce4 MX 440, GeForce4 MX 420,
        GeForce4 MX 440-SE, GeForce4 440 Go, GeForce4 420 Go,
        GeForce4 420 Go 32M, GeForce4 460 Go, Quadro4 550 XGL,
        GeForce4 440 Go 64M, Quadro4 NVS, Quadro4 500 GoGL,
        GeForce4 410 Go 16M, GeForce4 MX 440 with AGP8X,
        GeForce4 MX 440SE with AGP8X, GeForce4 MX 420 with AGP8X,
        GeForce4 MX 4000, GeForce4 448 Go, GeForce4 488 Go, Quadro4 580 XGL,
        Quadro4 280 NVS, Quadro4 380 XGL, Quadro NVS 50 PCI, GeForce4 448 Go,
        GeForce4 MX Integrated GPU, GeForce3, GeForce3 Ti 200,
        GeForce3 Ti 500, Quadro DCC, GeForce4 Ti 4600, GeForce4 Ti 4400,
        0x0252, GeForce4 Ti 4200, Quadro4 900 XGL, Quadro4 750 XGL,
        Quadro4 700 XGL, GeForce4 Ti 4800, GeForce4 Ti 4200 with AGP8X,
        GeForce4 Ti 4800 SE, GeForce4 4200 Go, Quadro4 700 GoGL,
        Quadro4 980 XGL, Quadro4 780 XGL, GeForce FX 5800 Ultra,
        GeForce FX 5800, Quadro FX 2000, Quadro FX 1000,
        GeForce FX 5600 Ultra, GeForce FX 5600, 0x0313, GeForce FX 5600SE,
        0x0316, 0x0317, GeForce FX Go5600, GeForce FX Go5650,
        Quadro FX Go700, 0x031D, 0x031E, 0x031F, GeForce FX 5200,
        GeForce FX 5200 Ultra, GeForce FX 5200, GeForce FX 5200SE,
        GeForce FX Go5200, GeForce FX Go5250, GeForce FX 5500,
        GeForce FX 5100, GeForce FX Go5200 32M/64M, 0x0329,
        Quadro NVS 55/280 PCI, Quadro FX 500/600 PCI,
        GeForce FX Go53xx Series, GeForce FX Go5100, 0x032F,
        GeForce FX 5900 Ultra, GeForce FX 5900, GeForce FX 5900XT,
        GeForce FX 5950 Ultra, Quadro FX 700, GeForce FX 5900ZT,
        Quadro FX 3000, GeForce FX 5700 Ultra, GeForce FX 5700,
        GeForce FX 5700LE, GeForce FX 5700VE, 0x0345, GeForce FX Go5700,
        GeForce FX Go5700, 0x0349, 0x034B, Quadro FX Go1000, Quadro FX 1100,
        0x034F, GeForce 6800 Ultra, GeForce 6800, GeForce 6800 LE, 0x0043,
        GeForce 6800 GT, GeForce 6800 GT, GeForce 6800 XT, 0x0049,
        Quadro FX 4000, 0x00C0, GeForce 6800, GeForce 6800 LE,
        GeForce 6800 XT, GeForce Go 6800, GeForce Go 6800 Ultra,
        Quadro FX Go1400, Quadro FX 3450/4000 SDI, Quadro FX 1400,
        GeForce 6600 GT, GeForce 6600, GeForce 6600 LE, 0x0143,
        GeForce Go 6600, GeForce 6610 XL, GeForce Go 6600 TE/6200 TE,
        GeForce 6700 XL, GeForce Go 6600, GeForce Go 6600 GT, 0x014B, 0x014C,
        0x014D, Quadro FX 540, GeForce 6200, GeForce 6500,
        GeForce 6200 TurboCache(TM), GeForce 6200SE TurboCache(TM),
        GeForce 6200 LE, GeForce Go 6200, Quadro NVS 285, GeForce Go 6400,
        GeForce Go 6200, GeForce Go 6400, GeForce 6250, 0x016B, 0x016C,
        0x016D, 0x016E, 0x0210, GeForce 6800, GeForce 6800 LE,
        GeForce 6800 GT, 0x0220, GeForce 6200, 0x0222, 0x0228, 0x0090,
        GeForce 7800 GTX, GeForce 7800 GT, 0x0093, 0x0094, GeForce Go 7800,
        GeForce Go 7800 GTX, 0x009C, Quadro FX 4500, 0x009E
(II) Primary Device is: PCI 01:00:0
(--) Chipset GeForce3 Ti 200 found

(II) Setting vga for screen 0.
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Loading /usr/X11R6/lib/modules/linux/libint10.so
(II) Module int10: vendor="X.Org Foundation"
        compiled for 6.9.0, module version = 1.0.0
        ABI class: X.Org Video Driver, version 0.8
(II) NV(0): Initializing int10
(II) NV(0): Primary V_BIOS segment is: 0xc000
(--) NV(0): Chipset: "GeForce3 Ti 200"
(==) NV(0): Depth 16, (==) framebuffer bpp 16
(==) NV(0): RGB weight 565
(==) NV(0): Default visual is TrueColor
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.so
(II) Module vgahw: vendor="X.Org Foundation"
        compiled for 6.9.0, module version = 0.1.0
        ABI class: X.Org Video Driver, version 0.8
(==) NV(0): Using HW cursor
(--) NV(0): Linear framebuffer at 0xE4000000
(--) NV(0): MMIO registers at 0xEC000000
(II) Loading sub module "i2c"
(II) LoadModule: "i2c"
(II) Loading /usr/X11R6/lib/modules/libi2c.so
(II) Module i2c: vendor="X.Org Foundation"
        compiled for 6.9.0, module version = 1.2.0
        ABI class: X.Org Video Driver, version 0.8
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Loading /usr/X11R6/lib/modules/libddc.so
(II) Module ddc: vendor="X.Org Foundation"
        compiled for 6.9.0, module version = 1.0.0
        ABI class: X.Org Video Driver, version 0.8
(II) NV(0): I2C bus "DDC" initialized.
(II) NV(0): Probing for EDID on I2C bus A...
(II) NV(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) NV(0): I2C device "DDC:ddc2" removed.
(II) NV(0):   ... none found
(--) NV(0): HW is currently programmed for CRT
(II) NV(0): Using CRT on CRTC 0
(--) NV(0): VideoRAM: 65536 kBytes
(==) NV(0): Using gamma correction (1.0, 1.0, 1.0)
(II) NV(0): My Monitor: Using hsync range of 31.50-60.00 kHz
(II) NV(0): My Monitor: Using vrefresh value of 60.00 Hz
(II) NV(0): Clock range:  12.00 to 350.00 MHz
(II) NV(0): Not using default mode "640x350" (vrefresh out of range)
(II) NV(0): Not using default mode "320x175" (vrefresh out of range)
(II) NV(0): Not using default mode "640x400" (vrefresh out of range)
(II) NV(0): Not using default mode "320x200" (vrefresh out of range)
(II) NV(0): Not using default mode "720x400" (vrefresh out of range)
(II) NV(0): Not using default mode "360x200" (vrefresh out of range)
(II) NV(0): Not using default mode "640x480" (vrefresh out of range)
(II) NV(0): Not using default mode "320x240" (vrefresh out of range)
(II) NV(0): Not using default mode "640x480" (vrefresh out of range)
(II) NV(0): Not using default mode "320x240" (vrefresh out of range)
(II) NV(0): Not using default mode "640x480" (vrefresh out of range)
(II) NV(0): Not using default mode "320x240" (vrefresh out of range)
(II) NV(0): Not using default mode "800x600" (vrefresh out of range)
(II) NV(0): Not using default mode "400x300" (vrefresh out of range)
(II) NV(0): Not using default mode "800x600" (vrefresh out of range)
(II) NV(0): Not using default mode "400x300" (vrefresh out of range)
(II) NV(0): Not using default mode "800x600" (vrefresh out of range)
(II) NV(0): Not using default mode "400x300" (vrefresh out of range)
(II) NV(0): Not using default mode "800x600" (vrefresh out of range)
(II) NV(0): Not using default mode "400x300" (vrefresh out of range)
(II) NV(0): Not using default mode "1024x768" (bad mode clock/interlace/doublescan)
(II) NV(0): Not using default mode "512x384" (bad mode clock/interlace/doublescan)
(II) NV(0): Not using default mode "1024x768" (vrefresh out of range)
(II) NV(0): Not using default mode "512x384" (vrefresh out of range)
(II) NV(0): Not using default mode "1024x768" (vrefresh out of range)
(II) NV(0): Not using default mode "512x384" (vrefresh out of range)
(II) NV(0): Not using default mode "1024x768" (hsync out of range)
(II) NV(0): Not using default mode "512x384" (hsync out of range)
(II) NV(0): Not using default mode "1152x864" (hsync out of range)
(II) NV(0): Not using default mode "576x432" (hsync out of range)
(II) NV(0): Not using default mode "1280x960" (hsync out of range)
(II) NV(0): Not using default mode "640x480" (hsync out of range)
(II) NV(0): Not using default mode "1280x1024" (hsync out of range)
(II) NV(0): Not using default mode "640x512" (hsync out of range)
(II) NV(0): Not using default mode "1280x1024" (hsync out of range)
(II) NV(0): Not using default mode "640x512" (hsync out of range)
(II) NV(0): Not using default mode "1280x1024" (hsync out of range)
(II) NV(0): Not using default mode "640x512" (hsync out of range)
(II) NV(0): Not using default mode "1600x1200" (hsync out of range)
(II) NV(0): Not using default mode "800x600" (hsync out of range)
(II) NV(0): Not using default mode "1600x1200" (hsync out of range)
(II) NV(0): Not using default mode "800x600" (hsync out of range)
(II) NV(0): Not using default mode "1600x1200" (hsync out of range)
(II) NV(0): Not using default mode "800x600" (hsync out of range)
(II) NV(0): Not using default mode "1600x1200" (hsync out of range)
(II) NV(0): Not using default mode "800x600" (hsync out of range)
(II) NV(0): Not using default mode "1600x1200" (hsync out of range)
(II) NV(0): Not using default mode "800x600" (hsync out of range)
(II) NV(0): Not using default mode "1792x1344" (hsync out of range)
(II) NV(0): Not using default mode "896x672" (hsync out of range)
(II) NV(0): Not using default mode "1792x1344" (hsync out of range)
(II) NV(0): Not using default mode "896x672" (hsync out of range)
(II) NV(0): Not using default mode "1856x1392" (hsync out of range)
(II) NV(0): Not using default mode "928x696" (hsync out of range)
(II) NV(0): Not using default mode "1856x1392" (hsync out of range)
(II) NV(0): Not using default mode "928x696" (hsync out of range)
(II) NV(0): Not using default mode "1920x1440" (hsync out of range)
(II) NV(0): Not using default mode "960x720" (hsync out of range)
(II) NV(0): Not using default mode "1920x1440" (hsync out of range)
(II) NV(0): Not using default mode "960x720" (hsync out of range)
(II) NV(0): Not using default mode "832x624" (vrefresh out of range)
(II) NV(0): Not using default mode "416x312" (vrefresh out of range)
(II) NV(0): Not using default mode "1152x768" (vrefresh out of range)
(II) NV(0): Not using default mode "576x384" (vrefresh out of range)
(II) NV(0): Not using default mode "1400x1050" (hsync out of range)
(II) NV(0): Not using default mode "700x525" (hsync out of range)
(II) NV(0): Not using default mode "1400x1050" (hsync out of range)
(II) NV(0): Not using default mode "700x525" (hsync out of range)
(II) NV(0): Not using default mode "1600x1024" (hsync out of range)
(II) NV(0): Not using default mode "800x512" (hsync out of range)
(II) NV(0): Not using default mode "1920x1440" (hsync out of range)
(II) NV(0): Not using default mode "960x720" (hsync out of range)
(II) NV(0): Not using default mode "2048x1536" (hsync out of range)
(II) NV(0): Not using default mode "1024x768" (hsync out of range)
(II) NV(0): Not using default mode "2048x1536" (hsync out of range)
(II) NV(0): Not using default mode "1024x768" (hsync out of range)
(II) NV(0): Not using default mode "2048x1536" (bad mode clock/interlace/doublescan)
(II) NV(0): Not using default mode "1024x768" (hsync out of range)
(II) NV(0): Not using mode "1280x1024" (no mode of this name)
(II) NV(0): Not using mode "1152x900" (no mode of this name)
(II) NV(0): Not using mode "1152x870" (no mode of this name)
(II) NV(0): Not using mode "1152x768" (no mode of this name)
(II) NV(0): Not using default mode "1280x960" (width too large for virtual size)
(--) NV(0): Virtual size is 1024x768 (pitch 1024)
(**) NV(0): *Default mode "1024x768": 65.0 MHz, 48.4 kHz, 60.0 Hz
(II) NV(0): Modeline "1024x768"   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync
(**) NV(0):  Default mode "800x600": 40.0 MHz, 37.9 kHz, 60.3 Hz
(II) NV(0): Modeline "800x600"   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync
(**) NV(0):  Default mode "640x480": 25.2 MHz, 31.5 kHz, 60.0 Hz
(II) NV(0): Modeline "640x480"   25.20  640 656 752 800  480 490 492 525 -hsync -vsync
(**) NV(0):  Default mode "640x480": 54.0 MHz, 60.0 kHz, 60.0 Hz (D)
(II) NV(0): Modeline "640x480"   54.00  640 688 744 900  480 480 482 500 doublescan +hsync +vsync
(**) NV(0):  Default mode "512x384": 32.5 MHz, 48.4 kHz, 60.0 Hz (D)
(II) NV(0): Modeline "512x384"   32.50  512 524 592 672  384 385 388 403 doublescan -hsync -vsync
(**) NV(0):  Default mode "400x300": 20.0 MHz, 37.9 kHz, 60.3 Hz (D)
(II) NV(0): Modeline "400x300"   20.00  400 420 484 528  300 300 302 314 doublescan +hsync +vsync
(**) NV(0):  Default mode "320x240": 12.6 MHz, 31.5 kHz, 60.1 Hz (D)
(II) NV(0): Modeline "320x240"   12.60  320 328 376 400  240 245 246 262 doublescan -hsync -vsync
(==) NV(0): DPI set to (75, 75)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
        compiled for 6.9.0, module version = 1.0.0
        ABI class: X.Org ANSI C Emulation, version 0.2
(II) Loading sub module "xaa"
(II) LoadModule: "xaa"
(II) Loading /usr/X11R6/lib/modules/libxaa.so
(II) Module xaa: vendor="X.Org Foundation"
        compiled for 6.9.0, module version = 1.2.0
        ABI class: X.Org Video Driver, version 0.8
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/X11R6/lib/modules/libramdac.so
(II) Module ramdac: vendor="X.Org Foundation"
        compiled for 6.9.0, module version = 0.1.0
        ABI class: X.Org Video Driver, version 0.8
(II) do I need RAC?  No, I don't.
(==) NV(0): Write-combining range (0xe4000000,0x4000000)
(II) NV(0): Using XFree86 Acceleration Architecture (XAA)
        Screen to screen bit blits
        Solid filled rectangles
        8x8 mono pattern filled rectangles
        Indirect CPU to Screen color expansion
        Solid Lines
        Scanline Image Writes
        Offscreen Pixmaps
        Setting up tile and stipple cache:
                32 128x128 slots
                32 256x256 slots
                16 512x512 slots
(==) NV(0): Backing store disabled
(==) NV(0): Silken mouse enabled
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(EE) Failed to initialize GLX extension (NVIDIA X driver not found)
(**) Option "Protocol" "IMPS/2"
(**) Mouse1: Device: "/dev/mouse"
(**) Mouse1: Protocol: "IMPS/2"
(**) Option "CorePointer"
(**) Mouse1: Core Pointer
(**) Option "Device" "/dev/mouse"
(==) Mouse1: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5"
(**) Mouse1: ZAxisMapping: buttons 4 and 5
(**) Mouse1: Buttons: 9
(**) Option "CoreKeyboard"
(**) Keyboard1: Core Keyboard
(**) Option "Protocol" "standard"
(**) Keyboard1: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Keyboard1: XkbRules: "xorg"
(**) Option "XkbModel" "pc105"
(**) Keyboard1: XkbModel: "pc105"
(**) Option "XkbLayout" "us"
(**) Keyboard1: XkbLayout: "us"
(**) Option "CustomKeycodes" "off"
(**) Keyboard1: CustomKeycodes disabled
(II) XINPUT: Adding extended input device "Keyboard1" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "Mouse1" (type: MOUSE)
(II) Mouse1: ps2EnableDataReporting: succeeded
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
 
Old 01-28-2007, 02:48 PM   #3
raskin
Senior Member
 
Registered: Sep 2005
Location: Russia
Distribution: NixOS (http://nixos.org)
Posts: 1,893

Rep: Reputation: 68
Sorry, but 60KHz Horizontal synchronization at 60 fps gives you only 1000 lines. Put "HorizSync 30-70", it must help.

Edited: minor typo.

Last edited by raskin; 01-29-2007 at 01:25 AM.
 
Old 01-28-2007, 10:28 PM   #4
jonlake
Member
 
Registered: Apr 2004
Distribution: Slackware 11.0, Gentoo
Posts: 252

Original Poster
Rep: Reputation: 31
Thank You

After changing the horizsync to 30-70, I now can get the resolution I need.
 
Old 04-14-2007, 01:04 PM   #5
ailecoupé
LQ Newbie
 
Registered: Feb 2007
Posts: 2

Rep: Reputation: 0
similar problem - different outcome

I am also using an NV20, however with nvidia-glx-legacy drivers. The monitor is a Compaq TFT5000 (lcd) with a native resolution of 1024x768. I tried making the above modifications to my xorg.conf, and copied the specified screen resolutions verbatim. I am wondering if this has anything to do with the Monitor, or if it is the fact that these legacy drivers are no longer supported by NVIDIA. No problems loading, but gnome still won't recognize the new resolutions, even after I used the Configuration Editor to replace the default screen with 1280x1024. Any ideas? Here is my xorg.conf:
Code:
Section "Files"
        FontPath        "/usr/share/fonts/X11/misc"
        FontPath        "/usr/share/fonts/X11/cyrillic"
        FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath        "/usr/share/fonts/X11/Type1"
        FontPath        "/usr/share/fonts/X11/100dpi"
        FontPath        "/usr/share/fonts/X11/75dpi"
        # path to defoma fonts
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
        Load    "bitmap"
        Load    "ddc"
        Load    "dri"
        Load    "extmod"
        Load    "freetype"
        Load    "glx"
        Load    "int10"
        Load    "vbe"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "us"
        Option          "XkbOptions"    "lv3:ralt_switch"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ImPS/2"
        Option          "ZAxisMapping"          "4 5"
        Option          "Emulate3Buttons"       "true"
EndSection

Section "InputDevice"
        Driver          "wacom"
        Identifier      "stylus"
        Option          "Device"        "/dev/input/wacom"
        Option          "Type"          "stylus"
        Option          "ForceDevice"   "ISDV4"         # Tablet PC ONLY
EndSection

Section "InputDevice"
        Driver          "wacom"
        Identifier      "eraser"
        Option          "Device"        "/dev/input/wacom"
        Option          "Type"          "eraser"
        Option          "ForceDevice"   "ISDV4"         # Tablet PC ONLY
EndSection

Section "InputDevice"
        Driver          "wacom"
        Identifier      "cursor"
        Option          "Device"        "/dev/input/wacom"
        Option          "Type"          "cursor"
        Option          "ForceDevice"   "ISDV4"         # Tablet PC ONLY
EndSection

Section "Device"
        Identifier      "geoforce`"
        Driver          "nvidia"
        BusID           "PCI:1:0:0"
EndSection

Section "Monitor"
        Identifier      "compaq tft5000"
        Option          "DPMS"
        HorizSync       30-70
        VertRefresh     57-85
        Option          "NoLogo"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "geoforce`"
        Monitor         "compaq tft5000"
        DefaultDepth    24
        SubSection "Display"
                Depth           1
                Modes "1280x1024" "1152x900" "1152x870" "1152x768" "1024x768"
        EndSubSection
        SubSection "Display"
                Depth           4
                Modes "1280x1024" "1152x900" "1152x870" "1152x768" "1024x768"
        EndSubSection
        SubSection "Display"
                Depth           8
                Modes "1280x1024" "1152x900" "1152x870" "1152x768" "1024x768"
        EndSubSection
        SubSection "Display"
                Depth           15
                Modes "1280x1024" "1152x900" "1152x870" "1152x768" "1024x768"
        EndSubSection
        SubSection "Display"
                Depth           16
                Modes "1280x1024" "1152x900" "1152x870" "1152x768" "1024x768"
        EndSubSection
        SubSection "Display"
                Depth           24
                Modes "1280x1024" "1152x900" "1152x870" "1152x768" "1024x768"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
        InputDevice     "stylus"        "SendCoreEvents"
        InputDevice     "cursor"        "SendCoreEvents"
        InputDevice     "eraser"        "SendCoreEvents"
EndSection

Section "DRI"
        Mode    0666
EndSection
Thanks in advance,

Stumped

p.s. an afterthought: After I tried to force gnome to recognize 1280x1024 as the default resolution, gdm takes longer to load after login, and the screen gives a few visual "pops." Maybe this is pointing less gnome and more driver/hardware. Dunno.

Last edited by ailecoupé; 04-15-2007 at 07:58 AM.
 
  


Reply

Tags
horizontal, nvidia, nvidia drivers, nvidia glx, screen, screen resolution, vertrefresh, xorgconf


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get a higher resolution. duffmckagan Yoper 3 04-28-2007 12:00 PM
Higher Resolution muppski Linux - General 7 11-30-2005 04:46 AM
Higher resolution o3h Linux - Software 2 10-06-2005 04:21 AM
Need higher resolution 1madstork Debian 2 11-25-2004 02:50 AM
Can't get resolution any higher ChaosZ3RO Linux - Hardware 2 07-15-2004 07:57 AM


All times are GMT -5. The time now is 06:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration