LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   trouble with Kensington trackball (http://www.linuxquestions.org/questions/linux-hardware-18/trouble-with-kensington-trackball-365434/)

Lord Zoltar 09-20-2005 10:15 PM

trouble with Kensington trackball
 
Well, I finally got fed up with the Microsoft Trackball and switched to a Kensington Expert Mouse. The last couple months, I've been mostly using it in Windows and quite enjoying it :)
I finally decided to configure it properly for Linux and ran into problems. All the documentation I can find says to use the "ThinkingMousePS/2" protocol when using a Kensington trackball or mouse. I tried this protocol out, with not too great results. The mouse motion seemed much smoother, but if I stopped moving the mouse for a second or two then started again, the cursor would suddenly snap to the bottom left corner of the screen. Is there any special Option that must be set to use this protocol?

teckk 09-22-2005 02:02 PM

I would back up my xorg.conf somewhere and rerun xorgconfig a few times and choose different mouse types. See if you can find one that works better. Try microsoft, auto, ect. You may find one that works better.
Copy xorg.conf as xorg.conf.123 or something. Then if you screw it all up or can't find a better mouse you can always restore it. You could of course edit xorg manually.

I had a 5 button scroll mouse recently that just would not work well in Linux. I tried it in 3 different distros. I put it on a windoze machine and it works fine. There is sometimes hardware that just does not work.

Good luck.
cd to your xorg directory and issue
Code:

cp xorg.conf.123 xorg.conf
to get your backed up xorg back. You'll have to be root.

Lord Zoltar 09-22-2005 06:43 PM

Well, I've been editing xorg.conf manually, since the xorgconfig never seems to do a great job. The trackball works with other drivers, but the motion is a bit too fast and jerky. I don't know if it's a driver issue, or some kernel option (I compile my own kernel so the nVidia drivers will work)... The driver for the ExpertMouse (ThinkingMousePS/2) gives good motion and control but like I mentioned, the cursor keeps snapping back to the bottom left.

teckk 09-22-2005 09:15 PM

I had that happen with Debian once. I could not fix the problem until I swapped the mouse. Just like you said it would pull the cursor all the way over to the side of the screen. It must be a config issue.

Let us know if you fix it.

Lord Zoltar 09-23-2005 10:31 PM

well... it's sort of fixed.

I tried running xorgconfig after all... after I cleaned up the mistakes it made with my video card, I had this:

Code:

    Identifier        "Mouse1"
    Driver        "mouse"
    #Option "Protocol"    "ThinkingMousePS/2"
    Option "Protocol" "IMPS/2"
    Option "Device"      "/dev/mouse"
    Option "Buttons" "6"
    Option "ZAxisMapping" "4 5"

# Mouse-speed setting for PS/2 mouse.

    Option "Resolution"        "256"

I switched to IMPS/2 protocol after the ThiningMousePS/2 worked EXACTLY the same as before. I think what's making the difference is the Resolution. I was sure I'd tried playing with it before, to no avail. well, at least it works now. (maybe xorgconfig did fix something else after all?)

I wouldn't call the problem 100% fixed though. The mouse motion is better than before, but could be better (it IS better in Windows, still). But I'm not sure I'll see any more improvements unless the ThinkingMousePS/2 protocol is fixed. :(


All times are GMT -5. The time now is 09:31 AM.