LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 03-28-2008, 10:26 AM   #1
matt_ttam
LQ Newbie
 
Registered: Mar 2008
Posts: 5

Rep: Reputation: 0
Trouble with intel 930m graphics driver


I recently aquired a toshiba 1000 s157 laptop which i believe has a intel 930m graphics card. the laptop does not have a CD drive, so I removed the hdd and installed mepis with my other laptop.

Now mepis boots fine on the toshiba, however when I get to the login screen, the monitor flashes and goes black. The strange thing is if I plug in an external monitor and press fnc+f5, the laptop and external monitor will show the login screen and the computer works great from there. However if I log off, the screen goes black again.

I am trying to get his working to interface with a PA system to play music, and record.

I'm pretty sure the LCD screen on the laptop is functional because it came installed with winxp and that worked perfect (for windows.)

If anyone has any ideas, I would really appreciate it. Thanks in advance.
 
Old 03-28-2008, 10:55 AM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,764

Rep: Reputation: 306Reputation: 306Reputation: 306Reputation: 306
It's possible that Mepis didn't load the correct graphics module, or it isn't configured correctly for the laptop's monitor.

I don't know what tools Mepis provides for graphics configuration. If you can run the config app from the command line, try booting to runlevel 3 then run the config to manually set up the monitor.
 
Old 03-28-2008, 11:44 AM   #3
matt_ttam
LQ Newbie
 
Registered: Mar 2008
Posts: 5

Original Poster
Rep: Reputation: 0
Wink i think i got it

Thanks for that simple suggestion. I got it working... heres what I did.

I started the computer and hooked up a external monitor so i could get a screen.

Went to system...mepis...xwindows assistant. clicked the monitor tab and installed a Toshiba monitor. I don't know which one I have, but I installed the top 15 inch LCD monitor. now it boots fine.

However it leaves the outside inch of the screen unused. This is not a big issue for me, but I will work on it and post my solution if I find it.
 
  


Reply

Tags
intel, mepis, toshiba


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel GM965 (X3100) Graphics Trouble poetic_assassin Linux - Hardware 6 02-19-2008 09:49 PM
Ubuntu Install Trouble with Intel 82845G graphics card cyborg939 Linux - Hardware 11 07-15-2007 08:48 AM
Intel Extreme Graphics 865GBF graphics driver _UnPrEdictAbLe_ Linux - Hardware 3 07-31-2006 01:48 AM
Mandrake 10.1 having trouble with onboard Intel 82865G Graphics card. sairam9 Mandriva 6 06-23-2005 11:46 AM
: Intel® 865G Chipset with Intel® Extreme Graphics 2 -driver for linux7.0 ker 2.4.1 schandak Red Hat 1 10-28-2004 12:43 AM


All times are GMT -5. The time now is 09:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration