LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 06-15-2007, 11:45 PM   #1
SeanWcisel
LQ Newbie
 
Registered: Apr 2007
Location: Grand Rapids, Michigan
Distribution: Ubuntu, Gentoo, Debian
Posts: 11

Rep: Reputation: 0
Trouble with fglrx drivers on debian etch system


Hi guys,

This problem has several symptoms, and I'm not sure about the cause. With that said, I'll try to be as specific as possible:

I'm trying to install the fglrx drivers (version 8.37.6) on my debian system. I've gone through the process per the ati site, and the gui seems to indicate that everything was successful. When I run "glxgears --info" I get

Xlib: extension "XFree86-DRI" missing on display ":0.0"

xorg.conf is indeed set up with the option 0666. I also get the following in my xorg.0.log file:

(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed! *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO) *
(WW) fglrx(0): * no 3D acceleration available *
(WW) fglrx(0): ********************************************* *

Of course, I could have predicted those "WW" lines . I'll go ahead and post my whole xorg.conf file, just to speed things along:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
Option "XkbVariant" "dvorak"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection

Section "Device"
Identifier "ATI Technologies Inc Radeon R350 [Radeon 9800 Pro]"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "eView17f3"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc Radeon R350 [Radeon 9800 Pro]"
Monitor "eView17f3"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection


There you go. Thanks a thousand times to anyone who can help me, I've been struggling with this for days.

-Sean
 
Old 06-15-2007, 11:50 PM   #2
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 60
You don't say what release you're running, but the last I knew the i386 ati driver was broken. You should have gotten a message stating that during the compiling. For some reason, the AMD64 version works fine.

I trust you are executing these things the "debian way," ... using the ati script to generate .deb packages, then using module-assistant to install them.
 
Old 06-16-2007, 12:00 AM   #3
SeanWcisel
LQ Newbie
 
Registered: Apr 2007
Location: Grand Rapids, Michigan
Distribution: Ubuntu, Gentoo, Debian
Posts: 11

Original Poster
Rep: Reputation: 0
Hey, thanks for the reply. Yeah, I have tried doing it that way, and when I run a package manager on those files, I get the "the same package is already installed" message. What do you suppose would be my next avenue?

Thank you very much

P.S. Sorry, here's the output of uname -r && cat /proc/version 2.6.18-4-486

Linux version 2.6.18-4-486 (Debian 2.6.18.dfsg.1-12etch2) (dannf@debian.org) (gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)) #1 Wed May 9 22:23:40 UTC 2007

P.P.S. I should add, when I open the synaptic package manager, and search "fglrx", the drivers appear to be installed, but in need of an upgrade. When I attempt to upgrade, I get:

fglrx-driver:
Depends: libc6 (>=2.5-5) but 2.3.6.ds1-13 is to be installed
Depends: libgcc1 (>=1:4.2-20070516) but 1:4.1.1-21 is to be installed
Depends: libxrandr2 (>=2:1.2.0) but 2:1.1.0.2-5 is to be installed

I also got that when I tried to install them via that manager the first time.

Last edited by SeanWcisel; 06-16-2007 at 12:07 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Etch Install with PCIE RADEON X550 and FGLRX mikethefrog Debian 2 12-05-2007 01:26 PM
ATI 200M fglrx driver How to (Debian Etch) android6011 Linux - Hardware 18 07-28-2007 12:10 PM
FGLRX DRI issues in debian etch 1337ln Linux - Software 5 03-31-2007 02:23 PM
trying to load fglrx can't unload radeonfb module: debian etch MrInept Linux - Software 2 03-21-2007 07:03 AM
Installing fglrx on a Debian System vharishankar Debian 8 01-27-2005 02:49 PM


All times are GMT -5. The time now is 06:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration