LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-11-2006, 07:43 PM   #1
Uncle Buggerson
LQ Newbie
 
Registered: Jan 2006
Distribution: Mepis
Posts: 1

Rep: Reputation: 0
Unhappy Trouble with ati radeon 7000 VE agp in Mepis


Any help would be appreciated. I have been having some trouble with my ATI Radeon 7000 VE agp card, namely its lack of direct rendering. I have tried running glxinfo, at which this is spit out at me:

name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
GLX_SGIS_multisample, GLX_SGIX_hyperpipe, GLX_SGIX_swap_barrier,
GLX_SGIX_fbconfig
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_OML_swap_method,
GLX_OML_sync_control, GLX_SGI_make_current_read, GLX_SGI_swap_control,
GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group
GLX extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_fbconfig
OpenGL vendor string: Mesa project: (this is the mesa url, I have to remove it because I mayn't post them)
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.1)
OpenGL extensions:
GL_ARB_depth_texture, GL_ARB_imaging, GL_ARB_multitexture,
GL_ARB_point_parameters, GL_ARB_point_sprite, GL_ARB_shadow,
GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar,
GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
GL_ARB_texture_rectangle, GL_ARB_transpose_matrix, GL_ARB_window_pos,
GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color, GL_EXT_blend_func_separate,
GL_EXT_blend_logic_op, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
GL_EXT_clip_volume_hint, GL_EXT_copy_texture, GL_EXT_draw_range_elements,
GL_EXT_fog_coord, GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels,
GL_EXT_point_parameters, GL_EXT_polygon_offset, GL_EXT_rescale_normal,
GL_EXT_secondary_color, GL_EXT_separate_specular_color,
GL_EXT_shadow_funcs, GL_EXT_stencil_two_side, GL_EXT_stencil_wrap,
GL_EXT_subtexture, GL_EXT_texture, GL_EXT_texture3D,
GL_EXT_texture_edge_clamp, GL_EXT_texture_env_add,
GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_texture_rectangle,
GL_EXT_vertex_array, GL_APPLE_packed_pixels, GL_ATI_texture_env_combine3,
GL_ATI_texture_mirror_once, GL_ATIX_texture_env_combine3,
GL_HP_occlusion_test, GL_IBM_texture_mirrored_repeat,
GL_INGR_blend_func_separate, GL_MESA_pack_invert, GL_MESA_ycbcr_texture,
GL_NV_blend_square, GL_NV_point_sprite, GL_NV_texgen_reflection,
GL_NV_texture_rectangle, GL_SGIS_generate_mipmap,
GL_SGIS_texture_border_clamp, GL_SGIS_texture_edge_clamp,
GL_SGIS_texture_lod, GL_SGIX_depth_texture, GL_SGIX_shadow,
GL_SGIX_shadow_ambient, GL_SUN_multi_draw_arrays
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x22 16 tc 0 16 0 r y . 5 6 5 0 0 16 0 0 0 0 0 0 0 None
0x23 16 tc 0 16 0 r y . 5 6 5 0 0 16 8 16 16 16 0 0 0 None
0x24 16 tc 0 24 0 r y . 5 6 5 8 0 16 8 16 16 16 16 0 0 None
0x25 16 tc 0 24 0 r . . 5 6 5 8 0 16 8 16 16 16 16 0 0 None


Now I can see that the lines:

OpenGL vendor string: Mesa project: (I mayn't post urls)
OpenGL renderer string: Mesa GLX Indirect

should not be as they are.

I have tried changing /etc/x11/XF86Config-4 and xorg.conf so that they are both the same and are as follows:

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
#InputDevice "PS/2 Mouse" "CorePointer"
InputDevice "USB Mouse" "CorePointer"
#InputDevice "Serial Mouse" "CorePointer"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "true"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
# True type and type1 fonts
FontPath "/usr/share/fonts/truetype/ttf-xfree86-nonfree"
FontPath "/usr/share/fonts/truetype/java"
FontPath "/usr/share/fonts/truetype/arphic"
FontPath "/usr/share/fonts/truetype/freefont"
FontPath "/usr/share/fonts/truetype/openoffice"
FontPath "/usr/share/fonts/truetype/ttf-bitstream-vera"
FontPath "/usr/share/fonts/ttf/western"
FontPath "/usr/share/fonts/ttf/decoratives"
FontPath "/usr/share/fonts/type1/gsfonts"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/defoma/CID"
FontPath "/usr/X11R6/lib/X11/fonts/defoma/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"

EndSection

Section "Module"
Load "GLcore"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "speedo"
Load "type1"
Load "vbe"
# Load "synaptics"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XKbOptions" ""
EndSection

Section "InputDevice"
Identifier "Serial Mouse"
Driver "mouse"
Option "Protocol" "Microsoft"
Option "Device" "/dev/ttyS0"
Option "Emulate3Buttons" "false"
Option "Emulate3Timeout" "70"
EndSection

Section "InputDevice"
Identifier "Touchpad"
Driver "synaptics"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "LeftEdge" "1700"
Option "RightEdge" "5300"
Option "TopEdge" "1700"
Option "BottomEdge" "4200"
Option "FingerLow" "25"
Option "FingerHigh" "30"
Option "MaxTapTime" "180"
Option "MaxTapMove" "220"
Option "VertScrollDelta" "100"
Option "MinSpeed" "0.06"
Option "MaxSpeed" "0.12"
Option "AccelFactor" "0.0010"
Option "SHMConfig" "on"
Option "Repeater" "/dev/input/mice"
EndSection

Section "InputDevice"
Identifier "PS/2 Mouse"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "false"
Option "Emulate3Timeout" "70"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"
EndSection

Section "InputDevice"
Identifier "USB Mouse"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "unknown"
ModelName "unknown"
#Option "DPMS" "true"
HorizSync 30.0 - 82.0 # Warning: This may fry old Monitors
VertRefresh 50.0 - 70.0 # Very conservative. May flicker.
Modeline "640x480" 25.175 640 664 760 800 480 491 493 525 #60Hz
Modeline "800x600" 40.12 800 848 968 1056 600 601 605 628 #60Hz
Modeline "1024x768" 75 1024 1048 1184 1328 768 771 777 806 -hsync -vsync
Modeline "1024x768" 85 1024 1056 1152 1360 768 784 787 823
ModeLine "1152x864" 65 1152 1168 1384 1480 864 865 875 985 Interlace
Modeline "1152x864" 92 1152 1208 1368 1474 864 865 875 895
Modeline "1152x864" 110 1152 1240 1324 1552 864 864 876 908
Modeline "1152x864" 135 1152 1464 1592 1776 864 864 876 908
Modeline "1152x864" 137.65 1152 1184 1312 1536 864 866 885 902 -HSync -VSync
Modeline "1280x1024" 80 1280 1296 1512 1568 1024 1025 1037 1165 Interlace
Modeline "1280x1024" 110 1280 1328 1512 1712 1024 1025 1028 1054
Modeline "1280x1024" 126.5 1280 1312 1472 1696 1024 1032 1040 1068 -HSync -VSync
Modeline "1280x1024" 135 1280 1312 1456 1712 1024 1027 1030 1064
Modeline "1280x1024" 135 1280 1312 1416 1664 1024 1027 1030 1064
Modeline "1280x1024" 157.5 1280 1344 1504 1728 1024 1025 1028 1072 +HSync +VSync
Modeline "1280x1024" 181.75 1280 1312 1440 1696 1024 1031 1046 1072 -HSync -VSync
Modeline "1400x1050" 129 1400 1464 1656 1960 1050 1051 1054 1100 +HSync +VSync
Modeline "1600x1200" 162 1600 1664 1856 2160 1200 1201 1204 1250 +HSync +VSync
Modeline "1600x1200" 189 1600 1664 1856 2160 1200 1201 1204 1250 -HSync -VSync
Modeline "1600x1200" 202.5 1600 1664 1856 2160 1200 1201 1204 1250 +HSync +VSync
Modeline "1600x1200" 220 1600 1616 1808 2080 1200 1204 1207 1244 +HSync +VSync
ModeLine "1800x1440" 230 1800 1896 2088 2392 1440 1441 1444 1490 +HSync +VSync
ModeLine "1800x1440" 250 1800 1896 2088 2392 1440 1441 1444 1490 +HSync +VSync
EndSection

Section "Device"
#Option "sw_cursor" # needed for some ati cards
#Option "hw_cursor"
#Option "NoAccel"
#Option "ShowCache"
#Option "ShadowFB"
#Option "UseFBDev"
#Option "Rotate"
#Option "NoUseBios" # needed for some Savage cards
Option "UseInternalAGPGART" "yes"
# nvidia special options, use with care
Option "CursorShadow" "1"
Option "CursorShadowAlpha" "63"
Option "CursorShadowYOffset" "2"
Option "CursorShadowXOffset" "4"
Option "FlatPanelProperties" "Scaling = native"
Option "NoLogo" "false"
#Option "IgnoreEdid" "true" # needs to be true for some nvidia cards
Identifier "Card0"
Driver "radeon"
BoardName "ATI Radeon 7000"
VideoRam 65536
#BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultColorDepth 16
SubSection "Display"
Depth 1
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 32
Modes "1024x768"
EndSubSection
# Only the official NVIDIA driver supports twinview
# these setting are an example
Option "TwinView" "false"
Option "SecondMonitorVendorName" "unknown"
Option "SecondMonitorModelName" "unknown"
Option "SecondMonitorHorizSync" "30-82"
Option "SecondMonitorVertRefresh" "50-75"
Option "MetaModes" "1024x768, 1024x768; 800x600, 800x600; 640x480, 640x480"
Option "TwinViewOrientation" "RightOf"
Option "ConnectedMonitor" "dfp,dfp"
EndSection

Section "DRI"
Mode 0666
EndSection

I also ran glxgears and was rather upset about the horrors of software rendering:
glxgears
846 frames in 5.0 seconds = 169.122 FPS
832 frames in 5.0 seconds = 166.359 FPS
829 frames in 5.0 seconds = 165.701 FPS
825 frames in 5.0 seconds = 164.858 FPS
829 frames in 5.0 seconds = 165.777 FPS
819 frames in 5.0 seconds = 162.350 FPS
809 frames in 5.0 seconds = 161.640 FPS
835 frames in 5.0 seconds = 166.764 FPS
833 frames in 5.0 seconds = 166.496 FPS

I do have 2 monitors in at once, if that makes a difference.

Last edited by Uncle Buggerson; 01-11-2006 at 07:57 PM.
 
Old 01-13-2006, 10:11 AM   #2
deroB
Member
 
Registered: Dec 2005
Location: Sydney, Australia
Distribution: Arch Linux
Posts: 208

Rep: Reputation: 30
try changing this line of xorg.conf or x11/XF86Config-4(whichever you are using):

Driver "radeon"
to
Driver "fglrx"

worked for me

if fglrx isn't isntalled get the proprietry linux drivers from the ATI website.

Last edited by deroB; 01-13-2006 at 10:19 AM.
 
Old 01-31-2006, 01:32 PM   #3
cougyr
Member
 
Registered: Nov 2003
Posts: 98

Rep: Reputation: 15
Are you still there, Uncle Buggerson? Do you still have this problem? I have this card and went through this problem. It will never be a super card, but it will render 3D. There is a boot race when the kernel loads. If the order is wrong, direct rendering won't load. Which kernel are you using? Are you using a via chipset?

Check in /etc/modules. You may want to add: via-agp Do this to beat the boot race.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ati 7000 and mepis problem Tha1 MEPIS 1 12-08-2005 06:22 PM
xorg, can't enable direct rendering, logfile doesn't update Radeon 7000 AGP slackwarefan Linux - Software 0 04-11-2005 10:34 PM
Can't enable DRI Radeon 7000 AGP slackwarefan Slackware 22 04-05-2005 04:23 PM
hello a new in linux and i got a big problem with my ati radeon 7000/radeon ve card AKAKAK Linux - Hardware 0 01-19-2005 09:39 AM
redhat 8 and ATI Radeon agp 320m (aka Radeon Mobility U1) nelsonnery Linux - Hardware 11 11-06-2003 06:24 AM


All times are GMT -5. The time now is 07:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration