LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 05-08-2004, 04:35 AM   #1
mattuc
LQ Newbie
 
Registered: Apr 2004
Location: Portland, OR
Distribution: Red Hat 9
Posts: 21

Rep: Reputation: 15
Question trouble mounting drive, bad superblock error


Running RH9, kernel 2.4.20-31.9
trying to mount an 80G Maxtor drive. model 6Y080L0
In secondary slave position, jumpered slave.
I'm trying to make one 80G fat32 LBA partition accessible from both Linux and Win98.
I partitioned this drive as Fat32 (LBA) w/ fdisk in Linux, formatted it in windows. Windows can read it, but scandisk found bad sectors which it supposedly fixed. made a directory in Linux (/mnt/d) but when I try to mount I get the error:
mount: wrong fs type, bad option, bad superblock on /dev/hdd1,
or too many mounted file systems
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)
i ran fsck and got:
fsck 1.32 (09-Nov-2002)
e2fsck 1.32 (09-Nov-2002)
/dev/hdd: clean, 11/10010624 files, 314137/20010816 blocks
this would have found a bad superblock, correct?
I also tried deleting the partition and making and formatting a linux partition to see if it would mount that, but no luck there either. In fact, after formatting it in Linux and rebooting it doesn't recognize the partition table because fdisk -l shows this:
Disk /dev/hdd: 81.9 GB, 81964302336 bytes
16 heads, 63 sectors/track, 158816 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

Disk /dev/hdd doesn't contain a valid partition table <<<

My BIOS is set to autodetect and chooses LBA by default, but if I change settings from autodetect to 'user' and let it auto detect the type it chooses CHS. I have no idea if that has anything to do with anything though.
Win98 has no trouble reading or writing to this drive, I just can't get it to mount in Linux. Other LBA drives and windows partitions mount fine, and I'm not mounting them all at the same time, so it shouldn't be a "too many mounted filesystems" problem.
Help?

Last edited by mattuc; 05-08-2004 at 04:43 AM.
 
Old 05-08-2004, 01:27 PM   #2
mattuc
LQ Newbie
 
Registered: Apr 2004
Location: Portland, OR
Distribution: Red Hat 9
Posts: 21

Original Poster
Rep: Reputation: 15
bump

bump
 
Old 05-26-2004, 01:18 PM   #3
draco aardvark
LQ Newbie
 
Registered: May 2004
Location: Pittsburgh
Distribution: Debian
Posts: 2

Rep: Reputation: 0
I'm having the same troubles with my /dev/ataraid/d0p1

I moved the computer to a new case, added a video card and a hard disk and now it doesn't mount my RAID drive :-(

when I searched for this error on google, I got a lot of people asking about it and nobody answering, or saying "IM me and we'll work it out." So I think geting at least an explanation of the what the problem is online would be good.

In my case, the RAID drive is reiserfs formated, and it worked fine untill I moved everything. I was very carefull to preserve the cable oder (it's raid0, I don't want to screw that up!) and I've never had troubles with it before.

The server is Linux only, so I can't test it under windows.
 
Old 05-27-2004, 11:05 AM   #4
draco aardvark
LQ Newbie
 
Registered: May 2004
Location: Pittsburgh
Distribution: Debian
Posts: 2

Rep: Reputation: 0
Well, in my case it was a hardware problem.
I hope you get yours fixed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem mounting CD-ROM: wrong fs type, bad option, bad superblock on /dev/cdrom Oooska Linux - Newbie 7 07-10-2013 12:37 PM
ERROR AT MOUNTING USB :mount: wrong fs type, bad option, bad superblock on /dev/sda1, saiket Linux - Hardware 3 04-12-2008 01:07 AM
Bad superblock when mounting hard drive... SamJ Linux - Hardware 5 06-04-2005 08:32 PM
problems mounting a cdrom in redhat (from rockscluster.org OS install) >>> bad superblock akay Linux - Hardware 6 12-01-2004 01:04 PM
"...bad superblock" error when mounting cdrom Trinity22 Linux - Hardware 4 09-19-2004 08:59 PM


All times are GMT -5. The time now is 02:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration