LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-27-2007, 08:55 AM   #1
kopf91
LQ Newbie
 
Registered: May 2007
Posts: 3

Rep: Reputation: 0
Unhappy Trouble installing ATI drivers


Hi,

I'm on debian etch, got a mobility radeon 9700 in this laptop. I'm trying to install the drivers for it.

I've followed all the instructions here to the letter, and yet when I do a "fglrxinfo" i still get the following:

Code:
kopf@rocket:~$ fglrxinfo
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)
They mention this problem on another ATI page as a "persistant loading of the mesa driver" or something, and the fix is apparently the first fix mentioned on the page i have linked above:

Code:
# mkdir -p /usr/X11R6/lib/modules/dri
# ln -s /usr/lib/dri/fglrx_dri.so /usr/X11R6/lib/modules/dri
But that doesn't do anything. Any ideas?

Thanks..
 
Old 05-27-2007, 09:43 AM   #2
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 60
Did you install the drivers from the Debian repos, or the ones from ATI?

What is the output of $ uname -r?
 
Old 05-27-2007, 09:45 AM   #3
kopf91
LQ Newbie
 
Registered: May 2007
Posts: 3

Original Poster
Rep: Reputation: 0
2.6.18-4-686

i installed the debian packages, i think. As i said, I followed the instructions on that linked page to the letter, so whatever packages they got me to install, I installed.
 
Old 05-27-2007, 09:51 AM   #4
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 60
That page includes instructions for both package sources.

Try running # dpkg-reconfigure xserver-xorg

Make sure you pick the fglrx driver from the list.

Post the output of # lsmod | grep fglrx
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble loading video drivers of Live CDs offa G5 Powermac with an ATI X800XT sladuuch Linux - Newbie 1 01-23-2006 10:13 PM
Trouble installing ATI Radeon 9600 Drivers in Mandrake RAMMS+EIN Linux - Hardware 2 05-27-2005 04:58 PM
ATI 9700 Pro, WIerd Drivers Mouse trouble Jarcader Linux - Hardware 0 03-01-2005 03:18 PM
X trouble after Ati drivers install enigma82 Linux - Hardware 3 12-06-2004 12:34 PM
ATI Drivers Radeon 9600 Mobile Trouble gbkyle Linux - Laptop and Netbook 1 12-04-2004 02:51 PM


All times are GMT -5. The time now is 06:07 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration