LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 07-15-2009, 08:31 PM   #1
William (Dthdealer)
Member
 
Registered: Jan 2009
Location: Sydney, Australia
Distribution: Debian Testing
Posts: 99
Blog Entries: 39

Rep: Reputation: 19
Touchpad disable button permanently disables touchpad until reboot


Ubuntu 9.04 AMD64 - Acer Aspire 5536

A togglable button is placed next to my touchpad to temporarily disable it, however once toggled it can't be turned on without rebooting. The backlight behind it still toggles.

The button works perfectly under (*shiver*) Vista.

I've tried the touchfreeeze utility, but it doesn't work for me. Constantly while typing I 'tap' the touchpad, emulating a click and moving my cursor somewhere else. This is a pain

Does anyone know how I can configure my system to re-detect the mouse input from the touchpad once it is re-enabled?

-william
 
Old 07-15-2009, 10:46 PM   #2
foodown
Member
 
Registered: Jun 2009
Location: Texas
Distribution: Slackware
Posts: 607

Rep: Reputation: 218Reputation: 218Reputation: 218
Try this to yield more information for us:

Immediately after toggling the touch pad off, give us the output of:
Code:
tail /var/log/messages
Once we can see exactly what is happening when the thing gets toggled off, we can probably tell you what to do to help get it back on.

Last edited by foodown; 07-15-2009 at 10:48 PM.
 
Old 07-16-2009, 06:16 AM   #3
William (Dthdealer)
Member
 
Registered: Jan 2009
Location: Sydney, Australia
Distribution: Debian Testing
Posts: 99
Blog Entries: 39

Original Poster
Rep: Reputation: 19
There is no change to the logs before and after toggling the button, even after toggling it back on.

Code:
Jul 16 20:38:06 AFKveyrdite kernel: [   27.565907] ADDRCONF(NETDEV_UP): wlan0: link is not ready
Jul 16 20:38:50 AFKveyrdite kernel: [   68.793901] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Jul 16 20:51:28 AFKveyrdite kernel: [  829.571386] totem-plugin-vi[4477]: segfault at 8 ip 0000000000411b00 sp 00007fff369f1020 error 4 in totem-plugin-viewer[400000+35000]
 *Here I plug another mouse in to use before toggling the button*
Jul 16 21:10:52 AFKveyrdite kernel: [ 1993.984086] usb 5-1: new low speed USB device using ohci_hcd and address 2
Jul 16 21:10:52 AFKveyrdite kernel: [ 1994.155010] usb 5-1: configuration #1 chosen from 1 choice
Jul 16 21:10:52 AFKveyrdite kernel: [ 1994.222249] usbcore: registered new interface driver hiddev
Jul 16 21:10:52 AFKveyrdite kernel: [ 1994.227012] input: Microsoft Microsoft 3-Button Mouse with IntelliEye(TM) as /devices/pci0000:00/0000:00:13.0/usb5/5-1/5-1:1.0/input/input10
Jul 16 21:10:52 AFKveyrdite kernel: [ 1994.257191] generic-usb 0003:045E:0040.0001: input,hidraw0: USB HID v1.10 Mouse [Microsoft Microsoft 3-Button Mouse with IntelliEye(TM)] on usb-0000:00:13.0-1/input0
Jul 16 21:10:52 AFKveyrdite kernel: [ 1994.257239] usbcore: registered new interface driver usbhid
Jul 16 21:10:52 AFKveyrdite kernel: [ 1994.257246] usbhid: v2.6:USB HID core driver
 *button toggled off - no change*
 *button toggled on - no change*
EDIT: Kernel 2.6.28-13-generic

Last edited by William (Dthdealer); 07-16-2009 at 10:57 PM. Reason: Added 'kernel version'
 
Old 07-16-2009, 11:02 PM   #4
William (Dthdealer)
Member
 
Registered: Jan 2009
Location: Sydney, Australia
Distribution: Debian Testing
Posts: 99
Blog Entries: 39

Original Poster
Rep: Reputation: 19
Red face

Checked Xorg.0.log, syslog and the command lspci, nothing relevant.
 
Old 07-16-2009, 11:29 PM   #5
foodown
Member
 
Registered: Jun 2009
Location: Texas
Distribution: Slackware
Posts: 607

Rep: Reputation: 218Reputation: 218Reputation: 218
Quote:
Originally Posted by William (Dthdealer) View Post
Checked Xorg.0.log, syslog and the command lspci, nothing relevant.
Well that is all quite irritating. . . .

How does the thing appear in your dmesg?
 
Old 07-17-2009, 03:03 PM   #6
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
The following page should work.

http://www.linuxine.com/2008/06/how-...in-ubuntu.html

I suggest create a custom udev script to set a name for the desire touchpad that matches the vendor ID and product ID.
 
Old 07-18-2009, 12:45 AM   #7
William (Dthdealer)
Member
 
Registered: Jan 2009
Location: Sydney, Australia
Distribution: Debian Testing
Posts: 99
Blog Entries: 39

Original Poster
Rep: Reputation: 19
Quote:
Originally Posted by foodown View Post
Well that is all quite irritating. . . .

How does the thing appear in your dmesg?
DMESG logs everything to /var/log/messages, and so the output is the same.

Will try Electro
 
Old 07-18-2009, 12:56 AM   #8
William (Dthdealer)
Member
 
Registered: Jan 2009
Location: Sydney, Australia
Distribution: Debian Testing
Posts: 99
Blog Entries: 39

Original Poster
Rep: Reputation: 19
I've added the whole InputDevice section to xorg.conf, as it did not exist.
Code:
Section "InputDevice"
	Identifier "Synaptics Touchpad"
	Driver "synaptics"
	Option "SendCoreEvents" "true"
	Option "Device" "/dev/psaux"
	Option "Protocol" "auto-dev"
	Option "HorizEdgeScroll" "0"
	Option "SHMConfig" "on" 
EndSection
However upon running either synclient touchpadoff=1 or synclient touchpadoff=0 I'm informed Can't access shared memory area. SHMConfig disabled?
.
 
Old 07-22-2009, 02:32 AM   #9
William (Dthdealer)
Member
 
Registered: Jan 2009
Location: Sydney, Australia
Distribution: Debian Testing
Posts: 99
Blog Entries: 39

Original Poster
Rep: Reputation: 19
*bump*
Any clues?
Will only bump this once (in this topic)
 
Old 07-22-2009, 02:21 PM   #10
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
If you get a message stating "Can't access shared memory area. SHMConfig disabled", common sense may tell you it could be a permission problem. If running the utility "synclient" using root or sudo and it still gives you problems, then it could be X11 or something else that is causing the problem.

BTW, do not use colors in post unless you know it will not blend with other colors. Orange is a bad color in this forum. Darker colors are better. Even better plain black works just fine.
 
Old 07-23-2009, 07:17 AM   #11
William (Dthdealer)
Member
 
Registered: Jan 2009
Location: Sydney, Australia
Distribution: Debian Testing
Posts: 99
Blog Entries: 39

Original Poster
Rep: Reputation: 19
Sorry electro - I'm used to forums with only one style where colours contrast.

Thanks - it is a permission problem. I'll try changing the exec permissions of the executable.

EDIT: Seemingly not - even while using superuser/root I still encounter the same problems. X11 problems are a pain to fix, but I'll check the documentation regarding synaptics.

Last edited by William (Dthdealer); 07-23-2009 at 07:20 AM.
 
Old 08-01-2009, 01:01 AM   #12
Crinisulla
LQ Newbie
 
Registered: Aug 2009
Distribution: Ubuntu, CentOS
Posts: 4

Rep: Reputation: 0
I'm running an Acer Aspire 4810T with Ubuntu Jaunty 9.04 x86_64. I figured out how to get synclient working by doing the following:

Code:
sudo cat >> /etc/hal/fdi/policy/shmconfig.fdi << EOF
<?xml version=”1.0″ encoding=”ISO-8859-1″?>
<deviceinfo version=”0.2″>
<device>
<match key=”input.x11_driver” string=”synaptics”>
<merge key=”input.x11_options.SHMConfig” type=”string”>True</merge>
<merge key=”input.x11_options.HorizEdgeScroll” type=”string”>1</merge>
</match>
</device>
</deviceinfo>
EOF
Knowledge acquired from various sources, and I can't post the URLs thanks to the forum rules!

This allows me to use
Code:
synclient TouchpadOff=0
and
Code:
synclient TouchpadOff=1
to toggle the touchpad from the command line. The next step for me is to see if I can make the touchpad toggle button do that for me.
 
Old 08-01-2009, 10:51 PM   #13
William (Dthdealer)
Member
 
Registered: Jan 2009
Location: Sydney, Australia
Distribution: Debian Testing
Posts: 99
Blog Entries: 39

Original Poster
Rep: Reputation: 19
Any attempt to edit /etc/hal/fdi/policy/shmconfig.fdi gives me a permission denied, even as root. The file does not exist.

Should I boot into recovery mode-->root console and create the file?
 
  


Reply

Tags
disable, touchpad


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
disable touchpad MicahCarrick Linux - Laptop and Netbook 0 07-18-2004 07:23 PM
3-button mouse emulation with touchpad durvasa Linux - Laptop and Netbook 0 05-16-2004 03:54 PM
How to disable touchpad? jimbo Linux - Laptop and Netbook 3 04-04-2004 09:06 AM
Using Touchpad + USB WLAN means touchpad and keyboard stops responding randomly ultrabeam16 Linux - Laptop and Netbook 0 03-21-2004 02:19 PM
switch from 3-button ps2 to touchpad bfkeats Linux - Laptop and Netbook 11 07-07-2003 09:49 AM


All times are GMT -5. The time now is 11:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration