LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   This is the coolest Linux forum....but I still have one more question (http://www.linuxquestions.org/questions/linux-hardware-18/this-is-the-coolest-linux-forum-but-i-still-have-one-more-question-27673/)

chem1 08-11-2002 12:44 AM

This is the coolest Linux forum....but I still have one more question
 
Being a newbie....and ofr that matter a new linux convert...I am amazed at the speed at which I am getting resposes....and good ones..... to my problems


One for the gurus..

How do I change my Screen Resolution on KDE?

Thankx in advance....

tundra 08-11-2002 01:05 AM

try using Xconfigurator, since you're using redhat...
assume root privileges, then at the command prompt, type Xconfigurator. Follow the wizard through and you'll get to a part where you can change the screen resolution.

but you can try pressing "ctrl alt +" first to see if the various screen resolutions are already supported...

MasterC 08-11-2002 01:14 AM

Just a tid...

And alternatively CTRL ALT -

Oh, and yes, I love this site too. The people are all good, and very fast. Glad to be a member :)


lynch 08-11-2002 05:41 AM

The ctrl alt + and ctrl alt - only works on the numerical keypad,I believe:)
lynch

finegan 08-11-2002 03:18 PM

If all else fails, hack up the XF86Config file by hand:

pico /etc/X11/XF86Config (possibly XF86Config-4)

At the bottom look for what depth you're running, probably 16 or 24, it should be listed as DefaultDepth. Find the section for your default depth, edit the line "Modes" for the resolutions you want in the format:

Modes "1280x1024" "1024x768" "800x600"

The order they're in is the order of display, first it will try 1280, then 1024, then 800, and if it launches in 1280 say, then you can switch between them with the ctrl+alt+(+/-) like they said above.

Then, if it doesn't have a ViewPort line, you might want to add that right beneath mode:

ViewPort 0 0

That'll force X to not display past the limits of the screen.

Cheers,

Finegan, command line junky.

chem1 08-11-2002 10:01 PM

Hum...
XConfigurator says that there was aproblem with setting my Video Settings...no matter what I do
I ahve tried changing my Video Memory as well but still the same message appears :-(

Thankx in advance...

shoot2kill 08-11-2002 10:27 PM

You have to tweak around with your vertical and horizontal settings.

zLinuxz 08-12-2002 05:29 AM

and just add the additional resolutiong...what I haven't firgured out however, is when you have more than one resolution set to default...it is only the first one that doesn't get the desktop biger than the physical screen, but after the control+alt+(+), the desktop is always bigger than the screen. How can you aviod that if you don't want to keep changing the first default resolution from the Xf86config file???

realos 08-12-2002 06:08 AM

I have set 24bit color depth and 1024*768 as default and then 800*600 as the next alternative.

with default 1024+768 everything seems to be okay but the problem with 800*600 is as follows:

My monitor does not fit the windows on the screen. I have to bring the mouse to the edge of the monitor and then it scrolls to the rest of the windows.

ViewPort 0 0

does not seem to bring and change. Any idea???

thanx

tundra 08-12-2002 08:32 AM

um i think it's actually supposed to behave like that...

chem1 08-12-2002 07:19 PM

Ok, guys I changed my screen resolution using the Xconfigurator and the ctrl+alt+ (+/-) method.
Hoewever, now OpenOffice does not show ANY tool bars or menus; even the dialog boxes show only empty butons with nothing written on them

I am doomed :-(

zLinuxz 08-14-2002 01:52 AM

Quote:

Originally posted by tundra
um i think it's actually supposed to behave like that...
Well I don't like it to behave like that, and it shouldn't behave like that because it's just stupid and annoying. Someone should tell who ever is working on the XF86config project that they should fix that annoying feature of just letting the default resolution fit completely in the screen, otherwise it's a waste of time and very, very, very annoying!!

Debianewb 08-14-2002 07:15 PM

Quote:

Originally posted by chem1
...I am amazed at the speed at which I am getting resposes....
Well, at the risk of sounding impatient/-grateful or whatever: it has been days since I posted my newb-topic in the "newbies"-section ...and still no reply AT ALL! :( So one could say I'm amazed at your amazement.. ;)

Since you all seem to know your X, maybe one of u guys can take a look at my topic in the "newbies"-section: "Cannot start X:Failed to initialize core devices"... ? I really do want to learn more about Linux, but I'd also like my Xserver to work..

Eagerness is bliss..

Quote:

Thankx in advance....

Thymox 08-14-2002 07:32 PM

Hey, I don't think this is the most appropriate way to bring attention to your own thread, do you? I just checked your X-related thread and all I can see is a very long post of your X log(s). No mention of your XF86Config file; little on what you have read elsewhere and whether it is the correct way of doing things; and precious little on what you have done to sort the problem yourself. Now, if someone were to phone you up and say 'Hey, fix my car!' without really giving any history or details of the problem, then what would you do? Is it the clutch? Is it the gearbox? Who knows? The same applies here! The more information you can give us, the quicker we may be able to help you.

I hope you don't take this as me being rude, 'cause I'm actually a relaxed kinda-guy. I just don't think this was appropriate. You could have 'bumped' your thread!

Debianewb 08-14-2002 08:06 PM

Point taken.. ;) I should'nt have gone about this way.
Frustation, it seems, does influence my writing; I did NOT mean to sound "inappropriate" I just wanted to flex your attention.

Again, I appologize


All times are GMT -5. The time now is 04:14 AM.