LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 03-01-2006, 01:38 PM   #1
__spc__
Member
 
Registered: Feb 2006
Location: Bridgend, Wales
Distribution: Kubuntu 10.04.25 (Feb 2011)
Posts: 172

Rep: Reputation: 30
System bell but no sound


Hi,

I have compiled 2.6.15.4 including ALi 5451 and ASLA support, under Slackware 10.1. I get the system bell, but other audio. I have taken ALSAMIXER off mute, used ALSACTL STORE to save the settings. In KDE 3.5.1 I have all the sound-bars set to max, but seemingly no joy.

Here is lspci:
bash-3.00# lspci
00:00.0 Host bridge: ATI Technologies Inc AGP Bridge [IGP 320M] (rev 13)
00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 320M] (rev 01)
00:07.0 ISA bridge: ALi Corporation M1533 PCI to ISA Bridge [Aladdin IV]
00:08.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link Controller Audio Device (rev 02)
00:09.0 Modem: ALi Corporation Intel 537 [M5457 AC-Link Modem]
00:0a.0 CardBus bridge: Texas Instruments PCI4410 PC card Cardbus Controller (rev 02)
00:0a.1 FireWire (IEEE 1394): Texas Instruments PCI4410 FireWire Controller (rev 02)
00:0c.0 Network controller: Broadcom Corporation BCM94306 802.11g (rev 03)
00:0d.0 USB Controller: NEC Corporation USB (rev 43)
00:0d.1 USB Controller: NEC Corporation USB (rev 43)
00:0d.2 USB Controller: NEC Corporation USB 2.0 (rev 04)
00:0e.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)
00:10.0 IDE interface: ALi Corporation M5229 IDE (rev c4)
00:11.0 Bridge: ALi Corporation M7101 PMU
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility U1

Here is dmesg:
Linux version 2.6.15.4 (root@laptop) (gcc version 3.3.4) #1 Sat Feb 25 08:31:13 GMT 2006
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009f800 (usable)
BIOS-e820: 000000000009f800 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000d0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000001eef0000 (usable)
BIOS-e820: 000000001eef0000 - 000000001eeff000 (ACPI data)
BIOS-e820: 000000001eeff000 - 000000001ef00000 (ACPI NVS)
BIOS-e820: 000000001ef00000 - 000000001f000000 (usable)
BIOS-e820: 00000000fff80000 - 0000000100000000 (reserved)
496MB LOWMEM available.
On node 0 totalpages: 126976
DMA zone: 4096 pages, LIFO batch:0
DMA32 zone: 0 pages, LIFO batch:0
Normal zone: 122880 pages, LIFO batch:31
HighMem zone: 0 pages, LIFO batch:0
DMI 2.3 present.
ACPI: RSDP (v000 ARIMA ) @ 0x000f7680
ACPI: RSDT (v001 PTLTD RSDT 0x06040000 LTP 0x00000000) @ 0x1eefae80
ACPI: FADT (v001 ARIMA W720-K7 0x06040000 PTL_ 0x000f4240) @ 0x1eefee53
ACPI: SSDT (v001 PTLTD POWERNOW 0x06040000 LTP 0x00000001) @ 0x1eefeec7
ACPI: DSDT (v001 ARIMA W720-K7 0x06040000 MSFT 0x0100000d) @ 0x00000000
ACPI: PM-Timer IO Port: 0x8008
Allocating PCI resources starting at 20000000 (gap: 1f000000:e0f80000)
Built 1 zonelists
Kernel command line: BOOT_IMAGE=Linux_2.6.15.4 ro root=306
Initializing CPU#0
PID hash table entries: 2048 (order: 11, 32768 bytes)
Detected 1987.800 MHz processor.
Using pmtmr for high-res timesource
Console: colour VGA+ 80x25
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 498872k/507904k available (2742k kernel code, 8436k reserved, 918k data, 192k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay using timer specific routine.. 3977.77 BogoMIPS (lpj=7955543)
Mount-cache hash table entries: 512
CPU: After generic identify, caps: 0383f9ff c1cbf9ff 00000000 00000000 00000000 00000000 00000000
CPU: After vendor identify, caps: 0383f9ff c1cbf9ff 00000000 00000000 00000000 00000000 00000000
CPU: CLK_CTL MSR was 60071263. Reprogramming to 20071263
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 512K (64 bytes/line)
CPU: After all inits, caps: 0383f9ff c1cbf9ff 00000000 00000020 00000000 00000000 00000000
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
mtrr: v2.0 (20020519)
CPU: AMD Mobile AMD Athlon(tm) XP 2600+ stepping 00
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
ACPI: setting ELCR to 0200 (from 0c20)
NET: Registered protocol family 16
ACPI: bus type pci registered
PCI: PCI BIOS revision 2.10 entry at 0xfd88e, last bus=1
PCI: Using configuration type 1
ACPI: Subsystem revision 20050902
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Probing PCI hardware (bus 00)
PCI quirk: region 8000-803f claimed by ali7101 ACPI
PCI quirk: region 8040-805f claimed by ali7101 SMB
Boot video device is 0000:01:05.0
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Link [LNK0] (IRQs 3 4 5 6 7 10 11 12) *0, disabled.
ACPI: PCI Interrupt Link [LNK1] (IRQs 3 4 5 6 7 10 *11 12)
ACPI: PCI Interrupt Link [LNK2] (IRQs 3 4 5 6 7 *10 11 12)
ACPI: PCI Interrupt Link [LNK3] (IRQs 3 4 5 6 7 10 *11 12)
ACPI: PCI Interrupt Link [LNK4] (IRQs 3 4 5 6 7 10 11 12) *0, disabled.
ACPI: PCI Interrupt Link [LNK5] (IRQs 3 4 5 6 7 10 11 12) *0, disabled.
ACPI: PCI Interrupt Link [LNK6] (IRQs 3 4 *5 6 7 10 11 12)
ACPI: PCI Interrupt Link [LNK7] (IRQs 3 4 5 6 7 10 *11 12)
ACPI: PCI Interrupt Link [LNK8] (IRQs 3 4 5 6 7 10 11 12) *0, disabled.
ACPI: Embedded Controller [EC] (gpe 24)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.AGP_._PRT]
Linux Plug and Play Support v0.97 (c) Adam Belay
SCSI subsystem initialized
usbcore: registered new driver usbfs
usbcore: registered new driver hub
PCI: Using ACPI for IRQ routing
PCI: If a device doesn't work, try "pci=routeirq". If it helps, post a report
Bluetooth: Core ver 2.8
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
PCI: Bridge: 0000:00:01.0
IO window: 9000-9fff
MEM window: d0100000-d01fffff
PREFETCH window: e0000000-efffffff
PCI: Bus 2, cardbus bridge: 0000:00:0a.0
IO window: 00001000-000010ff
IO window: 00001400-000014ff
PREFETCH window: 20000000-21ffffff
MEM window: 22000000-23ffffff
ACPI: PCI Interrupt Link [LNK2] enabled at IRQ 10
PCI: setting IRQ 10 as level-triggered
ACPI: PCI Interrupt 0000:00:0a.0[A] -> Link [LNK2] -> GSI 10 (level, low) -> IRQ 10
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
apm: overridden by ACPI.
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
Initializing Cryptographic API
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered
ATI Northbridge, reserving I/O ports 0x3b0 to 0x3bb.
Activating ISA DMA hang workarounds.
ACPI: AC Adapter [AC] (on-line)
ACPI: Battery Slot [BAT0] (battery present)
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Real Time Clock Driver v1.12
PNP: No PS/2 controller found. Probing ports directly.
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
ACPI: PCI Interrupt Link [LNK6] enabled at IRQ 5
PCI: setting IRQ 5 as level-triggered
ACPI: PCI Interrupt 0000:00:09.0[A] -> Link [LNK6] -> GSI 5 (level, low) -> IRQ 5
0000:00:09.0: ttyS0 at I/O 0x8828 (irq = 5) is a 8250
0000:00:09.0: ttyS1 at I/O 0x8840 (irq = 5) is a 8250
0000:00:09.0: ttyS2 at I/O 0x8850 (irq = 5) is a 8250
0000:00:09.0: ttyS3 at I/O 0x8860 (irq = 5) is a 8250
Couldn't register serial port 0000:00:09.0: -28
RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize
arlan: No Arlan devices found
STRIP: Version 1.3A-STUART.CHESHIRE (unlimited channels)
orinoco 0.15rc3 (David Gibson <hermes@gibson.dropbear.id.au>, Pavel Roskin <proski@gnu.org>, et al)
orinoco_plx 0.15rc3 (Pavel Roskin <proski@gnu.org>, David Gibson <hermes@gibson.dropbear.id.au>, Daniel Barlow <dan@telent.net>)
orinoco_pci 0.15rc3 (Pavel Roskin <proski@gnu.org>, David Gibson <hermes@gibson.dropbear.id.au> & Jean Tourrilhes <jt@hpl.hp.com>)
orinoco_tmd 0.15rc3 (Joerg Dorchain <joerg@dorchain.net>)
orinoco_nortel 0.15rc3 (Tobias Hoffmann & Christoph Jungegger <disdos@traum404.de>)
airo: Probing for PCI adapters
airo: Finished probing for PCI adapters
Loaded prism54 driver, version 1.2
hostap_plx: 0.4.4-kernel (Jouni Malinen <jkmaline@cc.hut.fi>)
hostap_pci: 0.4.4-kernel (Jouni Malinen <jkmaline@cc.hut.fi>)
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
alim15x3: ATI Radeon IGP Northbridge is not yet fully tested.
ALI15X3: IDE controller at PCI slot 0000:00:10.0
ACPI: PCI Interrupt 0000:00:10.0[A]: no GSI
ALI15X3: chipset revision 196
ALI15X3: not 100% native mode: will probe irqs later
ide0: BM-DMA at 0x8080-0x8087, BIOS settings: hdaMA, hdbio
ide1: BM-DMA at 0x8088-0x808f, BIOS settings: hdcMA, hddio
Probing IDE interface ide0...
hda: IC25N060ATMR04-0, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Probing IDE interface ide1...
hdc: PIONEER DVD-RW DVR-K12D, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
hda: max request size: 128KiB
hda: 117210240 sectors (60011 MB) w/7884KiB Cache, CHS=16383/255/63, UDMA(100)
hda: cache flushes supported
hda: hda1 hda2 < hda5 hda6 hda7 hda8 >
hdc: ATAPI 24X DVD-ROM DVD-R CD-R/RW drive, 2000kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
ieee1394: Initialized config rom entry `ip1394'
ACPI: PCI Interrupt Link [LNK1] enabled at IRQ 11
PCI: setting IRQ 11 as level-triggered
ACPI: PCI Interrupt 0000:00:0d.2[C] -> Link [LNK1] -> GSI 11 (level, low) -> IRQ 11
ehci_hcd 0000:00:0d.2: EHCI Host Controller
ehci_hcd 0000:00:0d.2: new USB bus registered, assigned bus number 1
ehci_hcd 0000:00:0d.2: irq 11, io mem 0xd000c800
ehci_hcd 0000:00:0d.2: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 5 ports detected
usbcore: registered new driver usblp
drivers/usb/class/usblp.c: v0.13: USB Printer Device Class driver
Initializing USB Mass Storage driver...
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
usbcore: registered new driver hiddev
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.6:USB HID core driver
usbcore: registered new driver usbled
mice: PS/2 mouse device common for all mice
inport.c: Didn't find InPort mouse at 0x23c
input: PC Speaker as /class/input/input0
Advanced Linux Sound Architecture Driver Version 1.0.10rc3 (Mon Nov 07 13:30:21 2005 UTC).
ACPI: PCI Interrupt Link [LNK7] enabled at IRQ 11
ACPI: PCI Interrupt 0000:00:08.0[A] -> Link [LNK7] -> GSI 11 (level, low) -> IRQ 11
input: AT Translated Set 2 keyboard as /class/input/input1
atkbd.c: Spurious ACK on isa0060/serio0. Some program, like XFree86, might be trying access hardware directly.
Synaptics Touchpad, model: 1, fw: 5.9, id: 0x236eb3, caps: 0x904713/0x10008
input: SynPS/2 Synaptics TouchPad as /class/input/input2
AC'97 1 does not respond - RESET
AC'97 1 access is not valid [0xffffffff], removing mixer.
ali mixer 1 creating error.
ALSA device list:
#0: ALI 5451 at 0x8400, irq 11
NET: Registered protocol family 2
IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
TCP established hash table entries: 16384 (order: 4, 65536 bytes)
TCP bind hash table entries: 16384 (order: 4, 65536 bytes)
TCP: Hash tables configured (established 16384 bind 16384)
TCP reno registered
TCP bic registered
Initializing IPsec netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
ieee80211: 802.11 data/management/control stack, git-1.1.7
ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
ieee80211_crypt: registered algorithm 'NULL'
ieee80211_crypt: registered algorithm 'WEP'
Using IPI Shortcut mode
ACPI wakeup devices:
SLPB PWRB LID KBC0 CRD0 NICD USB3 USB4 USB5 MODM
ACPI: (supports S0 S3 S4 S5)
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 192k freed
Adding 1028120k swap on /dev/hda7. Priority:-1 extents:1 across:1028120k
Linux agpgart interface v0.101 (c) Dave Jones
NTFS driver 2.1.25 [Flags: R/W MODULE].
NTFS volume version 3.1.
NTFS volume version 3.1.
ACPI: PCI Interrupt 0000:00:0a.0[A] -> Link [LNK2] -> GSI 10 (level, low) -> IRQ 10
Yenta: CardBus bridge found at 0000:00:0a.0 [161f:2029]
Yenta: Using CSCINT to route CSC interrupts to PCI
Yenta: Routing CardBus interrupts to PCI
Yenta TI: socket 0000:00:0a.0, mfunc 0x01001c00, devctl 0x64
Yenta: ISA IRQ mask 0x00f8, PCI irq 10
Socket status: 30000006
b44.c:v0.97 (Nov 30, 2005)
ACPI: PCI Interrupt Link [LNK3] enabled at IRQ 11
ACPI: PCI Interrupt 0000:00:0e.0[A] -> Link [LNK3] -> GSI 11 (level, low) -> IRQ 11
eth0: Broadcom 4400 10/100BaseT Ethernet 00:03:25:18:05:fd
ohci_hcd: 2005 April 22 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
ACPI: PCI Interrupt 0000:00:0d.0[A] -> Link [LNK1] -> GSI 11 (level, low) -> IRQ 11
ohci_hcd 0000:00:0d.0: OHCI Host Controller
ohci_hcd 0000:00:0d.0: new USB bus registered, assigned bus number 2
ohci_hcd 0000:00:0d.0: irq 11, io mem 0xd000a000
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 3 ports detected
ACPI: PCI Interrupt 0000:00:0d.1[B] -> Link [LNK1] -> GSI 11 (level, low) -> IRQ 11
ohci_hcd 0000:00:0d.1: OHCI Host Controller
usb 2-2: new full speed USB device using ohci_hcd and address 2
ohci_hcd 0000:00:0d.1: new USB bus registered, assigned bus number 3
ohci_hcd 0000:00:0d.1: irq 11, io mem 0xd000b000
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
hub 2-2:1.0: USB hub found
hub 2-2:1.0: 4 ports detected
usb 2-2.1: new low speed USB device using ohci_hcd and address 3
input: Logitech USB Trackball as /class/input/input3
input: USB HID v1.10 Mouse [Logitech USB Trackball] on usb-0000:00:0d.0-2.1
usb 2-2.4: new full speed USB device using ohci_hcd and address 4
Bluetooth: HCI USB driver ver 2.9
usbcore: registered new driver hci_usb
ohci1394: $Rev: 1313 $ Ben Collins <bcollins@debian.org>
ACPI: PCI Interrupt 0000:00:0a.1[A] -> Link [LNK2] -> GSI 10 (level, low) -> IRQ 10
ohci1394: fw-host0: OHCI-1394 1.0 (PCI): IRQ=[10] MMIO=[d000c000-d000c7ff] Max Packet=[2048]
agpgart: Detected Ati IGP320/M chipset
agpgart: AGP aperture is 64M @ 0xd4000000
ieee1394: Host added: ID:BUS[0-00:1023] GUID[000325211902a344]
eth1394: $Rev: 1312 $ Ben Collins <bcollins@debian.org>
eth1394: eth1: IEEE-1394 IPv4 over 1394 Ethernet (fw-host0)
USB Universal Host Controller Interface driver v2.3
ndiswrapper version 1.10 loaded (preempt=no,smp=no)
ndiswrapper: driver bcmwl5 (WLAN,07/17/2003, 3.30.15.0) loaded
ACPI: PCI Interrupt 0000:00:0c.0[A] -> Link [LNK2] -> GSI 10 (level, low) -> IRQ 10
ndiswrapper: using irq 10
wlan0: vendor: ''
wlan0: ndiswrapper ethernet device 00:90:96:bb:b5:c2 using driver bcmwl5, 14E4:4320:144F:7050.5.conf
wlan0: encryption modes supported: WEP; TKIP with WPA; AES/CCMP with WPA
[drm] Initialized drm 1.0.0 20040925
ACPI: PCI Interrupt 0000:01:05.0[A] -> Link [LNK2] -> GSI 10 (level, low) -> IRQ 10
[drm] Initialized radeon 1.19.0 20050911 on minor 0:
mtrr: 0xe0000000,0x10000000 overlaps existing 0xe0000000,0x1000000
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V2 device at 0000:01:05.0 into 4x mode
usb 2-2: USB disconnect, address 2
usb 2-2.1: USB disconnect, address 3
usb 2-2.4: USB disconnect, address 4

Any pointers would be gratefully appreciated.
 
Old 03-01-2006, 08:31 PM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Check your sound configuration section in your .config file, maybe you forgot something;

AC'97 1 does not respond - RESET
AC'97 1 access is not valid [0xffffffff], removing mixer.
ali mixer 1 creating error.
ALSA device list:
#0: ALI 5451 at 0x8400, irq 11
 
Old 03-02-2006, 12:59 AM   #3
__spc__
Member
 
Registered: Feb 2006
Location: Bridgend, Wales
Distribution: Kubuntu 10.04.25 (Feb 2011)
Posts: 172

Original Poster
Rep: Reputation: 30
Thanks - just checked .config and found under Sound > PCI devices that ATI IXP AC97 Controller was not installed.

Last edited by __spc__; 03-02-2006 at 01:02 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mepis - system bell satinet MEPIS 2 03-09-2006 04:23 AM
No sound system bell-9.2 akihandyman Mandriva 1 02-11-2004 06:34 PM
No sound aRTs and system bell(mdk9.2) akihandyman Mandriva 0 02-09-2004 02:26 PM
System Bell quit working in KDE falcon56215 Linux - Software 2 10-22-2003 02:44 PM
kde system bell only works for root mrtwice Linux - Software 2 07-08-2003 10:21 AM


All times are GMT -5. The time now is 03:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration