LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 03-20-2008, 07:50 PM   #1
etotheidotpy
LQ Newbie
 
Registered: Jan 2008
Location: Vancouver, BC
Distribution: Fedora 8
Posts: 11

Rep: Reputation: 0
Swap partition not being mounted after moving it


Hi,

I recently repartitioned my hard drive; I moved my swap partition so that I could grow my /home partition (it was getting pretty full.)

Upon booting (Fedora 8; kernel 2.6.24.3-34.fc8), I saw a message stating that it could not mount my swap partition. (which would be /dev/sda4)

The contents of my /etc/fstab file are:
Code:
LABEL=/1                /                       ext3    defaults        1 1
LABEL=/home             /home                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
LABEL=SWAP-sda4         swap                    swap    defaults        0 0
And /sbin/fdisk -l returns:
Code:
Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x95aa95aa

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        1786    14341288+   7  HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2            1787        3698    15358140    5  Extended
/dev/sda3            3699        9435    46082452+  83  Linux
/dev/sda4            9603        9729     1020127+  82  Linux swap / Solaris
/dev/sda5            1787        3061    10241406   83  Linux
Under gparted, I see that the swap partition currently has no label or mountpoint.

Help, please?

Last edited by etotheidotpy; 03-20-2008 at 07:54 PM.
 
Old 03-20-2008, 07:54 PM   #2
slackhack
Senior Member
 
Registered: Jun 2004
Distribution: Arch, Debian, Slack
Posts: 1,016

Rep: Reputation: 46
a guess: try referring to it in fstab as the device instead of by the label? maybe the label is messed up.
 
Old 03-20-2008, 08:33 PM   #3
etotheidotpy
LQ Newbie
 
Registered: Jan 2008
Location: Vancouver, BC
Distribution: Fedora 8
Posts: 11

Original Poster
Rep: Reputation: 0
I just tried that, and I got the same error during booting:
Unable to access resume device (LABEL=SWAP-sda4)
 
Old 03-20-2008, 08:45 PM   #4
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,593

Rep: Reputation: 188Reputation: 188
Try changing your swap line in /etc/fstab from:

LABEL=SWAP-sda4 swap swap defaults 0 0

to:

LABEL=SWAP-sda4 none swap sw 0 0


-------------------
Steve Stites
 
Old 03-20-2008, 09:03 PM   #5
etotheidotpy
LQ Newbie
 
Registered: Jan 2008
Location: Vancouver, BC
Distribution: Fedora 8
Posts: 11

Original Poster
Rep: Reputation: 0
Okay, I tried that; however, still no luck.
 
Old 03-20-2008, 09:04 PM   #6
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,505

Rep: Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079
Quote:
Originally Posted by etotheidotpy View Post
I just tried that, and I got the same error during booting:
Unable to access resume device (LABEL=SWAP-sda4)
Read the message - it's the resume partition reference it's complaining about. Check your boot-loader parameters.
 
Old 03-20-2008, 09:42 PM   #7
etotheidotpy
LQ Newbie
 
Registered: Jan 2008
Location: Vancouver, BC
Distribution: Fedora 8
Posts: 11

Original Poster
Rep: Reputation: 0
Ah, thanks for noticing that.

I just took a look at /boot/grub/grub.conf; this is what I have:
Code:
default=0
timeout=25
splashimage=(hd0,4)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.24.3-34.fc8)
	root (hd0,4)
	kernel /boot/vmlinuz-2.6.24.3-34.fc8 ro root=LABEL=/1 rhgb quiet
	initrd /boot/initrd-2.6.24.3-34.fc8.img
title Fedora (2.6.24.3-12.fc8)
	root (hd0,4)
	kernel /boot/vmlinuz-2.6.24.3-12.fc8 ro root=LABEL=/1 rhgb quiet
	initrd /boot/initrd-2.6.24.3-12.fc8.img
title Windows
	rootnoverify (hd0,0)
	chainloader +1
I'm not seeing a mention of a resume device there; what should I do?



edit: Here's menu.lst:
Code:
default=0
timeout=25
splashimage=(hd0,4)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.24.3-34.fc8)
	root (hd0,4)
	kernel /boot/vmlinuz-2.6.24.3-34.fc8 ro root=LABEL=/1 rhgb quiet
	initrd /boot/initrd-2.6.24.3-34.fc8.img
title Fedora (2.6.24.3-12.fc8)
	root (hd0,4)
	kernel /boot/vmlinuz-2.6.24.3-12.fc8 ro root=LABEL=/1 rhgb quiet
	initrd /boot/initrd-2.6.24.3-12.fc8.img
title Windows
	rootnoverify (hd0,0)
	chainloader +1

Last edited by etotheidotpy; 03-20-2008 at 09:56 PM.
 
Old 03-20-2008, 09:47 PM   #8
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,505

Rep: Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079
Me too - what does menu.lst look like ???.
 
Old 03-20-2008, 09:53 PM   #9
slackhack
Senior Member
 
Registered: Jun 2004
Distribution: Arch, Debian, Slack
Posts: 1,016

Rep: Reputation: 46
check out this thread:
http://forums.fedoraforum.org/showthread.php?t=111565
 
Old 03-20-2008, 10:28 PM   #10
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,505

Rep: Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079
Hopefully the mkswap was done - I had presumed so.
Else I'd be inclined to use noresume (just once).
 
Old 03-20-2008, 10:58 PM   #11
slackhack
Senior Member
 
Registered: Jun 2004
Distribution: Arch, Debian, Slack
Posts: 1,016

Rep: Reputation: 46
Quote:
Originally Posted by syg00 View Post
Hopefully the mkswap was done - I had presumed so.
Else I'd be inclined to use noresume (just once).
yes hopefully, but read down about the initrd.

OP you might try adding the resume=/dev/sda4 option first before trying noresume or rebuilding the initrd.
 
Old 03-21-2008, 06:58 PM   #12
etotheidotpy
LQ Newbie
 
Registered: Jan 2008
Location: Vancouver, BC
Distribution: Fedora 8
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by syg00 View Post
Hopefully the mkswap was done - I had presumed so.
Yeah, I did that.

Quote:
Originally Posted by slackhack
adding the resume=/dev/sda4 option
I just did that and the error is not appearing anymore when I boot. (Which I'm presuming means it's fixed.) Thanks!

And a big thank you to all of you.
 
  


Reply

Tags
labels, mount, mounting, partitions, resume, swap


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
swap partition not being mounted at boot lothario Linux - General 5 11-23-2007 08:17 AM
WARNING! When deleting or moving swap partition! IsaacKuo Debian 30 05-21-2007 11:56 AM
Moving a swap partition? Ahmed Linux - Hardware 7 09-30-2005 01:18 PM
swap partition not mounted after Debian installation codeape Linux - Hardware 4 02-12-2004 04:11 PM
swap partition not being mounted jclark00001 Linux - Newbie 28 02-15-2003 04:07 AM


All times are GMT -5. The time now is 07:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration