LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-17-2006, 04:17 AM   #1
stny
LQ Newbie
 
Registered: Jan 2006
Location: Hong Kong
Distribution: Fedora 4
Posts: 22

Rep: Reputation: 15
Suspend mode problem


When I start a progamme before going to X-windows, after about 20 minutes the monitor go to suspend mode ( black screen ) automatically, but I have turn off all screen saver and power management settings in Linux FC4 as below, and I also turn off suspend mode and APIC functions at mainboard CMOS setting, so apart from this setting, how can I set (either in Linux or CMOS) to control the monitor not go to suspend mode after a certain of time?
 
Old 01-18-2006, 12:51 AM   #2
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Quote:
When I start a progamme before going to X-windows
I don't understand this distinction - you are starting the program from the text-mode?
Quote:
I have turn off all screen saver and power management settings in Linux FC4 as below
"below" where? How did you turn off all power management and screensaver settings?

Does this happen for just one program or for all programs?

Do you start the program in the command line and then x-windows loads and then the screen suspends?

When you move the mouse, or touch a key, the screen returns?

The normal way to disable the screensaver in FC4 (Gnome) is:

main menue > desktop > preferences > screensaver

click the "mode" button, and select "disable screensaver".

Is this what you did?

If this is an acpi/apm suspend, you can turn these survices off on the kernel line in grub.conf or by using:

main menue > desktop > system settings > server settings > services

highlight the service you want to stop and click "stop".

Which did you do?

Aside: please put your location and distrbution in your profile. Thanks.
 
Old 01-20-2006, 03:14 AM   #3
stny
LQ Newbie
 
Registered: Jan 2006
Location: Hong Kong
Distribution: Fedora 4
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Simon Bridge
I don't understand this distinction - you are starting the program from the text-mode?"below" where? How did you turn off all power management and screensaver settings?

Does this happen for just one program or for all programs?

Do you start the program in the command line and then x-windows loads and then the screen suspends?

When you move the mouse, or touch a key, the screen returns?

The normal way to disable the screensaver in FC4 (Gnome) is:

main menue > desktop > preferences > screensaver

click the "mode" button, and select "disable screensaver".

Is this what you did?

If this is an acpi/apm suspend, you can turn these survices off on the kernel line in grub.conf or by using:

main menue > desktop > system settings > server settings > services

highlight the service you want to stop and click "stop".

Which did you do?

Aside: please put your location and distrbution in your profile. Thanks.
Thanks your reply.

Yes. When i move mouse or touch a key, the screen return.

I have put the command in the ~/.bashrc to start the program.
So this happen when pass the login screen but before the x-window load the module.
i tried stop the acpi/apm by using
main menue > desktop > system settings > server settings > services
After done this. The pc will not run into screen suspends, but when i start the program by command in ~/./bashrc before load the module, this problem pop up again.
 
Old 02-08-2006, 12:07 AM   #4
stny
LQ Newbie
 
Registered: Jan 2006
Location: Hong Kong
Distribution: Fedora 4
Posts: 22

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by stny
Thanks your reply.

Yes. When i move mouse or touch a key, the screen return.

I have put the command in the ~/.bashrc to start the program.
So this happen when pass the login screen but before the x-window load the module.
i tried stop the acpi/apm by using
main menue > desktop > system settings > server settings > services
After done this. The pc will not run into screen suspends, but when i start the program by command in ~/./bashrc before load the module, this problem pop up again.
I solve this problem.
using xset command to stop the X11 dpms and screen saver
"xset -dpms"
"xset s off"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Won't come out of Suspend Mode... caps_phisto Linux - General 1 01-10-2006 03:13 AM
turn off suspend mode messiahnet Linux - Software 1 05-09-2005 10:16 AM
Change suspend mode defaults scottman Linux - Newbie 5 09-20-2004 11:08 AM
help turning off suspend mode billman424 Linux - Laptop and Netbook 1 03-27-2004 05:03 AM
apmd problem on Aurox (suspend mode) psionides Linux - Laptop and Netbook 2 11-12-2003 11:31 AM


All times are GMT -5. The time now is 04:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration