LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-04-2009, 02:44 PM   #1
catholiccomposer
LQ Newbie
 
Registered: May 2009
Posts: 2

Rep: Reputation: 0
SUSE not recognizing cloned hard drive


I had an old box with a 40G HD acting as a server and wanted to upgrade it to a 200G. I cloned the HD and everything looked like it worked. When it boot, though, it says

Code:
Could not find /dev/disk/by-id/scsi-SATA_IC35...
Want me to fall back to /dev/disk/by-id/scsi-SATA_IC35...? (Y/n)
I'm relatively new to Linux, so I have no idea what to do here. Is there any way I can fix this?
 
Old 05-04-2009, 03:58 PM   #2
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,228
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Each disk gets a unique ID. so since your system was setup to boot using disk-by-id you may need to fix the mappings for the new drive..

http://www.nslu2-linux.org/wiki/HowTo/MountDisksByLabel

you may need to look at several files.. and make sure the disk id's match up to the appropriate partitions.

/boot/grub/device.map
/boot/grub/menu.lst
/boot/grub/grub.conf
/etc/fstab
 
Old 05-05-2009, 01:48 PM   #3
catholiccomposer
LQ Newbie
 
Registered: May 2009
Posts: 2

Original Poster
Rep: Reputation: 0
Awesome, thanks! I'll try that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Having a hard time making linux recognizing my new external hard drive jared nelson Linux - Hardware 19 03-24-2009 03:39 PM
I cloned a dual boot drive Windows and SUSE with Acronis ERROR 17 azhirise Suse/Novell 3 03-05-2009 05:27 PM
puzzling: NIC goes away if I use a cloned hard drive BrianK Linux - Hardware 5 03-12-2007 02:18 AM
Problem recognizing hard drive Pontius Linux - Hardware 2 06-23-2004 01:09 AM
problem recognizing seagate hard drive nom the unwise Linux - Hardware 1 02-09-2004 08:07 PM


All times are GMT -5. The time now is 04:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration