LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Suse 9.3 & WD external hard drive TO SLOW !! (http://www.linuxquestions.org/questions/linux-hardware-18/suse-9-3-and-wd-external-hard-drive-to-slow-320091/)

memo007 05-04-2005 01:34 PM

Suse 9.3 & WD external hard drive TO SLOW !!
 
I bought a 120 gb Wd external harddrive usb 2.0 and it only has about 1 mb per second.
And on windows it has 50mb per second transfer rate.
Is there any way to fix that ??

Oholiab 05-05-2005 01:01 PM

It may be the filesystem. I don't know much about this, but I would suggest that if you only use the hdd with Linux, then format it as ext2, ext3 or reiserfs.

mshahwan 05-27-2005 02:09 AM

same problem
 
i have a similar problem , i have a 40 gb usb 2.0 drive with a write speed of 1 Mb/s on suse 9.2. I think suse screwed something up with the subfs starting with the utf8 icharset. but thats not the case, something is diffenitly wrong, i was playing around with the subfs config files and i hit a 28Mb/s write speed, i wish i can recall what exactly that i changed. if anyone have a similar situation please feel free to share ur intake

mshahwan 01-07-2006 08:30 AM

I had all kinds of problems with external USB hardrives. the final solution to all of my problems is POWER. the USB bus can only provide 5.0v @ 500mA. The Problem is there is not many HD that can run on 500mA even 2.5 inch laptop onces. so check the drive and if the drive consumes more than 500mA run to the nearest hardware store and buy a 5.0v @ 1200mA+ power adapter. Since I swithed to a new 2100mA adapter I had no problems what so ever.

p.s the filesystem u use has no effect what so ever.

brianbdl 01-08-2006 10:33 PM

I had the same problem before. Fast read access to external USB HD but painfully slow write access. The problem turned out to be the fact that subfs was mounting the external HD with the sync option. This causes the write operations to wait until completion before continuing with the next one. This is done for safety of data on external media in case of accidental disconnection. The normal internal HD's are mounted without the sync option.

To speed up write access to the external HD, just remount with the 'nosync' option. Eg initially, mount shows the USB HD mounted with 'sync':

/dev/sdc6 on /media/usbdisk_2 type subfs (rw,nosuid,nodev,sync,fs=reiserfs)

Run mount command to remount with nosync like this:

mount -o remount,nosync /dev/sdc6 /media/usbdisk_2

Now mount shows:

/dev/sdc6 on /media/usbdisk_2 type subfs (rw,nosync)

and you can enjoy full speed writes. There's probably a way to configure subfs to do this permanently but I haven't bothered looking into it yet.


All times are GMT -5. The time now is 09:39 AM.