LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-19-2004, 09:10 AM   #1
davidhilbert
LQ Newbie
 
Registered: Nov 2004
Posts: 14

Rep: Reputation: 0
Suse 9.2 usb memory stick problem, system hangs


I have just updated my system from SuSe 9.0 to 9.2 - this has upded by kernel from 2.4 to 2.6 and my KDE from 3.? to 3.3.

Under 9.0 when I wanted to use my usb 2.0 flash memory stick, I would mount it in KDE, and it was a bit flakey but no real problem. In 9.2, KDE automatically mounts the device. It does this fine, but when I try and navigate through the files in Konquerer, the whole system completely hangs, to a degree I didn't think was possible in Linux - I can't even get to a command line to shutdown. Total disaster. I left it 20 minutes and then just cut the power, not something I want to do again.

My question is, where do I start investigating - KDE? Kernel? Device drivers? I'm a bit of a newbie, so any ideas would be much appreciated.
 
Old 11-19-2004, 12:35 PM   #2
bquest
LQ Newbie
 
Registered: Nov 2004
Posts: 2

Rep: Reputation: 0
system freeze

Hi, I have a similar and a different problem, the similar problem is, that the external USB HD IOMEGA 80 GB and the iRiver Jukebox were correctly mounted, but after a certain amount of transactions the system undergoes a hard freeze, just like you experienced. I changed the following, I got all the actual SuSE Updates (there are already quite a few), I updated to KDE 3.3.1 (with the packages found on the suse server) and I disabled the SuSE watcher.

I know this is not the scientific way of addressing the problem, but it works now without freezing.

The different problem is, that the USB Stick that worked and works under Suse 9.1, Mepis and Mandrake 10.0 refuses to work with 9.2 ... it can't be that difficult to have FULL USB support , except for SuSE ...

Hope it helps.

BEnjamin
 
Old 11-23-2004, 10:20 AM   #3
davidhilbert
LQ Newbie
 
Registered: Nov 2004
Posts: 14

Original Poster
Rep: Reputation: 0
I want to try mounting the device manually, ie the proper way, but kde always dows it automatically. Does anybody know how to turn this off in KDE?
 
Old 11-23-2004, 11:25 AM   #4
bquest
LQ Newbie
 
Registered: Nov 2004
Posts: 2

Rep: Reputation: 0
Hi David,
I cannot help you concerning this behavior in KDE in general, but to turn this behavior OFF in SuSE 9.2 you have to disable hotplug. This can be achieved in the following way (there might be other ways also): in the file /etc/sysconfig/hotplug there is more at the bottom of the file the option

HOTPLUG_DO_MOUNT=yes

change this into

HOTPLUG_DO_MOUNT=no

then you will have to edit your etc/fstab. Remove the device entry created by udev/hotplug and replace it with something convenient, for example:

/dev/sda1 /media/sda1 auto noauto,user,rw 0 0

(beware of the spaces, they have to be set correctly). Note that you must create the directory media/sda1 in the case above. You can also use mnt/myusbstick or whatever, but this then needs to be specified in the fstab entry. If you are in doubt which options to take, take an entry of a windows partition (if there is one ...). For a simple explanation: the first term is the device the second the directory in which it will be displayed, then comes the partitiontype ("vfat" for FAT partitions "reiserfs" for reiser and so on her the option "auto" means that the devices filesystem type will be recognized automatically (in the very most cases). "noauto" specifies that it will not be mounted at boot time you can set this to auto if you want to (useful for a USB HD that stays connected). "user" means that a user account will have the right to mount the device, "rw" means that it will be readable/writable. The digits I do not know, and there are several other options I do not really know either. Anyone yho knows a nice introduction into fstab options my post a link here ;-)

I did this hotplug "switch" yesterday and the problem seems solved by now. You can create a shortcut on the desktop pointing at the device, so the access is nearly as fast as with hotplug.

Sorry if my explanations were too lenghty, there are newbies and newbies, and I still would consider myself as one, since I found this workaround only I did not manage it myself ... so no knowhow here, only knowwhere.

BEnjamin
 
Old 11-23-2004, 11:40 AM   #5
davidhilbert
LQ Newbie
 
Registered: Nov 2004
Posts: 14

Original Poster
Rep: Reputation: 0
Thank you very much, that was extremely helpful
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
suse 10, usb memory stick thegreatgatsby Suse/Novell 17 11-02-2005 05:21 PM
SuSE 9.3 USB Memory Stick No Workee goofbaw Suse/Novell 1 08-17-2005 01:52 AM
Valid block device for USB memory stick on SUSE 9.2 amala Linux - Hardware 5 12-24-2004 12:20 PM
USB memory stick file system linmix Linux - Hardware 2 12-02-2004 05:02 PM
How do I get my USB memory stick to work in SuSE 8.2? Paul_Lee Linux - Hardware 13 02-13-2004 08:14 AM


All times are GMT -5. The time now is 01:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration