LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 08-25-2004, 10:18 AM   #1
eiffel
LQ Newbie
 
Registered: Oct 2003
Posts: 10

Rep: Reputation: 0
Unhappy Suse 9.1, Kernel 2.6.5-1.104, ati driver 3.11.1 problem


Hi there,

I am getting some problem between the ati driver and the updated version of Suse Kernel.
This is relevant to the installation of Suse on a Thinkpad T42p (T2 ati graphics card with 128M).

I installed 9.1, downloaded the Ati driver 3.11.1 from Suse X update website, installed the driver and everything worked fine. I then launch the Yast tool to automatically install the patches which included patches for the Kernel jumping from version 2.6.5.7.54 (I believe) to 2.6.5-7.104. Now the 3D acceleration does not function anymore. fglrxinfo reports that the Mesa driver is used instead of Ati's fglrx.
Has anyone had such a problem?

Thank You.

Eric
 
Old 08-25-2004, 10:42 AM   #2
Pcghost
Senior Member
 
Registered: Feb 2003
Location: The Real Washington
Distribution: Ubuntu, Debian, SuSE, UnSlung, Android
Posts: 1,819

Rep: Reputation: 46
My HP laptop uses an integrated ATI chipset as well. I chose Radeon 7000 and now I have it working well with 3D. Might be worth a shot. It seems the 7000 driver is generic enough to cover most laptop ATI cards.
 
Old 08-25-2004, 10:35 PM   #3
chrisptree
LQ Newbie
 
Registered: Jul 2004
Posts: 6

Rep: Reputation: 0
Hi eiffel

Look in the module section of your XF86Config file, and you should have a line Load "dri" and if it is not here, add it and you will have your 3D. And also, be sure to have the option
Option "UseInternalAGPGART" "no"
and have a line
/sbin/insmod agpgart
in /etc/rc.d/boot.local
with these 2 setting, I think you will get your 3D
 
Old 08-26-2004, 07:08 AM   #4
Xerop
Member
 
Registered: Jan 2004
Distribution: Suse, Red Hat
Posts: 129

Rep: Reputation: 15
look at that thread may help you.

http://www.linuxquestions.org/questi...readid=221912v
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[Suse 9.2] Installing kernel-module (ATI Drivers) problem Simkin Linux - Software 0 01-31-2005 03:58 AM
ATI 3.14.6 Driver Kernel 2.6.7 problem gotmonkey Slackware 4 11-15-2004 01:18 PM
PROBLEM WITH RUNNING GAMES : SUSE 9.1 : ATI driver op_stager Linux - Newbie 6 08-16-2004 06:04 AM
PROBLEM WITH RUNNING GAMES : SUSE 9.1 : ATI driver op_stager Linux - Software 0 08-16-2004 03:32 AM
ATI Driver problem on SuSE 9 TheOtaku Linux - Software 3 04-22-2004 04:42 PM


All times are GMT -5. The time now is 03:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration