LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   SUSE 10.3 Problems with HP Laser Jet 1200 connected to USB port (http://www.linuxquestions.org/questions/linux-hardware-18/suse-10-3-problems-with-hp-laser-jet-1200-connected-to-usb-port-819569/)

akkhcu 07-13-2010 08:03 AM

SUSE 10.3 Problems with HP Laser Jet 1200 connected to USB port
 
I have HP Laserjet 1200 which worked fine on Parallel port in earlier versions of SUSE. It works in windows even now. I install the printer with Yast. It does not print test page though connection is OK.
I stopped using a usb hub which I was using earlier.

Here is the output of hp-check. I donot know how to remove dependency problems and other errors.

If I visit localhost:631, I get a Error 404 Page Not found

====================================================================
HP Linux Imaging and Printing System (ver. 2.7.7)
Dependency/Version Check Utility ver. 10.0

Copyright (c) 2001-7 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Saving output in log file: hp-check.log

Initializing. Please wait...

---------------
| SYSTEM INFO |
---------------

Basic system information:
Linux pc20 2.6.22.5-31-bigsmp #1 SMP 2007/09/21 22:29:00 UTC i686 i686 i386 GNU/Linux

Distribution:
suse 10.3

HPOJ running?
No, HPOJ is not running (OK).

Checking Python version...
OK, version 2.5.1 installed

Checking PyQt version...
OK, version 3.17 installed.

Checking SIP version...
OK, Version 4.7 installed

Checking for CUPS...
Status: scheduler is running
Version: 1.2.12

----------------
| DEPENDENCIES |
----------------


Checking for dependency: cups - Common Unix Printing System...
OK, found.

Checking for dependency: cups-devel- Common Unix Printing System development files...
error: NOT FOUND! This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: gcc - GNU Project C and C++ Compiler...
error: NOT FOUND! This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: GhostScript - PostScript and PDF language interpreter and previewer...
OK, found.

Checking for dependency: libcrypto - OpenSSL cryptographic library...
error: NOT FOUND! This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: libjpeg - JPEG library...
error: NOT FOUND! This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: libnetsnmp-devel - SNMP networking library development files...
error: NOT FOUND! This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: libpthread - POSIX threads library...
OK, found.

Checking for dependency: libtool - Library building support services...
error: NOT FOUND! This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: libusb - USB library...
error: NOT FOUND! This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: make - GNU make utility to maintain groups of programs...
OK, found.

Checking for dependency: PIL - Python Imaging Library (required for commandline scanning with hp-scan)...
warning: NOT FOUND! This is an OPTIONAL dependency. Some HPLIP functionality may not function properly.

Checking for dependency: ppdev - Parallel port support kernel module....
error: NOT FOUND! This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: PyQt - Qt interface for Python...
OK, found.

Checking for dependency: python-devel - Python development files...
error: NOT FOUND! This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: Python 2.3 or greater - Required for fax functionality...
OK, found.

Checking for dependency: Python 2.2 or greater - Python programming language...
OK, found.

Checking for dependency: Reportlab - PDF library for Python...
warning: NOT FOUND! This is an OPTIONAL dependency. Some HPLIP functionality may not function properly.

Checking for dependency: SANE - Scanning library...
OK, found.

Checking for dependency: SANE - Scanning library development files...
OK, found.

Checking for dependency: scanimage - Shell scanning program...
OK, found.

Checking for dependency: xsane - Graphical scanner frontend for SANE...
warning: NOT FOUND! This is an OPTIONAL dependency. Some HPLIP functionality may not function properly.


----------------------
| HPLIP INSTALLATION |
----------------------


Currently installed HPLIP version...
HPLIP 2.7.7 currently installed in '/usr/share/hplip'.

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hpssd]
# Note: hpssd does not support dynamic ports
# Port 2207 is the IANA assigned port for hpssd
port=2207

[hplip]
version=2.7.7

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/cups/model/manufacturer-PPDs/hplip
ppdbase=/usr/share/cups/model/manufacturer-PPDs
doc=/usr/share/doc/packages/hplip
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
foomatic=/usr/share/foomatic

# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
foomatic-xml-install=no
foomatic-ppd-install=yes
internal-tag=2.7.7.27


----------------------
| INSTALLED PRINTERS |
----------------------


AdobePDF9
---------
Type: Unknown
Installed in HPLIP?: No, not using the hp: or hpfax: CUPS backend.
Device URI: ipp://172.16.65.210:631/printers/AdobePDF9

HP_LaserJet_1200
----------------
Type: Printer
Installed in HPLIP?: Yes, using the hp: CUPS backend.
Device URI: hp:/usb/HP_LaserJet_1200?serial=00SGCD164673
PPD: /etc/cups/ppd/HP_LaserJet_1200.ppd
PPD Description: HP LaserJet 1200 Postscript (recommended)
|^Printer status: printer HP_LaserJet_1200 disabled since Tue 13 Jul 2010 15:34:50 IST -Paused

LaserPrinter
------------
Type: Unknown
Installed in HPLIP?: No, not using the hp: or hpfax: CUPS backend.
Device URI: usb://HP/LaserJet%201200


----------------------
| SANE CONFIGURATION |
----------------------

'hpaio' in '/etc/sane.d/dll.conf'...
OK, found. SANE backend 'hpaio' is properly set up.

Checking output of 'scanimage -L'...

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).


---------------------
| PYTHON EXTENSIONS |
---------------------

Checking 'cupsext' CUPS extension...
OK, found.

Checking 'pcardext' Photocard extension...
OK, found.

Checking 'hpmudext' I/O extension...
OK, found.

Checking 'scanext' SANE scanning extension...
OK, found.


-----------------
| USB I/O SETUP |
-----------------

Checking proper HPLIP I/O setup (USB I/O only)...
error: udev "usb_device" access mode is INCORRECT: 0644 (it must be 066x)

Checking for permissions of USB attached printers...
HP Device 0x317 at 005:002:
Device URI: hp:/usb/HP_LaserJet_1200?serial=00SGCD164673
Device node: /dev/bus/usb/005/002
Mode: 0664
UID: 0 (root)
GID: 7 (lp)
Device group and mode appear correct.
HP Device 0x4105 at 002:002:
Device URI: hp:/usb/hp_scanjet?serial=CN64AA232P04CM
Device node: /dev/bus/usb/002/002
Mode: 0664
UID: 0 (root)
GID: 7 (lp)
Device group and mode appear correct.

Is user 'ashok' a member of the 'lp' group?
Yes (OK)

Is user 'guest' a member of the 'lp' group?
Yes (OK)


-----------
| SUMMARY |
-----------

error: 13 errors and/or warnings.

Please refer to the installation instructions at:
http://hplip.sourceforge.net/install/index.html
-----------------------------------------------------------------

sntnlz 07-14-2010 05:08 PM

It seems to me your problem is a minor one of missing packages and libraries. Provided your package repositories are configured with more than just the DVD and the "update" repo (i.e. you have the OSS, Non-OSS repos... etc. added). You should be able to find and install all these packages through Yast. Use the names of the missing packages as they appear in the report you posted. If you can't find one or more, try Google as some packages may have a slightly different name than what is reported by hp-check.

akkhcu 07-27-2010 04:34 AM

I downloaded

HP Linux Imaging and Printing System (ver. 3.10.6)
and tries to upgrade HPLIP. I get the following messages

INSTALL MISSING OPTIONAL DEPENDENCIES
-------------------------------------
warning: There are 4 missing OPTIONAL dependencies.
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency for option 'gui_qt4': pyqt4-dbus (PyQt 4 DBus - DBus Support for PyQt4)
warning: This installer cannot install 'pyqt4-dbus' for your distro/OS and/or version.
warning: Option 'gui_qt4' has been turned off.
warning: Missing REQUIRED dependency for option 'gui_qt4': pyqt4 (PyQt 4- Qt interface for Python (for Qt version 4.x))
==================================================================================================== =====
Is there a solution to the problem?


All times are GMT -5. The time now is 10:25 AM.