LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 05-17-2006, 02:36 PM   #1
edesmarais
LQ Newbie
 
Registered: Nov 2003
Location: Worcester, MA
Distribution: Slackware 10.2/SuSE 10.1
Posts: 25

Rep: Reputation: 15
suse 10.1 radeon 9200 pro dual head/driver problems


Problem Description:

I just installed suse 10.1 on my compaq, which has three video cards:

0: Radeon 9200 pro (128MB)
1: Radeon 9200 pro (128MB)
2: Onboard Unichrome IGP (8MB shared)

When I had windows installed, I couldn't do a dual head setup using the onboard card, hence the two radeons. However, now that I have linux, I can't get either of the radeons to work. Ultimately, I want to use a dual head setup preferrably using the radeon cards, but I'll use any combination that works. Right now, I am using the onboard card to view at a crappy resolution. In case this matters, one monitor is a sylvania 19" flat panel and the other is a 17" Dell CRT (this is the only one that works with the particular situation I'm in).

What I've Tried:

1) I tried downloading drivers from ATI. I also downloaded and ran the installer. No luck. fglrxinfo still shows that I'm using MESA.

2) I found some instructions to build a suse rpm from the above downloads. Tried it. Installed it. Restarted. No luck. I assume this all means I have no idea how to install the ati driver AND use it.

3) I tried activating the displays and dual head using the graphical sax via yast. When I try to test the settings, both monitors turn on and one monitor(the flat panel) has the X cursor and the other has colored garbage. After 2 seconds, the computer freezes and I have to cold boot.

I don't know where to go from here.

LSPCI Output:*******************************************

00:00.0 Host bridge: VIA Technologies, Inc. VT8378 [KM400/A] Chipset Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:08.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200 PRO] (rev 01)
00:08.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200 PRO] (Secondary) (rev 01)
00:09.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200 PRO] (rev 01)
00:09.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200 PRO] (Secondary) (rev 01)
00:0a.0 Communication controller: Agere Systems V.92 56K WinModem (rev 03)
00:0b.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 80)
00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller (rev 80)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
01:00.0 VGA compatible controller: VIA Technologies, Inc. VT8378 [S3 UniChrome] Integrated Video (rev 01)

Xorg.conf: *********************************************

# /.../
# SaX generated X11 config file
# Created on: 2006-05-16T20:48:39-0400.
#
# Version: 7.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (7.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "ServerLayout"
Identifier "Layout[all]"
Screen "Screen[2]" LeftOf "Screen[0]"
Screen "aticonfig Screen 1" RightOf "Screen[2]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
EndSection

Section "Files"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
EndSection

Section "Module"
Load "v4l"
Load "dbe"
Load "glx"
Load "type1"
Load "freetype"
Load "extmod"
Load "dri"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard[0]"
Driver "kbd"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Identifier "Mouse[1]"
Driver "mouse"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "Logitech Optical Wheel Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Modes"
Identifier "Modes[0]"
ModeLine "1280x1024" 105.2 1280 1360 1496 1712 1024 1025 1028 1059
ModeLine "1280x960" 97.7 1280 1352 1488 1696 960 961 964 993
ModeLine "1280x800" 80.6 1280 1344 1480 1680 800 801 804 827
ModeLine "1152x864" 78.8 1152 1216 1336 1520 864 865 868 894
ModeLine "1280x768" 77.4 1280 1344 1480 1680 768 769 772 794
ModeLine "1024x768" 61.9 1024 1080 1184 1344 768 769 772 794
ModeLine "1280x600" 58.8 1280 1328 1456 1632 600 601 604 621
ModeLine "1024x600" 47.3 1024 1064 1168 1312 600 601 604 621
ModeLine "800x600" 36.9 800 832 912 1024 600 601 604 621
ModeLine "768x576" 33.7 768 792 872 976 576 577 580 596
ModeLine "640x480" 23.1 640 656 720 800 480 481 484 497
ModeLine "1280x1024" 121.3 1280 1368 1504 1728 1024 1025 1028 1064
ModeLine "1280x1024" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
ModeLine "1280x960" 120.8 1280 1368 1504 1728 960 961 964 999
ModeLine "1280x800" 107.2 1280 1360 1496 1712 800 801 804 835
ModeLine "1152x864" 105.0 1152 1224 1352 1552 864 865 868 902
ModeLine "1280x768" 103.0 1280 1360 1496 1712 768 769 772 802
ModeLine "1024x768" 81.8 1024 1080 1192 1360 768 769 772 802
ModeLine "1280x600" 79.0 1280 1344 1480 1680 600 601 604 627
ModeLine "1024x600" 63.2 1024 1080 1184 1344 600 601 604 627
ModeLine "800x600" 48.9 800 840 920 1040 600 601 604 627
ModeLine "768x576" 45.5 768 808 888 1008 576 577 580 602
ModeLine "640x480" 30.7 640 664 728 816 480 481 484 502
ModeLine "1400x1050" 122.0 1400 1488 1640 1880 1050 1052 1064 1082
EndSection

Section "Modes"
Identifier "Modes[1]"
ModeLine "800x600" 42.1 800 840 920 1040 600 601 604 623
ModeLine "800x600" 40.8 800 832 912 1024 600 601 604 623
ModeLine "800x600" 40.2 800 832 912 1024 600 601 604 623
ModeLine "768x576" 39.8 768 800 880 992 576 577 580 599
ModeLine "768x576" 39.2 768 800 880 992 576 577 580 599
ModeLine "768x576" 38.6 768 800 880 992 576 577 580 598
ModeLine "640x480" 29.8 640 664 728 816 480 481 484 501
ModeLine "640x480" 29.4 640 664 728 816 480 481 484 501
ModeLine "640x480" 29.0 640 664 728 816 480 481 484 501
EndSection

Section "Modes"
Identifier "Modes[2]"
ModeLine "1024x768" 96.7 1024 1088 1200 1376 768 769 772 808
ModeLine "1024x768" 95.5 1024 1088 1200 1376 768 769 772 807
ModeLine "1024x768" 94.4 1024 1088 1200 1376 768 769 772 807
ModeLine "1024x600" 96.9 1024 1088 1200 1376 600 601 604 640
ModeLine "1024x600" 95.8 1024 1088 1200 1376 600 601 604 639
ModeLine "1024x600" 95.0 1024 1088 1200 1376 600 601 604 639
ModeLine "800x600" 75.5 800 848 936 1072 600 601 604 640
ModeLine "800x600" 74.7 800 848 936 1072 600 601 604 639
ModeLine "800x600" 74.0 800 848 936 1072 600 601 604 639
ModeLine "768x576" 73.0 768 824 904 1040 576 577 580 616
ModeLine "768x576" 72.3 768 824 904 1040 576 577 580 615
ModeLine "768x576" 71.6 768 824 904 1040 576 577 580 615
ModeLine "640x480" 60.6 640 680 752 864 480 481 484 520
ModeLine "640x480" 60.1 640 680 752 864 480 481 484 519
ModeLine "640x480" 59.6 640 680 752 864 480 481 484 519
EndSection

Section "Monitor"
Identifier "Monitor[0]"
VendorName "--> VESA"
ModelName "1280X1024@60HZ"
UseModes "Modes[0]"
DisplaySize 320 240
HorizSync 28.0 - 64.0
VertRefresh 50.0 - 60.0
Option "DPMS"
EndSection

Section "Monitor"
Identifier "Monitor[1]"
VendorName "Unknown"
ModelName "Unknown"
UseModes "Modes[1]"
DisplaySize 305 230
HorizSync 30.0 - 40.0
VertRefresh 43.0 - 75.0
EndSection

Section "Monitor"
Identifier "Monitor[2]"
VendorName "DELL"
ModelName "E773C"
UseModes "Modes[2]"
DisplaySize 305 230
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
EndSection

Section "Monitor"
Identifier "aticonfig Monitor 1"
EndSection

Section "Device"
Identifier "Device[0]"
Driver "fglrx"
VendorName "ATI"
BoardName "RV280 5960"
Option "SaXDualHead"
Option "1024x600" ""
Option "1024x768" ""
Option "crt1" ""
Option "SaXDualMonitorVendor" "--> VESA"
Option "HSync2" "31-70"
Option "DesktopSetup" "Horizontal"
Option "SaXDualResolution" "1280x1024"
Option "SaXDualOrientation" "LeftOf"
Option "SaXDualMode" "Xinerama"
Option "ForceMonitors" "auto,crt1"
Option "SaXDualHSync" "31-70"
Option "SaXDualMonitorModel" "1280X1024@75HZ"
Option "1280x800" ""
Option "SaXDualVSync" "50-75"
Option "VRefresh2" "50-75"
Option "Mode2" "1280x1024,1280x960,1280x800,1152x864,1280x768,1024x768,1280x600,1024x600,800x600,768x576,640x48 0"
Option "1280x960" ""
Option "768x576" ""
Option "1280x600" ""
Option "1152x864" ""
Option "1280x768" ""
Option "800x600" ""
Option "640x480" ""
BusID "0:8:0"
EndSection

Section "Device"
Identifier "Device[1]"
Driver "radeon"
VendorName "ATI"
BoardName "RV280 5960"
BusID "0:9:0"
EndSection

Section "Device"
Identifier "Device[2]"
Driver "via"
VendorName "VIA Technologies, Inc."
BoardName "KM400"
BusID "1:0:0"
EndSection

Section "Device"
Identifier "ATI Graphics Adapter 1"
Driver "fglrx"
BusID "PCI:0:8:0"
Screen 1
EndSection

Section "Screen"
Identifier "Screen[0]"
Device "Device[0]"
Monitor "Monitor[0]"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen[1]"
Device "Device[1]"
Monitor "Monitor[1]"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "800x600" "768x576" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen[2]"
Device "Device[2]"
Monitor "Monitor[2]"
DefaultDepth 16
SubSection "Display"
Depth 15
Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig Screen 1"
Device "ATI Graphics Adapter 1"
Monitor "aticonfig Monitor 1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection


#END xorg.conf

If anyone has any insight, I would GREATLY appreciate it!

Thanks!
Evan
 
Old 05-26-2006, 10:57 AM   #2
edesmarais
LQ Newbie
 
Registered: Nov 2003
Location: Worcester, MA
Distribution: Slackware 10.2/SuSE 10.1
Posts: 25

Original Poster
Rep: Reputation: 15
I don't mean to be impatient, but does ANYONE know how to solve this at all? I really need to get this up.

Thanks,
Evan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Breezy and Ati Radeon 9700 Pro dual head Kontti Ubuntu 2 10-27-2005 08:51 PM
Breezy and Ati Radeon 9700 Pro dual head Kontti Linux - Hardware 0 10-24-2005 03:44 AM
Dual Head with ATI-Radeon 9600 pro daveberg Linux - Hardware 3 01-17-2005 10:10 AM
Installing a Radeon 9200 se in SuSE 9 pro. keith Linux - Hardware 5 04-25-2004 07:25 PM
ATI Radeon 9200 on Debian, driver problems mrnicke Linux - Hardware 6 03-19-2004 01:46 PM


All times are GMT -5. The time now is 04:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration