LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   suse 10.1 DHCP client via cable modem does not give a IP address... (http://www.linuxquestions.org/questions/linux-hardware-18/suse-10-1-dhcp-client-via-cable-modem-does-not-give-a-ip-address-477334/)

jojolx 08-25-2006 01:31 PM

suse 10.1 DHCP client via cable modem does not give a IP address...
 
Hi,

I have suse 10.1 x86-64 installed on my ADM 3000+ PC,
I'd like to use Internet via cable modem,
I configured onboard network card on my MB using YaST this way (IP+DNS via DHCP):

configuration NIC via YaST:
root: YaST/Network Devices/Network card:
Network Setup Method: User Controlled with NetworkManager ->Next
Micro-Star International MCP51 Ethernet Controller/Edit
General: Firewall zone=Firewall Disabled
Device Activation=On cable Connection
Address: Automatic Address Setup (via DHCP)
Hostaname and Domain Name (Global)
Hostname=js Domain Name=home
x Change Hostname via DHCP
x Update Name Servers and Search List via DHCP ->Next

but it does not work properly... a part of log following:

Aug 25 19:28:50 js ifup: eth0 device: nVidia Corporation MCP51 Ethernet Controller (rev a1)
Aug 25 19:28:50 js ifplugd(eth0)[19233]: client: eth0 configuration: eth-id-00:13:d3:cc:6a:8c
Aug 25 19:28:50 js ifup: eth0 configuration: eth-id-00:13:d3:cc:6a:8c
Aug 25 19:28:50 js ifup: eth0 device: nVidia Corporation MCP51 Ethernet Controller (rev a1)
Aug 25 19:28:50 js ifup: eth0 configuration: eth-id-00:13:d3:cc:6a:8c
Aug 25 19:28:50 js ifup: eth0 is controlled by ifplugd
Aug 25 19:28:50 js ifup-dhcp: Starting DHCP Client Daemon on eth0...
Aug 25 19:28:50 js ifup-dhcp: .
Aug 25 19:28:51 js ifup-dhcp: .
Aug 25 19:28:52 js ifup-dhcp: .
Aug 25 19:28:53 js ifup-dhcp: .
Aug 25 19:28:54 js ifup-dhcp: .
Aug 25 19:28:55 js ifup-dhcp: no IP address yet... backgrounding.
Aug 25 19:28:55 js ifplugd(eth0)[19233]: client: Starting DHCP Client Daemon on eth0... . . . . . no IP address yet... backgrounding.
Aug 25 19:28:55 js kernel: eth0: link down.
Aug 25 19:28:55 js ifplugd(eth0)[19233]: Program execution failed, return value is 12.
Aug 25 19:28:55 js ifplugd(eth0)[19233]: Link beat lost.
Aug 25 19:28:56 js kernel: eth0: link up.
Aug 25 19:28:57 js kernel: eth0: link down.
Aug 25 19:28:58 js kernel: eth0: link up.


Can anybody advice me how to solve this problem?

Thanks in advance

J.

bigrigdriver 08-25-2006 05:05 PM

Try /usr/sbin/hwinfo --netcard. The output should tell you which driver is needed, and whether or not that driver is active.

If the required driver is not active, use locate or find to determine if you have the driver you need in the kernel modules. Is it configured into your kernel, or do you need to download it from the vendor?

If the module is on your system, but not loaded, modprobe <module name> (without the .ko or .o extension) should load the module and probe the hardware to get it working.

Finally, you could try 'dhcpcd -D eth0' to see if that helps (on SuSe, man dhcpcd; on other distros: man dhcpd). dhcpcd is SuSEs implemention of dhcpd, if I understand these things correctly.

jojolx 08-26-2006 07:08 AM

First of all thank you very much for tips you sent me.

A short recapitulation:
network card configured via YaST, using traditional (ifup) method,
firewall disabled, device activation on cable connection, IP address and DNS name servers/domain search requested from ISP provider's DHCP server,
but there is no connectivity to Internet...

I tried the following:

1) /usr/sbin/hwinfo command:

js:/etc # /usr/sbin/hwinfo --netcard
32: PCI 14.0: 0200 Ethernet controller
[Created at pci.300]
UDI: /org/freedesktop/Hal/devices/pci_10de_269
Unique ID: rBUF.FusFvqEVhu3
SysFS ID: /devices/pci0000:00/0000:00:14.0
SysFS BusID: 0000:00:14.0
Hardware Class: network
Model: "Micro-Star International MCP51 Ethernet Controller"
Vendor: pci 0x10de "nVidia Corporation"
Device: pci 0x0269 "MCP51 Ethernet Controller"
SubVendor: pci 0x1462 "Micro-Star International Co., Ltd."
SubDevice: pci 0x7207
Revision: 0xa1
Driver: "forcedeth"
Device File: eth0
Memory Range: 0xfead7000-0xfead7fff (rw,non-prefetchable)
I/O Ports: 0xc080-0xc087 (rw)
IRQ: 209 (43949 events)
HW Address: 00:13:d3:cc:6a:8c
Link detected: yes
Module Alias: "pci:v000010DEd00000269sv00001462sd00007207bc06sc80i00"
Driver Info #0:
Driver Status: forcedeth is active
Driver Activation Cmd: "modprobe forcedeth"
Config Status: cfg=no, avail=yes, need=no, active=unknown

It seems the netcard driver forcedeth is part of kernel (Mainboard MSI k8ngm2-fid nForce 430 chipset) and is active (?).

2) modprobe command:

js:/etc # modprobe forcedeth
js:/etc #

No any response.

3) dhcpcd command:

js:/etc # dhcpcd -D eth0
js:/etc #

No any response, timeout (?), but in /var/log/messages is the following:

...............
Aug 26 14:33:30 js kernel: eth0: link up.
Aug 26 14:33:31 js ifplugd(eth0)[2670]: Link beat detected.
Aug 26 14:35:10 js kernel: eth0: link down.
Aug 26 14:35:11 js ifplugd(eth0)[2670]: Link beat lost.
Aug 26 14:35:11 js dhcpcd[5443]: timed out waiting for a valid DHCP server response
Aug 26 14:35:11 js dhcpcd[3105]: recvfrom: Network is down
Aug 26 14:35:11 js dhcpcd-hook: Skipping 'ifdown $INTERFACE -o dhcp' call
Aug 26 14:35:12 js kernel: eth0: no link during initialization.
Aug 26 14:35:12 js kernel: eth0: link up.
Aug 26 14:35:13 js ifplugd(eth0)[2670]: Link beat detected.
Aug 26 14:35:13 js kernel: eth0: link down.
...............

It seems the DHCP server of ISP provider (www.chello.sk) does not answer (?)

J.

jojolx 08-26-2006 07:35 AM

...by the way, this PC is using in dual booting, the same HW configuration works well using Windovs XP, DHCP is OK as well, it is probably suse/drivers/configuration (?) based problem...

jojolx

boombastic_007 09-24-2006 08:20 AM

Hi jojolx,

I had the same issue with Suse... This is an issue with the forcedeth driver. To get it to work correctly you need
to shutdown the pc and unplug the power cord, wait for a few seconds plug it back in and boot straight into linux...

I installed an additional nic card to resolve this.

The issue seems to have now been fixed in kernel 2.6.16.21-0.21-default. Try updating the kernel.

regards,

boombastic

AlteRFirE 11-19-2006 02:55 AM

Im having the exact same problem, but i also don't know very much about Linux.
How do i go about safely updateing my kernel, and where do i get the files from.
i tried going to suse.com and grabbing a kernal file off the site that was newer that the version you specified - guess what, it didnt work. it uninstalled about 15 things and that was about it
::cheers::

eagleMcMoe 12-02-2006 08:49 AM

I have also seen the same problem. Disconnecting the computer from power and then booting directly into Linux helped.

Quote:

Originally Posted by AlteRFirE
Im having the exact same problem, but i also don't know very much about Linux.
How do i go about safely updateing my kernel, and where do i get the files from.
::cheers::

After getting the network card started (see above), I used the Online Update to get a new kernel as follows (English labels could be incorrect - I used German translations)
- Add an update site to the catalogs, either by
a) calling "Online Update Configuration"
or by adding it by hand via
b) "Installation Sources"
Both can be started from the YaST control center. At least if you are not using the refresh release (from Okt.13th) this may take some (more) time.
- Use the "Online Update" module of YaST (YOU) to update your System. Do not use the System Tray plugin - I heard that this will not work due to a bug in libzypp. Ensure you updated everything - I had to start YOU several times because libzypp and YOU itself had to be updated (or it restarted automatically? don't know)

AlteRFirE 12-03-2006 02:02 AM

thx mate, although my install sources and stuff aren't working yet either, it just keeps crashing. i'll patch YOU first or somethin

eagleMcMoe 12-04-2006 04:19 AM

It seems as if the updated kernel has still the same problem. I'm running kernel 2.6.16.21-0.25, and everytime I boot Windows the network card does not work with Linux until I turn of the power supply. Fortunately, I do not have to unplug the cable, but have a switch - but this seems to be no adequate solution for the long term.
Has anyone a solution?

AlteRFirE 12-06-2006 07:48 PM

not that i've found, bud, also i got my yast2 to update b/c the little icon updater tool don't work at all, and you know what???? it gets all the way thru the dependencies and then just dies. yast2 dies. omg, am i just gonna have to reinstall windows? i can't update, i can't not update and the tutorials that i have found to update my kernel didn't work, just caused more pain and now it dosent work anyway. also prism54 devices die b/c the same thing, must power down and off first. suse 10.1, im not very impressed.

::just an update::

eagleMcMoe 12-09-2006 03:47 AM

openSUSE 10.2 solves the forcedeth/Windows problem
 
Quote:

Originally Posted by AlteRFirE
i got my yast2 to update b/c the little icon updater tool don't work at all, and you know what???? it gets all the way thru the dependencies and then just dies. yast2 dies. omg, am i just gonna have to reinstall windows?

In SuSE 10.1 the little updater icon does not work from a fresh install - you have to perfrom the first update using the YaST module YOU (YaST Online Update). But the kernel you get via YOU does not solve the initial problem (which was that after booting into Windows one has to disconnect the computer from power supply to get the on-board network cards running under Linux, again)
Sounds as if your installation is already broken and you should reinstall - if you want Linux, then, of course, it should be Linux, not Windows ;)

The good news: since Dezember 7th, openSUSE 10.2 is available in the final version with kernel 2.6.18 (2.6.18.2-34). The (original) problem was fixed in the 'forcedeth'-driver/module.


It is not required to use ZMD (the ZENworks Management Deamon - the one that performed so bad in SuSE 10.1, seems to work slightly better, now) anymore. But configuring that probably should become a new thread.

AlteRFirE 12-09-2006 04:04 AM

yeh nice, but bf2 just isnt an option in linux. if bf2 and the new vent client worked in linux, i'd be in major, but alas... anyhoo, i gave up, im useing 10.0 32 bit now, althogh i can't say its withou its problems :tisk:
thanks to all u guys that gave advice;)


All times are GMT -5. The time now is 10:51 PM.