LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 09-21-2003, 04:12 PM   #1
The-Demon
LQ Newbie
 
Registered: Sep 2003
Posts: 1

Rep: Reputation: 0
Unhappy Speedtouch 330 usb modem!!!!


ok, i have installed linux red hat 9 this weekend on a spare drive. i was amased it picked up most of my harware even ati 9500 pro. but how the hell im supposed to connect to the internet i dont have a clue! it just will not detect the modem at all and i have no idea how to get my bt broadband account working in it! i e-mailed bt and they say they dont support linux. so any 1 any ideas? please b4 i wipe it and never even think of linux again!

Last edited by The-Demon; 09-21-2003 at 06:31 PM.
 
Old 09-21-2003, 06:30 PM   #2
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Fear not.

Apparently this tutorial is one of the best out there for the 330. If it doesn't work for you, then leave another message and I'll try to find the tutorial I used.

http://www.xs4all.nl/~pschram/english.html

Good luck.

Dave.
 
Old 09-22-2003, 03:48 PM   #3
drakeman
Member
 
Registered: Sep 2003
Location: Rotterdam, The Netherlands
Distribution: Ubuntu 6.06; DSL
Posts: 31

Rep: Reputation: 15
You can try the package "speedtouch-1.1-1.i586.rpm". I have tried it on my Mandrake9.1 and it worked directly untill theee moment I tought to install the homenetwork. After that, i'm still on the internet with windows.
 
Old 10-30-2003, 04:51 PM   #4
alien72
LQ Newbie
 
Registered: Oct 2003
Posts: 5

Rep: Reputation: 0
Quote:
Originally posted by ilikejam
Fear not.

Apparently this tutorial is one of the best out there for the 330. If it doesn't work for you, then leave another message and I'll try to find the tutorial I used.

http://www.xs4all.nl/~pschram/english.html

Good luck.

Dave.
Hi
I followed the How-To you have mentioned to the letter but the modem still don't connect to internet.

I post here the connection message I receive.
If anyone can help I would be REALLY GRATEFUL ( I've been trying to install this DAMNED modem for THREE months with NO success )

using channel 1
Using interface ppp0
Connect: ppp0 <--> /dev/pts/2
Warning - secret file /etc/ppp/pap-secrets has world and/or group access
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x637a172c>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x637a172c>]
SIOCADDRT: No such device
[root@localhost tmp]# sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x637a172c>
]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x637a172c>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x637a172c>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x637a172c>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x637a172c>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x637a172c>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x637a172c>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x637a172c>]
LCP: timeout sending Config-Requests
Connection terminated.
Waiting for 1 child processes...
script /usr/local/sbin/pppoa3 -m 1 -c -vpi 35 -vci 8 -e 1, pid 4848
Script /usr/local/sbin/pppoa3 -m 1 -c -vpi 35 -vci 8 -e 1 finished (pid 4848), s
tatus = 0xff

Bye Alex
 
Old 10-30-2003, 05:30 PM   #5
drakeman
Member
 
Registered: Sep 2003
Location: Rotterdam, The Netherlands
Distribution: Ubuntu 6.06; DSL
Posts: 31

Rep: Reputation: 15
Alex,

I was able to connect my Speedtouch 330 modem with Win98SE in 5 minutes. Then I've tried to connect with Linux for nearly one year. Therefor I used the 8.1, 9.0 9.1 and 9.2 versions of Mandrake. Recently I changed to RedHat 9.0, because of the Internet connection. I folowed the discription of Peter Schram, without errors, but also without succes. This week I used the speedtouchconf script found on Sourceforge.net. Then with Linux I was even faster connected compaired to Win98SE. Unpack the TAR, download the mgmt.o file run the conf script and fill in the answers on the prompt (Speedtouch 330 ?; account name ?; password ? continue ?). Thats was all. I'll try it this weekend also with MDK9.1, which is installed on my notebook. I'll be back then. Succes.

Hans.
 
Old 10-30-2003, 06:44 PM   #6
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Hmmm. Try this one:

http://www.webconexion.net/speedtouc...ch_330_usb.php

this is the one I used, so I know it works with RedHat 9.

Just make sure you watch for where speedtouch.conf is saved by the installer (it's listed at the end of the install when you get your command line prompt back) the instructions say the speedtouch.conf file is saved to /etc/, but it's put elsewhere.

Dave

P.S. If you do finally get it working, try to get your hands on the Mac version's Firmware.bin, and substitute that for the mgmt.o file - it makes the modem just a little faster (but I wouldn't worry about that untill you've got it working).
 
Old 10-31-2003, 04:09 PM   #7
alien72
LQ Newbie
 
Registered: Oct 2003
Posts: 5

Rep: Reputation: 0
Quote:
Originally posted by drakeman
Alex,

[cut]
This week I used the speedtouchconf script found on Sourceforge.net. Then with Linux I was even faster connected compaired to Win98SE.
[cut]
Hans.
Hans...
You're my HERO!!!!!!
I used the files you suggested and now everything is fine and I'm able to connect.......INCREDIBLE!!!!!!!

The only strange thing is that when i try to disconnect the system tells me that the modem is busy with some other work and cannot disconnect ( in effect it has already put down the line so i am off-line and there is no real problem ).
The same message is sent by the system when shutting down the computer.
But apart from this everything works fine and, as you said, even faster than in windows.

Thanks again.
Alex

P.S.
If u come to Florence u have earned yourself a free place qhere to sleep
 
Old 11-01-2003, 10:05 AM   #8
drakeman
Member
 
Registered: Sep 2003
Location: Rotterdam, The Netherlands
Distribution: Ubuntu 6.06; DSL
Posts: 31

Rep: Reputation: 15
I have seen the message during disconnection. I don't know which process is running. Now I'm looking for security options. But the proper connection had the highest priority.

PS. I've been once in florence and I certenly want to go back there, but watch out. I have a wife and 5 kids. CU.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedtouch 330 USB Modem and XP adam-red Linux - Hardware 1 11-30-2004 11:54 AM
Speedtouch 330 USB Modem with Slackware 10.0 inkysplat Linux - Hardware 3 10-12-2004 10:16 AM
[slackware]alcatel speedtouch 330 usb modem hylke Linux - Newbie 16 06-24-2004 02:21 AM
SuSE 8.0 and Speedtouch 330 usb modem jsatherley Linux - Distributions 10 02-25-2004 05:41 PM
Speedtouch 330 USB modem install DavidTempler Mandriva 2 10-31-2003 08:50 AM


All times are GMT -5. The time now is 02:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration