LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 10-07-2003, 11:09 AM   #1
xianzai
Member
 
Registered: Oct 2003
Location: UK
Distribution: RHEL4
Posts: 54

Rep: Reputation: 15
Question Soundcard Driver for ALi M5451 Soundcard (Trident Module)


Hi,

I have just installed RH9 Personal (Kernel Version 2.4) on my friend's laptop, and everything works fine, but I am unable to correctly configure the soundcard.

The laptop is an Acer TravelMate 521TE, and has an ALi M5451 Soundcard. When I run the RH soundcard detection tool, the Trident module is shown, but when I try and play the test sound, nothing happens, and I am informed that the Trident driver could not be loaded. I have solved this problem before, on my machine, with a SoundBlaster card by disabling Plug and Play in the BIOS. Then during startup Kudzu ran and configured it for me. However, the BIOS on this computer doesn't have any feature whereby I can disable Plug and Play.

I have tried searching the net for a driver, and came across one at the ALi website, however, this involved recompiling the kernel, and that created errors, and exited. I have also tried using alsa, but that doesn't seem to work either...

Does anybody know how I can get sound? PLEASE?!

Thanks,

Matt :-)
 
Old 10-08-2003, 03:42 PM   #2
Seajays
LQ Newbie
 
Registered: Oct 2003
Posts: 4

Rep: Reputation: 0
I have the same problem with the M5451 sound card on an Acer Travelmate 201T.

It detects it OK, but the sound card fails to start on boot.
 
Old 12-14-2006, 11:01 PM   #3
speut
LQ Newbie
 
Registered: Jul 2006
Posts: 10

Rep: Reputation: 0
Unhappy

Same problem here as well.

I have used the trident module successfully on the 2.4 kernels but
on the new 2.6 kernel I cannot get sound with either the snd_trident
or snd_ali5451 modules.

I have an ali m5451 version 1 card integreated in a kds laptop. Seems the 2.6 versions of the modules are broken.
 
Old 12-15-2006, 12:00 PM   #4
speut
LQ Newbie
 
Registered: Jul 2006
Posts: 10

Rep: Reputation: 0
Unhappy

Seems to be that the mixer will not come up.

alsaconf finds the card ok. but 2> error.fil gives me this.

/usr/sbin/alsactl: save_state:1194: No soundcards found.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RH9 and ALi M5451 : (trident) driver could not be loaded ! Help ! xtrips Linux - Hardware 5 07-19-2007 09:48 AM
ALi M5451 PCI South Bridge Audio(rev 01) driver for Debian harlemno1 Linux - Hardware 6 11-10-2004 12:18 PM
How to make a soundcard use driver module escargot22026 Linux - Hardware 6 08-19-2004 04:56 PM
Trouble with ALi 5451 soundcard Punkduplo Linux - Laptop and Netbook 6 10-19-2003 09:40 AM
Restarting soundcard driver module??? AZ_Rider Linux - Newbie 5 09-10-2003 10:08 PM


All times are GMT -5. The time now is 02:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration