LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-10-2013, 10:48 PM   #1
Luke_Wolf
LQ Newbie
 
Registered: Jan 2011
Distribution: Slackware & openSUSE
Posts: 10

Rep: Reputation: 0
Soundblaster Live! X Gamer (CT 4760) Fails to load driver


Hello, I recently got a Creative CT4760 SoundBlaster Live X Gamer from a friend and I've tried Fedora 17, openSUSE 12.2, and Kubuntu 12.10 with it and the sound drivers for this card just refuse to load.

based upon this section of dmesg which I got from Fedora (which was the most verbose on it with the extra line about the sound card removal)

[ 31.951657] ALSA sound/pci/ac97/ac97_codec.c:2091 AC'97 0 does not respond - RESET
[ 31.951671] ALSA sound/pci/ac97/ac97_codec.c:2100 AC'97 0 access is not valid [0xffffffff], removing mixer.
[ 31.952452] ALSA sound/pci/emu10k1/irq.c:44 snd-emu10k1: Suspected sound card removal
[ 31.952548] snd_emu10k1: probe of 0000:01:06.0 failed with error -5

It's looking to me as if this ac97 driver is stepping in and trying to take over the card but failing to do so and thus results in the sound card being "removed" from under emu10k1's feet. The card pretty obviously works though because the gameport driver successfully connects to it as seen here from lspci -vv

01:06.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
Subsystem: Creative Labs CT4760 SBLive!
Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Interrupt: pin A routed to IRQ 20
Region 0: I/O ports at efc0 [size=32]
Capabilities: [dc] Power Management version 1
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-

01:06.1 Input device controller: Creative Labs SB Live! Game Port (rev 07)
Subsystem: Creative Labs Gameport Joystick
Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 32
Region 0: I/O ports at eff8 [size=8]
Capabilities: [dc] Power Management version 1
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
Kernel driver in use: Emu10k1_gameport

now I've tried putting snd-ac97 and snd-ac97-codec (as are my guesses at the names of the kernel drivers associated with this ac97 driver), in blacklist.conf under /etc/modprobe.d/ but that doesn't seem to have effected anything.

not really sure what to try now.. but if nobody posts a fix over the next few days I'll go ahead and report a bug against ALSA.

Last edited by Luke_Wolf; 01-10-2013 at 11:02 PM.
 
Old 01-11-2013, 03:27 AM   #2
Luke_Wolf
LQ Newbie
 
Registered: Jan 2011
Distribution: Slackware & openSUSE
Posts: 10

Original Poster
Rep: Reputation: 0
After some testing with old distros all the way back to Slax 4.2.0 I've come to the conclusion that I'm looking at some sort of long standing ALSA bug so I've gone ahead and reported it here https://bugzilla.redhat.com/show_bug.cgi?id=894265 since the upstream ALSA bugtracker is down
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Soundblaster Live 24 - alsa driver Vookimedlo Linux - Hardware 6 04-01-2005 11:14 AM
No sound on SuSe 9.0 with Soundblaster! Audigy Gamer smokey83647 Linux - Hardware 0 02-09-2004 10:56 AM
Need Help With SoundBlaster Audigy Gamer eggman95 Linux - Hardware 1 10-20-2003 09:48 PM
Creative Soundblaster Gamer wolffmanl7 Linux - Hardware 1 07-06-2002 06:36 AM
soundblaster audigy gamer... mkzmonkeylagger Linux - General 1 03-14-2002 03:34 PM


All times are GMT -5. The time now is 05:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration