LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 09-11-2004, 07:58 AM   #1
n0x
LQ Newbie
 
Registered: Apr 2004
Distribution: Slackware 9.1
Posts: 13

Rep: Reputation: 0
Unhappy Sound works as root but not as user?


I have searched the forum and still couldnt solve my problems...

Sound doesnt seem to work as a user but works fine as root.

im on Slackware 9.1 and have onboard sound... VT8233 AC97 Audio Controller

I've just noticed (in gnome) the speaker icon in the top-right corner
has a line through it... i click it and i get the error "could not open mixer decive /dev/sound/mixer"

Last edited by n0x; 09-11-2004 at 08:06 AM.
 
Old 09-11-2004, 08:25 AM   #2
Charalambos
Member
 
Registered: Aug 2004
Location: Switzerland
Distribution: debian
Posts: 149

Rep: Reputation: 15
Perhaps your user account doesn't belong to the audio group. Type "groups username" to find out. If he doesn't belong to the audio group, add the user to the group in the file "/etc/group".
 
Old 09-11-2004, 08:27 AM   #3
akudewan
Member
 
Registered: Apr 2004
Location: India
Distribution: Ubuntu
Posts: 364

Rep: Reputation: 30
Its a permissions problem. look at: http://www.linuxquestions.org/questi...und+permission

Run a search. This is a very common problem
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC3 No Sound As User Works As Root AliasMrJones Fedora 2 01-22-2005 06:34 PM
IntelliMouse thumb buttons work as root, broken as non-root user, wheel works always digital vortex Linux - Hardware 7 03-02-2004 05:14 PM
sound works in root - no sound in user - Debian seanb Debian 9 02-28-2004 01:42 AM
Sound works for root and first user created, no one else downinthemine Linux - Hardware 7 01-15-2004 09:44 PM
sound works with root not user shanenin Linux - Software 3 10-29-2003 07:05 PM


All times are GMT -5. The time now is 08:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration