Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 07-14-2008, 08:56 PM   #1
Registered: Feb 2007
Posts: 36

Rep: Reputation: 15
sound stopped working after installing totem on fedora 9

this is beyond me - i tried to play a .mp3 file, and it's all "hey, you need a player!" so i installed totem, and tried to play the file again, totem opens up, and appears to be playing the music, only; no audio. my speakers won't make any noise. i uninstalled it, and got xmms as well as the .mp3 plugin, and still, same issue.

the speakers DO work, the sound on pc and speakers are at maximum, and no sound. i also might want to note that the speakers did deliver sound before the installation of totem - frozen bubble was making noise just fine. after all this fiddling, now even frozen bubble won't make any noise.

anyone have any idea what's going on?
how can i fix this?

running fedora 9, 1686 with GNOME 2.22.3
Old 07-15-2008, 06:55 AM   #2
LQ Newbie
Registered: Oct 2004
Location: Netherlands
Distribution: Fedora core
Posts: 17

Rep: Reputation: 0
There's always installing vlc then:

vlc->setting->audio->output modules
check "advanced options"
audio output module->ALSA audio output

vlc->setting->audio->output modules->ALSA
click refresh list
and select your audio card directly to circumvent pulseaudio

To disabling pulseaudio permanently (as root):
yum remove alsa-plugins-pulseaudio
This will remove the alsa to pulseaudio plugin.
Old 07-15-2008, 10:49 AM   #3
LQ Newbie
Registered: Oct 2007
Posts: 4

Rep: Reputation: 0
try messing with the sound card options and test it until it works. thats what I do
Old 07-15-2008, 01:02 PM   #4
LQ Newbie
Registered: Jul 2007
Posts: 19

Rep: Reputation: 9

Make sure Gnome is configured to use ALSA or *big part* if you did not uninstall PulseAudio, make sure Gnome is set to use PulseAudio by default (System -> Preferences -> Hardware -> Sound). This causes the gstreamer backend to use Pulse (or alsa if you removed Pulse) by default. In my experience, it's worked best to have Gnome/Gstreamer based apps using Pulse and non-Pulse aware apps (e.g. Wine) using Alsa. The other advantage is zero config necessary for gstreamer using apps (e.g. Banshee, Totem, etc).

Hope that helps,
Old 07-16-2008, 06:07 PM   #5
LQ Newbie
Registered: Oct 2007
Posts: 4

Rep: Reputation: 0
has the sound ever worked, Like when in boots up do you hear the "shiny" noise?
Old 07-18-2008, 06:40 AM   #6
LQ Newbie
Registered: Jul 2008
Posts: 4

Rep: Reputation: 0
Sound...worth a try.

Try logging in as a different user rather than administrator. When I play Sauerbraten, I have to change log in to a user to have the sound working.
I use Xandros linux.
Old 07-18-2008, 08:46 AM   #7
LQ Newbie
Registered: Mar 2008
Location: Poquoson, VA
Distribution: Ubuntu 10.04
Posts: 12

Rep: Reputation: 0
Making sure the speakers are still working

From the terminal command line, try:

cat /dev/urandom > /dev/dsp

If the speakers are working, you will hear static.

This tip and others are from,+Part+2.htm

Good Luck -- audio problems can be a bear to figure out.


fedora, mp3, sound, totem

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
7.10 sound stopped working BigOil Ubuntu 2 04-07-2008 02:38 PM
Installing Kmix stopped sound from working with ac97 qwerty SUSE / openSUSE 2 05-24-2005 02:23 PM
sound stopped working King4lex Debian 13 12-14-2004 02:36 PM
My sound just STOPPED working.... oicdn Linux - Software 7 06-02-2004 05:40 PM
My sound just STOPPED working. oicdn Linux - Hardware 7 01-28-2004 03:28 PM

All times are GMT -5. The time now is 05:46 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration