LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Sound problems: Intel Corp. 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02) (http://www.linuxquestions.org/questions/linux-hardware-18/sound-problems-intel-corp-82801eb-er-ich5-ich5r-ac97-audio-controller-rev-02-a-270323/)

firedance 12-25-2004 07:39 PM

Sound problems: Intel Corp. 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
 
Well Im not sure if this should be in the newbie section but anyway.

I use FC3 with a modifyed kernel so i can use my wireless.
my sound wont work, in windows it says that i have 'SoundMax integrated digital audio'
and linux /sbin/lspci gives me.

00:1f.5 Multimedia audio controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)

When searching for answers i found that almost all of them pointed at alsa.
i downloaded alsa-driver-0.9.1adi and did the ./configure as they told me in the readme, after that i did make install and got


[root@firedance alsa-driver-0.9.1adi]# make install
make[1]: Entering directory `/home/firedance/Linux/alsa-driver-0.9.1adi/acore'
gcc -D__KERNEL__ -DMODULE=1 -I/home/firedance/Linux/alsa-driver-0.9.1adi/include -I/lib/modules/2.6.9-1.681_FC3.stk16/build/include -O2 -mpreferred-stack-boundary=2 -march=i686 -DLINUX -Wall -Wstrict-prototypes -fomit-frame-pointer -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -pipe -DALSA_BUILD -DEXPORT_SYMTAB -c hwdep.c
In file included from /home/firedance/Linux/alsa-driver-0.9.1adi/include/adriver.h:40,
from /home/firedance/Linux/alsa-driver-0.9.1adi/include/sound/driver.h:43,
from ../alsa-kernel/core/hwdep.c:22,
from hwdep.c:1:
/usr/include/linux/modversions.h:1:2: #error Modules should never use kernel-headers system headers,
/usr/include/linux/modversions.h:2:2: #error but rather headers from the appropriate kernel package.
/usr/include/linux/modversions.h:3:2: #error Change -I/usr/src/linux/include (or similar) to
/usr/include/linux/modversions.h:4:2: #error -I/lib/modules/$(uname -r)/build/include
/usr/include/linux/modversions.h:5:2: #error to build against the currently-running kernel.
In file included from /home/firedance/Linux/alsa-driver-0.9.1adi/include/adriver.h:41,
from /home/firedance/Linux/alsa-driver-0.9.1adi/include/sound/driver.h:43,
from ../alsa-kernel/core/hwdep.c:22,
from hwdep.c:1:
/home/firedance/Linux/alsa-driver-0.9.1adi/include/sndversions.h:3:29: linux/modsetver.h: No such file or directory
make[1]: *** [hwdep.o] Error 1
make[1]: Leaving directory `/home/firedance/Linux/alsa-driver-0.9.1adi/acore'
make: *** [compile] Error 1

Anyone of you know what to do or if im going in the right direction?

tiberiu 12-26-2004 11:43 AM

One idea...
 
Hi!

I have the same sound card on my Asus motherboard.
In FC3 there are no problems using it!
Maybe it doesn't work because you changed something in the kernel (I am new so I can't tell u more about this but I know that this sound card should work from the first minute of FC3 installation).

Tiberiu

jmsavoy 01-17-2005 09:40 PM

Hi, I have an IBM S50 desktop with the same chipset. My output from lspci is identical to yours, and I have no audio, just like you. Have you made any progress on this? I would have exected FC3 to come with all of the alsa stuff aready compiled and installed ... looks like they use a subset of the utilities though.

jmsavoy 01-17-2005 09:41 PM

btw, your problem with compiling above is that with the 2.6 kernel Linus has started to make sure you comple against the right kernel, and not default system header files, thus the error message for you to change the include's to point to your kernel source and not system headers.

dcg757s 01-21-2005 11:30 PM

seems to be a theme...82801EB AC'97 Audio
I too have no sound running on Mandrake 10.1

FishieFishie 01-22-2005 12:41 AM

I have the same chipset on my board, and I had the same problem. Though, I believe it has something to do with your drivers (XMMS uses OSS and it runs fine, aRts never worked for me and ALSA was very, very quiet). I don't know if that helps any, but you might want to experiment with drivers and hope that works.

Good luck.
- FishieFishie

dcg757s 01-23-2005 08:54 AM

maybe this wil help more, When I run Kanotix, the sound works perfectly. Knoppix and Mandrake both won't run sound. but they all use the same driver.

chem1946 03-11-2005 01:48 PM

I have the same sound problem as above. I have the Intel 82801EB/ER(ICH5/ICH5R) AC'97. I've installed Xine, It plays mpg, DVD so far, but quietly. I've tried using,alsamixer, changed settings and same result. I'm new at this and extremely confused. I was using RH9 and the sound was working. I'm now using FC3 without audio. Thanks to anyone for help.

rpz 03-11-2005 02:49 PM

Quote:

Originally posted by chem1946
I have the same sound problem as above. I have the Intel 82801EB/ER(ICH5/ICH5R) AC'97. I've installed Xine, It plays mpg, DVD so far, but quietly. I've tried using,alsamixer, changed settings and same result. I'm new at this and extremely confused. I was using RH9 and the sound was working. I'm now using FC3 without audio. Thanks to anyone for help.
Are you using S/PDIF for sound output? Try the earphone output and see if there's sound there. I have a 82801DB/DBL/DBM audio controller (so it's not the same but anyways..). I noticed that S/PDIF output for this card using alsa is a bit flaky. Among other things, the S/PDIF mute button is reversed (and I think the volume slider is too), and Dolby Digital output from VLC doesn't work either. Maybe some other controls are also reversed? I didn't really look into this because right now I don't need digital output so there might be a perfectly reasonable explanation.
Anyway, I would grab the latest alsa drivers...

chem1946 03-11-2005 04:31 PM

Thanks, rpz. I'm new at this and it's probably something very elementary. Chem1946

Jschnell 03-17-2005 09:24 AM

Sounds like a problem eh?
 
anhow... yeah.
same stuf have the same audio controller on my board, and I had the same problem.
i got it to work/it worked of the get go with suse, mandrake 10.1, and slackware 10.0... but now in fedora core 3... i am having problems. if anyone finds the answer to this problem... there will sure be alot of fixes made.
(with suse and slackware... all i had to do was unmute all the devices with alsamixer in the terminal.. it turned out that everything was defaulted as mute)
unfortunately my n00b skills allow me to do little more than that.

gregbazar 04-04-2005 11:29 PM

Got it working
 
I had the same issues as everyone here.

Running Ubuntu. Sound worked in previous version - but not when I upgraded to the new beta (Hoary).

Upgraded ALSA and then unmuted PCM sound. Started working right away.

Good Luck!

jmsavoy 05-06-2005 08:57 PM

Quote:

Originally posted by rpz
Are you using S/PDIF for sound output? Try the earphone output and see if there's sound there. I have a 82801DB/DBL/DBM audio controller (so it's not the same but anyways..). I noticed that S/PDIF output for this card using alsa is a bit flaky. Among other things, the S/PDIF mute button is reversed (and I think the volume slider is too), and Dolby Digital output from VLC doesn't work either. Maybe some other controls are also reversed? I didn't really look into this because right now I don't need digital output so there might be a perfectly reasonable explanation.
Anyway, I would grab the latest alsa drivers...

Ok, after reading your post I tried a few different things. I've found that volume for this chip for me is not controlled by either Master or PCM ... but by Headphone !!! I simply un-muted Headphone in the mixer, and turned up headphone volume ... and it now works .. really strange but now maybe I won't need to switch to windoze as often.

doomicon 04-12-2006 08:45 AM

I know this is a year late, but just wanted to add that unmuting the headphone volume on the mixer corrected my sound issue as well. I have the same Intel Chipset.

./doomicon

Bobymc 04-22-2006 09:34 PM

http://www.alsa-project.org/alsa-doc...=intel8x0#Inst

I'd try Alsa driver ,wonder what happened?


All times are GMT -5. The time now is 03:36 AM.