LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Sound problems in Slackware 11 with Sweex sound card (http://www.linuxquestions.org/questions/linux-hardware-18/sound-problems-in-slackware-11-with-sweex-sound-card-550182/)

RicardoB 04-30-2007 01:34 PM

Sound problems in Slackware 11 with Sweex sound card
 
I have a problem when playing videos in Slackware, the sound is... I don't know how to explain, it seems to be too loud on one channel. I'm using an el-cheapo Sweex 5.1 surround sound card and a Philips SPA2600 5.1 speaker set. When I listen to music, the sound is great, but whenever I see a movie, say Freedom Downtime or anything video, the sound becomes distorted. English isn't my first language but I can't even explain what's happening in my own language. It might be that the sound is distorted in the music as well, but I'm definitely not noticing the same behavior as with movies.

Here's my .asoundrc if it's any help...
Code:

pcm.softvol {
    type softvol
    slave {
        pcm "hw:0,1"
    }
    control {
        name "SoftMaster"
    }
}

pcm.dsp0 {
    type plug
    slave.pcm "softvol"
    slave.channels 6
    route_policy duplicate
}

pcm.!default {
    type plug
    slave.pcm "softvol"
    slave.channels 6
    route_policy duplicate
}

pcm.cmipci {
  type hw
  card 0
}

ctl.cmipci {
    type hw
    card 0
}

Edit: My volume levels are all normal and lowering them does not make any difference (alsamixer).


All times are GMT -5. The time now is 10:43 AM.