LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 06-13-2009, 02:35 PM   #1
waffe
Member
 
Registered: Sep 2003
Distribution: Debian
Posts: 69

Rep: Reputation: 15
Arrow sound problem when using Fluxbox


Hi,

I am on an Intel motherboard(DG45FC) with a Intel 82801JR (ICH10R) sound card with Ubuntu 9.04 and Kernel 2.6.28-11-generic.

Here is lsmod | grep snd

Code:
snd_hda_codec_intelhdmi    20608  1
snd_hda_codec_idt      65548  1
snd_hda_intel          34120  3
snd_hda_codec          83584  3 snd_hda_codec_intelhdmi,snd_hda_codec_idt,snd_hda_intel
snd_hwdep              15364  1 snd_hda_codec
snd_pcm_oss            45984  0
snd_mixer_oss          22912  1 snd_pcm_oss
snd_pcm                82948  4 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_dummy          10884  0
snd_seq_oss            36224  0
snd_seq_midi           14240  0
snd_rawmidi            29856  1 snd_seq_midi
snd_seq_midi_event     15232  2 snd_seq_oss,snd_seq_midi
snd_seq                57584  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              29192  2 snd_pcm,snd_seq
snd_seq_device         15372  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd                    66852  19 snd_hda_codec_intelhdmi,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_dummy,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore              15200  1 snd
snd_page_alloc         17032  2 snd_hda_intel,snd_pcm
Here is cat /proc/asound/modules
Code:
0 snd_hda_intel

When I am logged into a regular account(non-Fluxbox) sounds works perfectly in all application like Firefox, Flash VLC etc ... but the moment I log into the fluxbox account there is no sound except in gnome-sound-properties panel when I select oss analog and hit test, there is sound, but no where else!!!

The sound-settings-properties when logged into the non-Fluxbox account are all set to ALSA and everything works but if I set that in the Fluxbox account there is no sound including the test sound.

I have made sure in alsamixer nothing is muted and all volumes are turned up. And I have tried all the audio output ports on the sound card.

Also, in the non-Fluxbox account the master volume does not do change the volume, the PCM channel does. why?

Thanks for any help,

This makes me think I need to load something in the start up script for Fluxbox but I do not know what.

Last edited by waffe; 06-13-2009 at 02:39 PM.
 
Old 06-13-2009, 04:57 PM   #2
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 57
You probably haven't got the sound server running. Try executing pulseaudio --start. If that solves your problems, add it as a startup application for Fluxbox.
 
Old 06-13-2009, 08:42 PM   #3
waffe
Member
 
Registered: Sep 2003
Distribution: Debian
Posts: 69

Original Poster
Rep: Reputation: 15
I tried it loggin in as non-root and this is what I get:

I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root privileges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
N: main.c: Called SUID root and real-time and/or high-priority scheduling was requested in the configuration. However, we lack the necessary privileges:
N: main.c: We are not in group 'pulse-rt', PolicyKit refuse to grant us the requested privileges and we have no increase RLIMIT_NICE/RLIMIT_RTPRIO resource limits.
N: main.c: For enabling real-time/high-priority scheduling please acquire the appropriate PolicyKit privileges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.


and there is no sound.

The line that says, "N: main.c: We are not in group 'pulse-rt'" is this a problem or...

Thanks,
waffe
 
Old 06-17-2009, 07:27 PM   #4
waffe
Member
 
Registered: Sep 2003
Distribution: Debian
Posts: 69

Original Poster
Rep: Reputation: 15
Ok, so yes, I needed to add myself to the pulse-rt group and when I now run "pulseaudio --start" I get:

Code:
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root privileges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
And still no sound, I have set my gnome-sound-properties to pulseaudio sound server.

Any thing I can look into?

Thanks,
waffe
 
Old 06-17-2009, 10:50 PM   #5
waffe
Member
 
Registered: Sep 2003
Distribution: Debian
Posts: 69

Original Poster
Rep: Reputation: 15
Wink

Well, I don't know if it had to be done this way but I uninstalled pulseaudio and installed oss and everything is working.

First this:
https://help.ubuntu.com/community/OpenSound

and then this:
http://www.4front-tech.com/wiki/inde...ions_for_OSSv4

waffe
 
  


Reply

Tags
fluxbox, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fluxbox error /usr/share/fluxbox/nls/en_GB/fluxbox.cat humbletech99 Debian 2 12-29-2005 10:16 AM
KDE versus Fluxbox Sound Problem Murdock1979 Linux - Software 2 09-23-2005 07:41 AM
help with fluxbox and sound! Alexander.s Linux - Laptop and Netbook 1 01-23-2005 10:42 AM
Sound problems in fluxbox CatBreath Linux - Software 1 09-06-2004 08:42 AM
Fluxbox questions - sound problem. NomDeGuerre Linux - Newbie 12 03-10-2004 07:37 AM


All times are GMT -5. The time now is 11:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration