LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 12-04-2002, 09:26 PM   #1
mmr_85
LQ Newbie
 
Registered: Nov 2002
Distribution: Redhat 9
Posts: 25

Rep: Reputation: 15
Sound Problem after switching to redhat 8


I switched from Mandrake 9 to Redhat 8, and in Mandrake 9, my soundcard used to work perfectly with the ALSA support in mandrake. When I run Redhat, it shows that I do have a FM801 but, it DOESN'T play a sound, I press the play test sound, nothing comes up. I load a Music CD and it plays, but I dont hear anything. I boot and get back to windows, and it does works, I dont know what might be happening, because it used to work in Mandrake with ALSA support, and Redhat has it too, I suppose and I think I read somewhere during the installation. So why my soundcard doesnt play in Redhat 8?

When the computer loads the environment, I get an error message saying that it cant load the /dev/dsp something similar, I dont remember very acurately, Im in windows right now. And when the computer is shutted down, it says something about a module sound-service, which cant be loaded, I cant read it, since it runs to fast. Sorry for not being too accurate in my description, but Ill check, and post it accurately.

Please help me, Im new into this, so dont try to give me hard to follow solutions, that I might not be able to do, since I'm new in this.

Thanks in advance.

Last edited by mmr_85; 12-04-2002 at 09:36 PM.
 
Old 12-04-2002, 10:29 PM   #2
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 55
list the permissions on /dev/dsp*
ls -l /dev/dsp*
if it shows up like
Code:
crw------   root root yada yada /dev/dsp0
----------------------------------------------
crw------   root root yada yada /dev/dspN
then change perms as root
Code:
chmod 666 /dev/dsp* /dev/audio* /dev/mixer*
P.S. Sorry, I should've expected it the above is done in Xterm/Konsole/Other terminal emulation software, to become root issue /bin/su and type root password when prompted with Password:, you won't see anything when you type it.

Last edited by neo77777; 12-04-2002 at 10:32 PM.
 
Old 12-05-2002, 07:59 AM   #3
mmr_85
LQ Newbie
 
Registered: Nov 2002
Distribution: Redhat 9
Posts: 25

Original Poster
Rep: Reputation: 15
Im gonna try when I reinstall redhat, because I moved to mandrake, since Im gonna test a new modem I will buy today, when I return to redhat, Im gonna try it.


Here are the messages redhat displays
When It enters to Redhat environment, a message appears saying:

Quote:
Sound Server Initialization message:
Error while initializating the sound driver:
device /dev/dsp cant be opened (No such device)
The sound server will continue, using the null output service.
When redhat exits to shutdown it syas something very quick, but Im unable to see accurately what it says, it is very quick:

Quote:
mob prob cant locate module sound slot 0
Someting simililar, but Im not quite sure since it goes to fast.


Thanks
 
Old 12-05-2002, 07:32 PM   #4
mmr_85
LQ Newbie
 
Registered: Nov 2002
Distribution: Redhat 9
Posts: 25

Original Poster
Rep: Reputation: 15
when I run ls -l /dev/dsp*, I get other stuff diferent, it connects to 3 things, not 2, and they are not similar to this ones.
 
Old 12-06-2002, 05:53 PM   #5
mmr_85
LQ Newbie
 
Registered: Nov 2002
Distribution: Redhat 9
Posts: 25

Original Poster
Rep: Reputation: 15
Im following this:

http://www.alsa-project.org/alsa-doc...1&module=fm801

I dont have a clue what Im I doing wrong.

This is what I get after typing ls -l /dev/dsp*:

[root@localhost root]# ls -l /dev/dsp*
crw------- 1 root root 14, 3 ago 31 05:31 /dev/dsp
crw------- 1 root root 14, 19 ago 31 05:31 /dev/dsp1
crw------- 1 root root 55, 0 ago 31 05:31 /dev/dsp56k

I would really like to keep redhat, i like it, pleae help me
 
Old 12-07-2002, 04:14 AM   #6
rwhitworth
Member
 
Registered: Dec 2002
Location: Guildford, UK
Posts: 43

Rep: Reputation: 15
I've got this same problem on a Sony Viao laptop with MagicMedia 256AV sound card.

Quote:
Originally posted by neo77777
[B]list the permissions on /dev/dsp*
ls -l /dev/dsp*
if it shows up like
Code:
crw------   root root yada yada /dev/dsp0
----------------------------------------------
crw------   root root yada yada /dev/dspN
Yes - that's what I get.

Quote:
then change perms as root
Code:
chmod 666 /dev/dsp* /dev/audio* /dev/mixer*
Okay. And rechecking the permissions they have changed.

But even after this I can't open the volume control. I get:

"Error (gnome-volume-control) - I was not able to open your audio device. Please check that you have permission to open /dev/mixer and make sure you have sound support compiled into your kernel."

Also, the error message on shut-down is still there.

And next time I start up, the permissions have gone back to how they were!

What's going on here?
 
Old 12-07-2002, 10:21 AM   #7
mmr_85
LQ Newbie
 
Registered: Nov 2002
Distribution: Redhat 9
Posts: 25

Original Poster
Rep: Reputation: 15
I dont have a clue, It makes me mad, because it worked on mandrake, but I prefer redhat, but ti dislikes my soundcard or something.
 
Old 12-07-2002, 03:38 PM   #8
chrisharkness
Member
 
Registered: Nov 2002
Location: Halifax, UK
Distribution: Debian
Posts: 36

Rep: Reputation: 15
we ought to make a little club for people with silent redhat 8s, cos i have the same problem!
 
Old 12-08-2002, 09:55 AM   #9
mmr_85
LQ Newbie
 
Registered: Nov 2002
Distribution: Redhat 9
Posts: 25

Original Poster
Rep: Reputation: 15
Have you people tried with another linux distribution? Lke mandrake? Because I have both, but on Mandrake it does works.
 
Old 12-08-2002, 07:44 PM   #10
mmr_85
LQ Newbie
 
Registered: Nov 2002
Distribution: Redhat 9
Posts: 25

Original Poster
Rep: Reputation: 15
I solved the problem!

First I installed the kernel pack and the development pack from the packages thing. Then I went to the page of the alsa project, and downloaded the files, and followed the instructions provided in there. If someone needs help, because of the same problem. Contact me at mmr_85@hotmail.com

Goodluck to all of you.
 
Old 12-09-2002, 06:45 AM   #11
rwhitworth
Member
 
Registered: Dec 2002
Location: Guildford, UK
Posts: 43

Rep: Reputation: 15
I solved my problem too! Once I had worked out how to find and install "sndconfig" - which gets left out of the default Red Hat installation - it detected my card without any problem and fixed everything.
 
Old 12-09-2002, 10:15 AM   #12
billbeq
LQ Newbie
 
Registered: Dec 2002
Posts: 3

Rep: Reputation: 0
Soundcard not working with Redhat Ver. 8.0

I tried using sndconfig and it was not installed with the default RD install packages. How do you install sndconfig?
Thanks, Bill
 
Old 12-09-2002, 10:52 AM   #13
mmr_85
LQ Newbie
 
Registered: Nov 2002
Distribution: Redhat 9
Posts: 25

Original Poster
Rep: Reputation: 15
It is an rpm in one cd, I think it is #3, go to redhat/rpms and search for sndconfigblabla.rpm But I dont think its gonna make something, I isntalled it, detected my soundcard, but it told me that the soundcard was not detected, but the ALSA has been developing some drivers, so I went to the page of the alsa, and Isntalled it with the isntructions provided for my soundcard.

good luck
 
Old 12-09-2002, 02:06 PM   #14
billbeq
LQ Newbie
 
Registered: Dec 2002
Posts: 3

Rep: Reputation: 0
Thumbs up Thanks! sndconfig did the trick and some packages

I solved the problem of having no sound by:

1. I added all the packages for kernels and everything else my computer showed as not yet being installed after I entered Gnome Menu -System settings - packages

2. I then relogged in as "root".

3. Then I opened my terminal from Gnome Menu -System Tools - Terminal
and entered "whereis sndconfig".

4. Once I saw the directory path to the file I copied and pasted it and ran it!
The first soundcard I had was a PCI - Vortex and sndconfig said it was not supported by Redhat even though it was recognized. So I plugged in another card which was a ISAPNP - AWE64 Sound Blaster card and restarted the computer which installed it for me and removed the old sound card settings on startup.

5. Then I went into sndconfig, as mentioned above, and it recognized and installed all the settings for the AWE64 card. It runs great now!

All the advice here in this thread put me on the right path. Thank you! Now if I can just get my CD-R to burn but that is another story
Bill
 
Old 12-09-2002, 06:17 PM   #15
mmr_85
LQ Newbie
 
Registered: Nov 2002
Distribution: Redhat 9
Posts: 25

Original Poster
Rep: Reputation: 15
cool, now it works for you, well it is easy to replace the soundcard, but I installed all as the alsa saud, but I installed the kernel sources and the development packages, and follow all what the alsa page said about my soundcard.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RedHat 9.0 Sound Problem perry Red Hat 0 07-04-2004 08:37 AM
Sound problem under RedHat 9 Karybdde Linux - Hardware 3 04-06-2004 07:00 PM
redhat 9 sound problem Pete Dogg Red Hat 2 12-01-2003 02:09 AM
Switching from RedHat vincebs Mandriva 5 11-20-2003 09:10 PM
Sound problem in Redhat 8.0 jambeck Linux - Hardware 7 10-20-2002 08:38 PM


All times are GMT -5. The time now is 01:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration