LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Sound plays about 1 second then stops (http://www.linuxquestions.org/questions/linux-hardware-18/sound-plays-about-1-second-then-stops-428505/)

ssenuta 03-25-2006 07:59 PM

Sound plays about 1 second then stops
 
I installed a new asus A8V-MX motherboard with onboard sound which alsamixer lists as Card: VIA 823x rev70 Chip: Realtek ALC655 rev 1. I also compiled a new linux kernel-2.6.16 with alsa module support and ran alsaconf to configure sound with the snd-via82xx module.

Xmms will & aplay will briefly play a sound file and then stop with no error messages. I can move the Xmms slider bar and when I release it a different segment of the sound file will be heard for a brief moment.

Here is a list of things I tried to solve this problem:

1.) dxs_ support= [0 thru 5] (in modprobe.conf)
2.) Ac97_quirk=0 (in modprobe.conf)
3.) Pnp O/S disabled in bios
4.) turned acpi off (noacpi & acpi=off)
5.) gave via8237 exclusive use of irq 18 (disabled all usb controllers in bios)
6.) multi-boot to kernels 2.6.9, 2.6.13-1, 2.6.15.6 (using their snd-via82xx module)
7.) installed different alsa rpm pkgs:
(eg.) libalsa2-1.0.10-6mdk, alsa-utils-1.0.10-2mdk, alsa-data-1.0.10-6mdk
Here is a what the lspci -v cmd says:

00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235 AC97 Audio Controller (rev 70)
Subsystem: Asustek Computer, Inc.: Unknown device 81b9
Flags: bus master, medium devsel, latency 0, IRQ 18
I/O ports at d400 [size=256]
Capabilities: [c0] Power Management version 2
Note: irq 18 is shared with a two of my usb controllers according to the
/proc/interupts file & is sometimes listed as VIA8237 here depending
on my modprobe.conf dxs_support= option. Currently dxs_support=2 is
being used and /proc/interupts is showing:

(eg.) 18: 44 IO-APIC-level uhci_hcd:usb2, ehci_hcd:usb5, VIA8233A

I hope you can help me solve this sound problem. I don't know what else I can do. My sound was working just fine with kernel-2.6.13-1 before my e-machine motherboard failed.


All times are GMT -5. The time now is 09:33 PM.