LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 11-04-2004, 12:18 PM   #1
Gamezace
Member
 
Registered: Apr 2004
Location: NOVA, VT
Distribution: gentoo
Posts: 88

Rep: Reputation: 15
Sound is very high pitched


Well I got my sound all up and running with ALSA - and started playing some music off of my windows partition...and noticed something interesting.

All the pitches are sky high. The guitars sound like banjos. Mark from Blink 182 sounds like Tom. And techno sounds like it was made with those lose chinese strum-things.

How would I go about fixing the pitch settings for my machine? And if its just an equalizer problem, which I'm sure some of you will suspect, what Hz should I fix? I have toyed with it for hours, and I can't seem to find the right settings (if that indeed, is the problem).

Any ideas?

Thanks!

Sarge-Debian
AMD64 3400+
2GB RAM
AC'97 VIA82xx sound
Radeon 9700
 
Old 11-04-2004, 12:29 PM   #2
leadazide
Member
 
Registered: Apr 2004
Location: Germany
Distribution: SuSE 11.0, Ubuntu 7.10
Posts: 390

Rep: Reputation: 30
there's something wrong with sample rate
please post your asound.conf
 
Old 11-04-2004, 12:38 PM   #3
Gamezace
Member
 
Registered: Apr 2004
Location: NOVA, VT
Distribution: gentoo
Posts: 88

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by leadazide
there's something wrong with sample rate
please post your asound.conf
I don't seem to have that file...

Code:
lljkzace:/home/gamezace# locate asound.conf
lljkzace:/home/gamezace# locate asound
/usr/lib/libasound.so.2
/usr/lib/libasound.so.2.0.0
/usr/share/doc/jackd/examples/asound.rc
/usr/share/doc/libasound2
/usr/share/doc/libasound2/changelog.Debian.gz
/usr/share/doc/libasound2/copyright
/usr/share/doc/libasound2/NEWS.Debian.gz
/usr/src/alsa/alsa-driver-1.0.7rc2/alsa-kernel/include/asoundef.h
/usr/src/alsa/alsa-driver-1.0.7rc2/alsa-kernel/include/asound_fm.h
/usr/src/alsa/alsa-driver-1.0.7rc2/alsa-kernel/include/asound.h
/usr/src/alsa/alsa-driver-1.0.7rc2/utils/alsasound
/usr/src/alsa/alsa-driver-1.0.7rc2/utils/alsasound.in
/usr/src/alsa/alsa-driver-1.0.7rc2/utils/alsasound.posix
/usr/src/alsa/alsa-driver-1.0.7rc2/utils/alsasound.posix.in
/var/cache/apt/archives/libasound2_1.0.6-3_i386.deb
/var/lib/dpkg/info/libasound2.list
/var/lib/dpkg/info/libasound2.md5sums
/var/lib/dpkg/info/libasound2.postinst
/var/lib/dpkg/info/libasound2.postrm
/var/lib/dpkg/info/libasound2.shlibs
lljkzace:/home/gamezace#
 
Old 11-04-2004, 04:10 PM   #4
leadazide
Member
 
Registered: Apr 2004
Location: Germany
Distribution: SuSE 11.0, Ubuntu 7.10
Posts: 390

Rep: Reputation: 30
that's not so bad
try mine
create a file in /etc/asound.conf (as a superuser) and paste this


pcm.my_card {
type hw
card 0
mmap_emulation true
}

pcm.dmixed {
type dmix
# any unique number here
ipc_key 313
slave {
pcm "hw:0,0"
# these settings may require tweaking for different sound
# cards; this is for the Powerbook's built-in snd-powermac
# probably not required at all for well-behaved cards...
# period_time 0
# period_size 1024
# buffer_size 8192
# mentioning rate fixes wrong speed/pitch in native ALSA stuff
rate 44100
}
}

ctl.asymed {
type hw
card 0
}

pcm.dsnooped {
type dsnoop
ipc_key 2048
slave {
pcm "my_card"
# rate 48000
# period_size 128
}
}

pcm.asymed {
type asym
playback.pcm "dmixed"
capture.pcm "dsnooped"
}

pcm.pasymed {
type plug
slave.pcm "asymed"
}

pcm.dsp0 {
type plug
slave.pcm "asymed"
}

pcm.!default {
type plug
slave.pcm "asymed"
}

ctl.mixer0 {
type hw
card 0
}

ctl.!default {
type hw
card 0
}



 
Old 11-04-2004, 04:20 PM   #5
Gamezace
Member
 
Registered: Apr 2004
Location: NOVA, VT
Distribution: gentoo
Posts: 88

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by leadazide
that's not so bad
try mine
create a file in /etc/asound.conf (as a superuser) and paste this

(removed for space)

[/FONT]
Alright, I created the file. Don't I have to set my drivers to use it now or something? How do I go about that?

Thanks!
 
Old 11-04-2004, 10:31 PM   #6
Gamezace
Member
 
Registered: Apr 2004
Location: NOVA, VT
Distribution: gentoo
Posts: 88

Original Poster
Rep: Reputation: 15
Can you followup as to what I do with that code?
 
Old 11-05-2004, 08:06 AM   #7
leadazide
Member
 
Registered: Apr 2004
Location: Germany
Distribution: SuSE 11.0, Ubuntu 7.10
Posts: 390

Rep: Reputation: 30
/etc/asound.conf is a global configuration file for ALSA library. It will be detected automatically, you don't have to restart sound. Just create file and save it.


It enables Dmix software mixing plugin on output 0
(if you have creative live! or better sound card you can replace 'type dmix' with 'type hw <enter> card 0' and remove all dmix/dsnoop/asym stuff



pcm.dmixed {
type dmix
# any unique number here
ipc_key 313
slave {
pcm "hw:0,0"
# these settings may require tweaking for different sound
# cards; this is for the Powerbook's built-in snd-powermac
# probably not required at all for well-behaved cards...
# period_time 0
# period_size 1024
# buffer_size 8192
# mentioning rate fixes wrong speed/pitch in native ALSA stuff
rate 44100
}
}


Take a look on the last two lines - this should fix the pitch problems.
 
Old 11-05-2004, 12:40 PM   #8
Gamezace
Member
 
Registered: Apr 2004
Location: NOVA, VT
Distribution: gentoo
Posts: 88

Original Poster
Rep: Reputation: 15
Hm, alright - well I have created the /etc/asound.conf file, and pasted in the code above. Unfortunatly, I am still having the same problem.

Any other ideas?
 
Old 11-06-2004, 10:10 AM   #9
leadazide
Member
 
Registered: Apr 2004
Location: Germany
Distribution: SuSE 11.0, Ubuntu 7.10
Posts: 390

Rep: Reputation: 30
pcm.!default {
type plug
slave.pcm "asymed"

--> try to paste here
rate 44100
}

if it doesn't work, try rate 48000 (change it in pcm.dmixed and here)
 
Old 11-06-2004, 02:18 PM   #10
Gamezace
Member
 
Registered: Apr 2004
Location: NOVA, VT
Distribution: gentoo
Posts: 88

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by leadazide
pcm.!default {
type plug
slave.pcm "asymed"

--> try to paste here
rate 44100
}

if it doesn't work, try rate 48000 (change it in pcm.dmixed and here)
You, my friend, are a genius. Thank you so much!

Edit: That means it worked.
 
Old 11-07-2004, 10:10 AM   #11
leadazide
Member
 
Registered: Apr 2004
Location: Germany
Distribution: SuSE 11.0, Ubuntu 7.10
Posts: 390

Rep: Reputation: 30
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Flash player interrupted, high-pitched sound Artik Debian 1 05-20-2005 08:06 AM
monitor emits high pitched scream Frybyte Linux - Hardware 4 04-06-2005 09:46 AM
Weird, high pitched noise upon rebooting. Slovak Linux - Hardware 2 11-29-2004 10:40 PM
ALSA problem - High pitched sound Phantomas Linux - General 0 03-18-2004 11:06 PM
Sound latency too high stepse Linux - Hardware 0 09-23-2003 12:05 PM


All times are GMT -5. The time now is 01:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration