LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Sound in openSUSE extremely quiet (http://www.linuxquestions.org/questions/linux-hardware-18/sound-in-opensuse-extremely-quiet-772057/)

VerticalHorizon 11-28-2009 03:54 AM

Sound in openSUSE extremely quiet
 
I just installed openSUSE the other day on a partition on an external hard drive and the audio is extremely quiet. I have to turn my speakers up all the way in order to hear stuff and even then the audio is kinda distorted and still pretty low. I have PCM, Master, and Speaker turned up all the way in KMixer and Alsamixer (I've heard people talking about a channel called, "Front" but I don't have it.)

I'm really new to Linux so if you could treat me like so I'd appreciate it haha. Will give any info you need.

Here is some basic information to start.

http://www.alsa-project.org/db/?f=0f...c74196a4ee5710

alsa-utils-1.0.21-3.1.i586
alsa-oss-1.0.17-25.2.i586
alsa-1.0.21-3.2.i586
alsa-plugins-1.0.21-3.3.i586

libxine1-pulse-1.1.16.1-7.6.i586
libpulse0-0.9.19-2.3.i586

libasound2-1.0.21-3.2.i586

Linux linux-i04s 2.6.31.5-0.1-desktop #1 SMP PREEMPT 2009-10-26 15:49:03 +0100 i686 i686 i386 GNU/Linux

options snd slots=snd-hda-intel
# u1Nb.sYhCI1EfSbC:82801G (ICH7 Family) High Definition Audio Controller
alias snd-card-0 snd-hda-intel

repo 11-28-2009 04:09 AM

Try tu run
Code:

alsamixer
in a terminal
and adjust the volume

VerticalHorizon 11-28-2009 04:16 AM

Quote:

Originally Posted by VerticalHorizon (Post 3772118)
I have PCM, Master, and Speaker turned up all the way in KMixer and Alsamixer

I did.

business_kid 11-28-2009 04:29 AM

after setting the mixer, the next command should be

alsactl store
Check your card manufacturer, and mail on Suse lists to ask what soundcards their snd_hda_intel is configured for. All the makor chip manufacturers do one(intel, amd realtek, via, etc.), and there's a menu in the kernel config to select support for them

VerticalHorizon 11-28-2009 12:10 PM

I just reinstalled openSUSE and chose GNOME this time, and now the sound mixer is showing my card as, "Internal Audio 1 output Analog Stereo Output" And trying to start Alsamixer returns this:

linux-4civ:/home/VerticalHorizon # alsamixer
ALSA lib pulse.c:229: (pulse_connect) PulseAudio: Unable to connect: Connection refused

cannot open mixer: Connection refused

EDIT: I was just (barely) listening to some music and boom, audio is now completely gone.

I opened PulesAudio volume control and the little noise indicator is bouncing and showing signs of sound, but I hear nothing.

business_kid 11-29-2009 04:06 AM

Quote:

Originally Posted by VerticalHorizon (Post 3772523)
linux-4civ:/home/VerticalHorizon # alsamixer
ALSA lib pulse.c:229: (pulse_connect) PulseAudio: Unable to connect: Connection refused

cannot open mixer: Connection refused

That's pretty fatal. If root can't find the mixer, something serious is wrong. Is something else hogging the mixer?


All times are GMT -5. The time now is 01:02 AM.