Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 07-11-2006, 09:44 PM   #1
LQ Newbie
Registered: Mar 2006
Location: Oregon
Distribution: SuSE 10.0
Posts: 7

Rep: Reputation: 0
Sound Drivers not working in Ubuntu

when i started Ubuntu, the sound worked fine. then after i switched kernals to a kernal more friendly to my Intel Celeron D 325.

anywho, the sound stopped working, the volume control panel that i have says that no correct driver is found.

the laptop im on is a Toshiba Satellite A65-S1362, the sticker on the laptop says its an SRS sound system. im not sure if thats the onboard crap speakers, or the soundcard thats in the laptop.

im running Ubuntu 6.06
any help in fixing this problem will be greatly appriciated.
Old 07-13-2006, 07:31 AM   #2
LQ Guru
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
If you don't want to switch your kernel (again) nor recompile it yourself, your only option is to locate the driver or kernel module. If you got a driver, install it using the instructions provided with it; if you're looking for a kernel module, here's how it happens:

modprobe -l | less
# Now look for a module filename that sounds
# familiar and might suite your soundcard..
# If/when you find it, remember the modulename
# (filename without the .xx in the end). Press q
modprobe <modulename you just found>
Then simply retry if it works. Modules that you have currently loaded into your kernel can be seen via

Old 07-29-2008, 06:12 AM   #3
LQ Newbie
Registered: Jul 2008
Posts: 1

Rep: Reputation: 0

Had the same problem, this is how i did it

I thinks it's worth a try.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
sound not working, but detected in ubuntu kazuya1977 Ubuntu 3 03-05-2007 09:26 AM
ATI drivers not working on Ubuntu 6.06 eMcJagger Linux - Hardware 5 06-20-2006 07:20 PM
Sound not working on Ubuntu version 5.4 Zealeris Linux - Hardware 2 06-02-2006 02:46 PM
5.1 sound not working on suse 9.3 and ubuntu 5.04 shellshock Linux - Software 9 05-08-2006 06:53 PM
Sound not working properly in Ubuntu Icetec Linux - Hardware 1 04-16-2005 12:28 AM

All times are GMT -5. The time now is 01:44 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration