LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 03-09-2004, 09:50 AM   #1
spurgeonb
LQ Newbie
 
Registered: Mar 2001
Distribution: FC4 / Knoppix / Debian
Posts: 22

Rep: Reputation: 15
Sound Driver - Asus (AMD) - A7V266-MX (Via Chipset) on FC1


Hi!

I've installed FC1 (PCQ Linux 2004) on an AMD Athlon XP 2000+ / Asus A7V266-MX (Via Chipset) motherboard that has on board audio. While linux was able to detect the sound card, it however doesnt work and throws up the following error in /var/log/messages


kernel: Via 686a/8233/8235 audio driver 1.9.1-ac3
kernel: PCI: Found IRQ 5 for device 00:11.5
kernel: PCI: Sharing IRQ 5 with 00:0a.0
kernel: PCI: Sharing IRQ 5 with 00:10.2
kernel: via82cxxx: Six channel audio available
kernel: ac97_codec: AC97 Audio codec, id: ADS112 (Unknown)
kernel: via82cxxx: board #1 at 0xE400, IRQ 5
modprobe: modprobe: Can't locate module sound-service-0-0
modprobe: modprobe: Can't locate module sound-slot-1
modprobe: modprobe: Can't locate module sound-service-1-0
modprobe: modprobe: Can't locate module sound-slot-1
modprobe: modprobe: Can't locate module sound-service-1-0


Could some one guide me on any urls / drivers / guides for this?

Thanks!
 
Old 03-09-2004, 11:48 AM   #2
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
Did you turn on acpi support as the motherboards specifications tell you to?
 
Old 03-10-2004, 08:12 AM   #3
spurgeonb
LQ Newbie
 
Registered: Mar 2001
Distribution: FC4 / Knoppix / Debian
Posts: 22

Original Poster
Rep: Reputation: 15
Hi Caeda,

Thanks!

I had turned of acpid thinking its redundant. Would check it out..

thanks once again!
 
Old 03-13-2004, 08:54 AM   #4
spurgeonb
LQ Newbie
 
Registered: Mar 2001
Distribution: FC4 / Knoppix / Debian
Posts: 22

Original Poster
Rep: Reputation: 15
Unhappy Problem NOT solved!

Hi!

I checked acpid and related stuff.

It is on but still sound wouldnt work.!

And the funniest thing I noticed is sound is working only on xmms-1.2.10-1, and the wierdest thing to me is, xmms gives sound *output* thru *mic* !!!

Since I have a dual boot system, under Win* sound comes thru the actual speaker socket, but under lin (only on xmms) sound comes thru mic!!

any clues?

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can not Install Linux on AMD 64 + ASUS K8N(nForce 3 250 Chipset) utkal75 Linux - Hardware 6 05-03-2005 01:58 AM
Sound problem with ASUS A7V8X-X chipset KT400 mentallysilent Mandriva 30 06-24-2004 09:07 AM
how can i get sound driver for my a7v266-mx(asus,soundmax)in REDHAT lakshminarayan Linux - Software 1 06-06-2004 07:00 AM
No sound in Asus A7V266-MX motherboard with Slackware 9.1 rsamurti Slackware - Installation 2 05-04-2004 12:21 AM
New to linux; How to install Asus A7V266-E Sound Driver bohemien Linux - Hardware 2 01-29-2004 01:29 AM


All times are GMT -5. The time now is 06:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration