LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Sound don't plays continually (http://www.linuxquestions.org/questions/linux-hardware-18/sound-dont-plays-continually-378084/)

Klaus Paiva 10-29-2005 12:50 PM

Sound don't plays continually
 
Hello,
I've installed Kubuntu on my PC and I'm having some sound problems.

Note: I already used the system with the sound perfectly various time but, now, the system isn't acting very well...

I'm using XMMS to play some .pls and, the audio don't plays continually, it's play some time and stop 1 second, plays and stops again... (and it happens with any player)

I don't know if helps but, my /proc/interrupts follows:

Code:

          CPU0
  0:    3410847          XT-PIC  timer
  1:      4110          XT-PIC  i8042
  2:          0          XT-PIC  cascade
  5:      45672          XT-PIC  eth0
  7:          1          XT-PIC  parport0
  8:          1          XT-PIC  rtc
  9:          1          XT-PIC  acpi
 10:      34630          XT-PIC  Intel 82801AA-ICH
 11:          0          XT-PIC  uhci_hcd:usb1
 12:      48684          XT-PIC  i8042
 14:      15948          XT-PIC  ide0
 15:      29866          XT-PIC  ide1
NMI:          0
LOC:          0
ERR:          0

Thanks!

ciotog 10-30-2005 10:55 AM

If they're mp3 files you're playing, open XMMS preferences, then select the MPG Layer 1/2/3 Player plugin and choose Configure. Click on the Streaming tab and try increasing the pre-buffer % (mine's at 25). If the buffer size is very low (say lower than 128kb) you could increase that as well. For oggs the buffering settings are on the streaming tab.

You should also make sure DMA is enabled for the drive where the music files are, like so (assuming files are on hda):
Code:

# hdparm /dev/hda


All times are GMT -5. The time now is 07:25 PM.