LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Sound does not work with Ubuntu 8.10 new install (http://www.linuxquestions.org/questions/linux-hardware-18/sound-does-not-work-with-ubuntu-8-10-new-install-720270/)

jim23 04-19-2009 05:43 PM

Sound does not work with Ubuntu 8.10 new install
 
Hi
I am unable to get my speakers to work with Ubuntu 8.10.
I speak over 6 hours reading posts on line, checking the obvious:
a. not muted
b. volume up
c. looking at settings in the Volume control
d. Went to System -> Preferences -> Sound and Tested all possible settings
e. Right clicked the speaker and checked all the preferences

Still no sound at all. I had sound before on this computer when I had XP installed. Then once for about 10 seconds the sound worked when trying to adjust settings, but I could not get the sound back.

The sound card is: Creative SB Audigy 2 ZS. The computer is a Dell 9100

I read other posts where someone asks for more information after running commands, below is what I get on my computer:

cat /proc/asound/card0/codec#* | grep -i codec
Codec: SigmaTel STAC9221 A1

lspci |grep Audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)

I would appreciate any suggestions. I am somewhat new to Linux but have a fair amount of computer experience, but still am having problems.
Thanks,
Jim.

bergman 04-19-2009 06:18 PM

Jim, on some creative cards (mine included), '00' in the alsamixer software actually mutes the card, while 'M' gives sound.

Play a sound file in your player, then open a terminal and type 'alsamixer', scroll along untill you find mute, then hit the 'M' key a few times, which will toggle mute on and off.

jim23 04-19-2009 07:55 PM

The only mute button that I can locate is for the Speaker icon located on the Panel across the top of the Desktop -- next to the Date/Time. It is not muted. I did open up the Alsa Mixer (Applications -> Sound & Video -> ALSA Mixer) I don't see any mute in the options, but I am having problems getting the window resized to stay one size. As soon as I click in the window of the program it resizes and covers both of my dual monitors, and clicking again resizes it back to one monitor. I have used Windows OS's going back to Win95, and this app seems buggy. I can't resize the window by dragging a corner like other apps.

Any other suggestions?? Is your ALSA Mixer this way when trying to resize it? I rebooted, changed the settings under PROG -- upper right corner, I have right clicked the icon on the task bar, chose resize, maximize, minimize, move, all without getting control of this window. None of the other apps in Ubuntu behave like this.

Your help is appreciated.

jschiwal 04-19-2009 08:11 PM

A) Are you a member of the sound group
B) Run "alsaconf". It may install needed drivers. Then rerun Ubuntu's sound setup.

C) 1. If you use pulse audio, check if the avahi-daemon process is running
C) 2. Press "F2" and enter the command "pulseaudio --start". It will start the daemon if it isn't running.

D) Sometimes if you log out and log in again, sound will return.

jim23 04-19-2009 08:21 PM

Update:
I ran: alsamixer -V all -c 0 at the command prompt, and this gave me a control panel and after adjusting for a while, I now have sound. THANKS!!! I don't think it was a mute, but after making enough changes the sound is working and i can adjust with the Master volume.

I now have to find the screen that I saw earlier where I can setup 5.1 surround sound for all of my speakers. If you know where that is, please feel free to suggest. Off to bed for now, and another project for another day.

Your suggestion to use the command line worked much better than the GUI from the Menu.

Thanks, again.
Jim.

jim23 04-19-2009 08:26 PM

I just read your post about: running alsaconf as it may install needed drivers. I just got this to work just before reading your post. I will copy it and keep it in case i need it in the future. I have sound, but need to figure out how to get it to all speakers. I recall a setting somewhere for 5.1 and tomorrow i will look for that setting. Thanks for your time and suggestions.
Jim.

bergman 04-20-2009 04:38 AM

Quote:

Originally Posted by jim23 (Post 3514541)
alsamixer -V all -c 0

nice :)

Quote:

Originally Posted by jim23 (Post 3514541)
command line worked much better than the GUI from the Menu.

I find that in most situations it is much simpler and more efficient to use the commandline to run programs (referencing the programs associated man page).

Thinking about your above comment Jim, maybe you would be more suited to a slackware type system, where you get sys admin work done via the commandline. I know I couldnt use a gui based admin system, it would drive me nuts (although I do still use a graphical desktop for everyday use, browsing the web etc).

Just a thought :)

jim23 04-21-2009 04:17 AM

Quote:

Originally Posted by bergman (Post 3514851)
nice :)



I find that in most situations it is much simpler and more efficient to use the commandline to run programs (referencing the programs associated man page).

Thinking about your above comment Jim, maybe you would be more suited to a slackware type system, where you get sys admin work done via the commandline. I know I couldnt use a gui based admin system, it would drive me nuts (although I do still use a graphical desktop for everyday use, browsing the web etc).

Just a thought :)

Moving from Ubuntu to a slackware type system maybe something I should consider, and soon. I just installed Ubuntu about 3 or 4 weeks ago on my primary computer and I am still getting things setup the way I want. What slackware type systems would you recommend? Have you found one that you prefer where it is most compatible with Hardware and good resources on line for trouble shooting? I appreciate your suggestions and taking the time to suggest another distro. I like the idea and will explore this more. Thanks!!


All times are GMT -5. The time now is 07:50 AM.