LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 04-23-2008, 02:01 PM   #1
Sammi.jo
LQ Newbie
 
Registered: Apr 2008
Posts: 1

Rep: Reputation: 0
[SOLVED] Sound card VIA - totally stumped


I've x-posted this to Ubuntuforums, too.

I'm using Ubuntu 8.04 and have a VIA sound card. I had sound working up until recently when I restarted my computer, then I just had NONE!

I've tried purging and reinstalling alsa to no avail, and I've got this when I do lspci -v

Quote:
04:01.0 Audio device: VIA Technologies, Inc. VIA High Definition Audio Controller (rev 10)
Subsystem: Unknown device 1e40:1509
Flags: bus master, fast devsel, latency 0, IRQ 10
Memory at c9100000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
1) what does the access denied bit mean? Do I need access for this to work? How would I do it?

2) If I don't need access, can anybody please help me fix this?

Like I said - I had sound on recently, and it's worked with Gutsy too.

Kernel: 2.6.24-16-386


Big thanks in advance to anybody who can help!

SOLVED WITH sudo apt-get install linux-386

Last edited by Sammi.jo; 04-23-2008 at 03:14 PM. Reason: [SOLVED]
 
Old 04-24-2008, 09:34 AM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1
Posts: 4,839

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
From the driver matrix on the ALSA site, it looks like this is the driver that needs to be loaded for audio to work. http://www.alsa-project.org/main/ind...dule-hda-intel

Is it loaded?

To find out, from a konsole, as root, run the command 'lsmod | grep snd' ( without the quotes ) and see if you have the alsa stuff loaded. If it is not there, you will have silence.

Use modprobe sounndcore of soundcore is not there, then modprobe nameofdrivertoload to load the driver. Check the mixer, no muting, turn up volume.
 
  


Reply

Tags
sound, via


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how do I stop monitor, keyboard and mouse? totally stumped! andyroles Linux - Networking 6 06-27-2006 06:02 PM
How do I totally disable my sound card? max_croft Linux - Hardware 7 11-20-2005 01:34 PM
sound totally messed up djlosch Linux - Hardware 8 09-02-2004 09:24 PM
Totally newbie DWL-120 + USB wireless card Linox Linux - Wireless Networking 1 09-18-2003 03:39 PM
stumped by sound AC97 bigjohn Linux - Hardware 58 11-05-2002 10:36 AM


All times are GMT -5. The time now is 10:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration