LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Sound card recognition problem in rh9 (http://www.linuxquestions.org/questions/linux-hardware-18/sound-card-recognition-problem-in-rh9-108189/)

Pathian 10-24-2003 10:28 PM

Sound card recognition problem in rh9
 
I set up rh9 on my mlaptop and I've been very happy with it for the past few weeks. But just recently I've been having sound card trouble, when I reboot, I have no sound, and when I try to play a sound file with XMMS, I get a message that my sound device is either busy or not detected, then I open my volume controls in KDE, alter the volume settings a bit and replay the mp3 and it works and my sound is back. However, for some reason now the "volume" panel in KDE controls my PC speakers, but have no effect on headphones, I need to alter PCM and/or PCM2 to adjust the volume on headphones. I actually first noticed the problem while using gAIM, I noticed that I was no longer recieving chimes when I recieved and IM though my preferences were set so that I should have. I had always set my sound type to ESD, but now I can only get sound when I set it to Automatic, and when I go to KDE control panel under Information and go to Sound, it says there is "no information available about soundcard!" When I run the soundcard detection it says my sound device is from vendor: Intel Corp. Model: 82801DB AC'97 Audio module:i810_audio. This really isn't a critical problem for my system since I can re-enable my sound by going through the procss I described, but its a hassle to do that every time I reboot, does anyone have any idea on what I can configure to make things work?

adz 10-25-2003 01:58 AM

You could set up a script that adjusts the volume at start up. It's a band aid solution but it might work. Do you use a window manager? Do you have aumix (or some other commandline capable mixer app)? Add some variant of the line "aumix -v 80 -c 80 -p 80 -w 80 -W 80" to your window manager's start up script. See if that works.


All times are GMT -5. The time now is 07:25 AM.