LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 01-27-2007, 02:30 AM   #1
beachboy2
Member
 
Registered: Jan 2007
Distribution: various Linux
Posts: 212
Blog Entries: 1

Rep: Reputation: 44
Solved-"xine was unable to initialize any audio drivers"


I am using openSUSE 10.2 but I think that this general procedure will work with other Linux operating systems.

If you received the dreaded "xine was unable to initialize any audio drivers" message please do the following.

First, go to yast, select Hardware, then Sound and make sure that your sound card/audio controller is configured and any other one is deleted. You have probably done this already and everything is ok.
This is insufficient on its own. You must add audio to your user name. Weird isn't it?

Second, go to yast again, select "Security & Users" then select "User Management".
Make sure that the "Users" option is selected and not "Groups".
Click on Edit which takes you to "Existing Local User".
Click on "Details".
Under "Groups", check/tick the box for "audio" for your user name.
Click on Accept, exit and reboot.
I hope this works for you. It did for me.

Last edited by beachboy2; 01-27-2007 at 02:32 AM.
 
Old 01-27-2007, 06:28 AM   #2
rjwilmsi
Member
 
Registered: Mar 2005
Location: UK
Distribution: opensuse 12.2 x86_64
Posts: 563

Rep: Reputation: 38
Good info there. I had this occur when I upgraded the KDE packages to factory last week. A reboot fixed it all though, no need to change settings.
 
Old 02-15-2007, 07:38 AM   #3
voinovpa
LQ Newbie
 
Registered: Feb 2007
Posts: 1

Rep: Reputation: 0
But how permit non-local users to audio group?

I have the same situation, but for NON-LOCAL users - users logins in SUSE by ActiveDirectory accounts. So your way to solve problem doesn't works, because there are not a local users.

These users get uid=10000 and id like:
uid=10000(DOMAIN/username) gid=10001(DOMAIN/Domain users) groups=10001(list of domain groups, no one local)

Anybody know, how to add AD users to local audio group or some else way to allow their to access audio drivers?

Thanks a lot...

Last edited by voinovpa; 02-15-2007 at 02:07 PM.
 
Old 02-17-2007, 03:38 PM   #4
rockatansky
LQ Newbie
 
Registered: Sep 2005
Distribution: Suse 10.1 Ubuntu 6.06
Posts: 7

Rep: Reputation: 0
Excellent work. I just knackered my whole amarok setup then read this post. The thing is, Kaffeine worked fine all the time.

I love Linux. But sometimes it doesn't half weird me out.
 
Old 03-14-2007, 09:13 AM   #5
starkind
LQ Newbie
 
Registered: Mar 2007
Posts: 2

Rep: Reputation: 0
Thanks this really worked

Quote:
Originally Posted by beachboy2
I am using openSUSE 10.2 but I think that this general procedure will work with other Linux operating systems.

If you received the dreaded "xine was unable to initialize any audio drivers" message please do the following.

First, go to yast, select Hardware, then Sound and make sure that your sound card/audio controller is configured and any other one is deleted. You have probably done this already and everything is ok.
This is insufficient on its own. You must add audio to your user name. Weird isn't it?

Second, go to yast again, select "Security & Users" then select "User Management".
Make sure that the "Users" option is selected and not "Groups".
Click on Edit which takes you to "Existing Local User".
Click on "Details".
Under "Groups", check/tick the box for "audio" for your user name.
Click on Accept, exit and reboot.
I hope this works for you. It did for me.
Hi, Thanks alot.. Your solution worked brilliantly!!
 
Old 09-18-2007, 01:24 PM   #6
dAnIK SeNT
LQ Newbie
 
Registered: Jan 2006
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by voinovpa View Post
Anybody know, how to add AD users to local audio group or some else way to allow their to access audio drivers?
AD users could be added to local groups as any other users. Just edit your /etc/group file like this (considering that domain/name separator is '/' and not '\' or '+' - check your /etc/samba/smb.conf; I personally prefer '-' separator - it has the least amount of issues attached):

audio:x:17:localuser1,localuser2,DOMAIN/user1,DOMAIN/user2
 
  


Reply

Tags
active directory, audio, groups, opensuse, winbind, xine


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mplayer sound error: "Could not open/initialize audio device -> no sound" GTBlackwell Linux - Software 9 06-11-2008 02:23 PM
Proposed solution for "status" (aka "problem solved") indicator demerson3 LQ Suggestions & Feedback 12 04-08-2006 02:15 PM
xine was unable to initialize any audio-drivers sporks Suse/Novell 2 01-29-2006 09:02 AM
Error: "Unable to initialize frontend:KDE" massai Linux - Newbie 8 02-24-2004 06:40 PM
mplayer no sound " initialize audio " lonely10072003 Linux - Hardware 4 08-05-2003 01:07 PM


All times are GMT -5. The time now is 10:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration