LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Solved-"xine was unable to initialize any audio drivers" (http://www.linuxquestions.org/questions/linux-hardware-18/solved-xine-was-unable-to-initialize-any-audio-drivers-523184/)

beachboy2 01-27-2007 02:30 AM

Solved-"xine was unable to initialize any audio drivers"
 
I am using openSUSE 10.2 but I think that this general procedure will work with other Linux operating systems.

If you received the dreaded "xine was unable to initialize any audio drivers" message please do the following.

First, go to yast, select Hardware, then Sound and make sure that your sound card/audio controller is configured and any other one is deleted. You have probably done this already and everything is ok.
This is insufficient on its own. You must add audio to your user name. Weird isn't it?

Second, go to yast again, select "Security & Users" then select "User Management".
Make sure that the "Users" option is selected and not "Groups".
Click on Edit which takes you to "Existing Local User".
Click on "Details".
Under "Groups", check/tick the box for "audio" for your user name.
Click on Accept, exit and reboot.
I hope this works for you. It did for me.

rjwilmsi 01-27-2007 06:28 AM

Good info there. I had this occur when I upgraded the KDE packages to factory last week. A reboot fixed it all though, no need to change settings.

voinovpa 02-15-2007 07:38 AM

But how permit non-local users to audio group?
 
I have the same situation, but for NON-LOCAL users - users logins in SUSE by ActiveDirectory accounts. So your way to solve problem doesn't works, because there are not a local users.

These users get uid=10000 and id like:
uid=10000(DOMAIN/username) gid=10001(DOMAIN/Domain users) groups=10001(list of domain groups, no one local)

Anybody know, how to add AD users to local audio group or some else way to allow their to access audio drivers?

Thanks a lot...

rockatansky 02-17-2007 03:38 PM

Excellent work. I just knackered my whole amarok setup then read this post. The thing is, Kaffeine worked fine all the time.

I love Linux. But sometimes it doesn't half weird me out.

starkind 03-14-2007 09:13 AM

Thanks this really worked
 
Quote:

Originally Posted by beachboy2
I am using openSUSE 10.2 but I think that this general procedure will work with other Linux operating systems.

If you received the dreaded "xine was unable to initialize any audio drivers" message please do the following.

First, go to yast, select Hardware, then Sound and make sure that your sound card/audio controller is configured and any other one is deleted. You have probably done this already and everything is ok.
This is insufficient on its own. You must add audio to your user name. Weird isn't it?

Second, go to yast again, select "Security & Users" then select "User Management".
Make sure that the "Users" option is selected and not "Groups".
Click on Edit which takes you to "Existing Local User".
Click on "Details".
Under "Groups", check/tick the box for "audio" for your user name.
Click on Accept, exit and reboot.
I hope this works for you. It did for me.

Hi, Thanks alot.. Your solution worked brilliantly!!

dAnIK SeNT 09-18-2007 01:24 PM

Quote:

Originally Posted by voinovpa (Post 2631636)
Anybody know, how to add AD users to local audio group or some else way to allow their to access audio drivers?

AD users could be added to local groups as any other users. Just edit your /etc/group file like this (considering that domain/name separator is '/' and not '\' or '+' - check your /etc/samba/smb.conf; I personally prefer '-' separator - it has the least amount of issues attached):

audio:x:17:localuser1,localuser2,DOMAIN/user1,DOMAIN/user2


All times are GMT -5. The time now is 08:22 PM.