LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (http://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   smartctl testing not running/reporting (http://www.linuxquestions.org/questions/linux-hardware-18/smartctl-testing-not-running-reporting-883225/)

NirvanaII 05-28-2011 02:28 PM

smartctl testing not running/reporting
 
I'm trying to test my harddrive, but no results are coming through - running the following I hear the drive, and all reads to be well:

Code:

[stuart8.5@mepis1 Documents]$ sudo smartctl -t long /dev/sda
smartctl version 5.38 [x86_64-unknown-linux-gnu] Copyright (C) 2002-8 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

=== START OF OFFLINE IMMEDIATE AND SELF-TEST SECTION ===
Sending command: "Execute SMART Extended self-test routine immediately in off-line mode".
Drive command "Execute SMART Extended self-test routine immediately in off-line mode" successful.
Testing has begun.
Please wait 83 minutes for test to complete.
Test will complete after Sat May 28 16:31:54 2011

Use smartctl -X to abort test.

But, no matter how long, waiting out the 83 mins, or trying for an immediate result, I get the same output:

Code:

[stuart8.5@mepis1 Documents]$ sudo smartctl -l selftest /dev/sda
smartctl version 5.38 [x86_64-unknown-linux-gnu] Copyright (C) 2002-8 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

=== START OF READ SMART DATA SECTION ===
SMART Self-test log structure revision number 1
Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error
# 1  Extended offline    Completed without error      00%    11788        -
# 2  Short offline      Completed without error      00%    11783        -
# 3  Short offline      Completed without error      00%    11616        -
# 4  Short offline      Completed without error      00%    11563        -
# 5  Short offline      Completed without error      00%    11563        -
# 6  Short offline      Completed without error      00%    11563        -

Running this command on an older PC, I know that the "Remaining" percentage should decrease over time till expiration (83 mins here). Additionally, I have noticed that the 'complete time' of 16:31 is wrong, behind the actual time by 3/4 hours, but whether this is factor or not I don't know. Short testing is the same.

acid_kewpie 05-28-2011 03:00 PM

Please post your thread in only one forum. Posting a single thread in the most relevant forum will make it easier for members to help you and will keep the discussion in one place. This thread is being closed because it is a duplicate.

NirvanaII 05-28-2011 03:21 PM

That was in error when editing the subject. Apologies.


All times are GMT -5. The time now is 11:04 AM.